Problem with videocalls on WIFI

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

dani1720

Occasional Visitor
Hello,

I have a problem with calls and videocalls in whatsapp when I´m connected to the WIFI in my home. When someone calls me I hear and see them but they cannot hear me or see me. If I´m using 4G data it works fine.

I have an optic fiber internet connection and this is my hardware:

Nokia G-010G-P

Router Asus RT-AC66U B1


Any idea what could be the problem? I tried deactivating the router´s firewall but it didn´t solve he problem.
 

Trip

Very Senior Member
It could very well be bufferbloat on the WAN and/or WLAN interfaces of the AC66U. You can test to confirm at www.dslreports.com/speedtest, first with a hard-wired PC plugged into one of the Asus's LAN ports, then with a wireless device connected to the Asus's wifi. Test a few times each way, to be sure. Let us know your test results and we can go from there.
 

avtella

Very Senior Member
Is your phone using the 2.4 or 5Ghz band? I’d stick to 5Ghz as there’s less potential interference.
 

dani1720

Occasional Visitor
Is your phone using the 2.4 or 5Ghz band? I’d stick to 5Ghz as there’s less potential interference.
I tried with both 2.4 and 5Ghz and the problem is the same.
I have other access points in my building and the problem is the same from any WIFI I connect from.
It seems o be a problem only with whatsapp´s calls and videocalls. For example with Facebook messenger it works just fine.
 

avtella

Very Senior Member
Try disabling SIP-ALG in the router’s internet settings.
 

dani1720

Occasional Visitor
I think I just found a solution.
I deactivated the NAT acceleration on the router and the calls seem to work now.
What exactly is NAT acceleration and is it ok to deactivate it?
 

BreakingDad

Senior Member
Are you sure this isn't a QOS issue and/or port forwarding? Is UPNP on ? turning off NAT accel effectively will turn off QOS as well, for your speed of connection NAT accel should be on. You will notice a massive speed drop elsewhere with it off.

 

avtella

Very Senior Member
@dani1720 glad you solved the issue. I have heard in some cases CTF can do that. Only down side is your WAN throughput would be lowered significantly but disabling acceleration wouldn’t really hurt unless you had internet speeds of like 200+ Mbps.

As for CTF (Cut Through Forwarding) and FA (Flow Acceleration) that comprise NAT acceleration, is here is a great explanation by RMerlin:

@BreakingBad, Turning off NAT acceleration won’t turn off QoS. If anything it would be QoS which would conflict with NAT acceleration on older models causing it to disable Cut Through Fowarding.
 
Last edited:

Trip

Very Senior Member
Thanks for those. I presume you have a symmetric 500Mb connection? Hard-wired, your connection is completely bloat-free. Wireless, however is a different story. Judging from the level of retransmits and the high amount of jitter, if I had to guess, I'd say you're dealing with a fair amount of channel interference. If you don't already have it enabled, consider enabling auto-channel selection, or if the Asus can't do a good enough job with that, just set the channels manually to those with the least interference (you can test for these with a smartphone wifi analyzer app).
I think I just found a solution. I deactivated the NAT acceleration
Deactivating hardware acceleration (aka Broadcom CTF) is probably not the actual fix you think it is. All that is doing is altering how packets are being processed in relation to the Linux NetFilter stack, and will effect wired traffic as equally as it will wireless. Since you had perfectly good bufferbloat results with it on, I would re-enable it. This will also allow you to take full advantage of your 500Mb symmetric connection. With CTF disabled, your WAN-LAN throughput will be completely CPU-bound, resulting in much lower throughput on the wired side of things.

Judging from the wireless test results, I would venture that rebooting the router (after disabling CTF) and having the wifi re-channelize is what actually caused things to improve. I would go ahead and re-enable CTF, then reboot again (which will re-channelize wifi again) and see if wireless tests continue to test well.

If this inevitably starts happening to you again, then your ultimate solution may simply be replacement wifi, either in the form of a completely new all-in-one, or at least by disabling wifi on the AC66U and putting in a dedicated AP. Regardless of the approach, I would suggested Qualcomm-based radio hardware, which tends to have better link-layer quality and built-in AQM/SQM than the Broadcom equivalents.
 

avtella

Very Senior Member
If I'm not mistaken increased retransmits due to the way CTF/FA works in some instances may cause issues with some realtime applications/VoIP. I personally have not run into this but this isn't the first time I've seen disabling this as being a solution, albeit rare.
 

dani1720

Occasional Visitor
Thanks for all the replies.

Are you sure this isn't a QOS issue and/or port forwarding? Is UPNP on ?
I am not sure, QOS is deactivated on the router. And yes UPNP is on.

I presume you have a symmetric 500Mb connection?
It is a symmetric 600Mb connection.
As for the Wifi there are other networks around, but when I set it up I used an Wifi analyzer app to choose the channels, it is not having much interference.

I did the test again with the NAT acceleration deactivated and it gave me worse results, less speed and bad BufferBloat.

When I activate NAT acceleration and reboot the router the problem is immediately back again.

I don´t think it is a Wifi problem on my Asus router, because I have 4 more access points connected to a switch from the Asus router, some of them are set as routers and some only as access points. And the problem is the same from any of those Wifi networks. I also did a test cutting off the switch and all the other access points to see if the problem comes from there, but it didn´t solve it.
 

BreakingDad

Senior Member
@dani1720 glad you solved the issue. I have heard in some cases CTF can do that. Only down side is your WAN throughput would be lowered significantly but disabling acceleration wouldn’t really hurt unless you had internet speeds of like 200+ Mbps.

As for CTF (Cut Through Forwarding) and FA (Flow Acceleration) that comprise NAT acceleration, is here is a great explanation by RMerlin:

@BreakingBad, Turning off NAT acceleration won’t turn off QoS. If anything it would be QoS which would conflict with NAT acceleration on older models causing it to disable Cut Through Fowarding.
I got that the wrong way round, it's either NAT accel or QOS, not both together.
 

dani1720

Occasional Visitor
I think deactivating the NAT Acceleration won´t be a permanent solution because my speed is dropping.
I searched and found some posts where people had the same problem and the only solution I found was the same, deactivating NAT Acceleration.

Any idea if there is another way to solve it? Do I have to change my router?
 

avtella

Very Senior Member
Mind sharing your WAN/WiFi/QoS settings pages' images? Not sure I have any ideas but maybe someone else might see something.

Since you say multiple APs connected to this router have the same issue.. yes it's unlikely to be WiFi. Unless you enabled AirTime fairness which can lead to similar issues sometimes but as you said disabling NAT already fixed it.
 

dani1720

Occasional Visitor
Ok, here are some screenshots from my router configuration. Let me know if you need any other screenshot.
1.jpg
2.jpg
3.jpg
4.jpg
5.jpg
 

dani1720

Occasional Visitor
I also did more tests with other apps and they all work fine, Telegram, Skype, Facebook messenger. The only one with the problem seems to be Whatsapp.
 

bluzfanmr1

Senior Member
I also did more tests with other apps and they all work fine, Telegram, Skype, Facebook messenger. The only one with the problem seems to be Whatsapp.

It might help to post your settings for each band from the wireless/professional tab, though it sounds like it could be that app causing the issue.

Also, what about picking the least congested channel instead of using auto? There could be a hiccup if auto is switching channels in the middle of a call. I use WiFi Explorer Lite to keep track of what channels are congested around me.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top