Problems with ESP8266 devices using Merlin (RT-AC68U)

  • SNBForums will be unavailable for about 2 hours TOMORROW 23 January starting around 2PM EDT for a server changeover.

    All accounts and posts will be preserved.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Antonio

New Around Here
Hello everyone, first post here.

I wonder if anyone could help me out: I've been using Merling for a while now on both my RT-AC68U (one is a router with DHCP and the other set as AP) and the couple of weeks have been really odd here. After flashing 40 ESP devices, a few of them are not able to connect to my network again. I have a total of 37 wireless devices connect to my router (home automation low bandwidth esp chips), not that many.

I don't believe there is a problem with the firmware because these shows up on the logs:

Code:
Mar 28 09:15:36 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:15:48 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:15:53 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:15:58 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:16:03 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:16:17 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:16:22 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:16:27 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:16:32 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:16:39 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:16:40 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:16:49 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:16:50 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:16:53 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:17:03 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:17:05 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:17:11 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:17:15 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:17:21 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:17:24 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:17:34 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:17:34 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:17:42 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:17:44 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:17:52 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:17:58 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:18:08 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:18:18 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:18:30 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:18:38 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:18:40 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:18:48 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:18:58 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:19:01 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:19:02 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:19:11 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:19:12 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:19:19 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:19:29 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:19:32 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:19:34 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:19:42 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:19:44 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:19:50 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:20:00 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:20:03 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:20:06 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:20:13 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:20:36 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:20:47 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:20:57 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:21:03 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:21:13 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:21:21 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:21:27 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:21:31 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:21:34 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:21:37 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:21:44 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:21:50 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:22:00 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:22:05 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:22:13 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:22:15 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:22:18 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:22:20 WLCEVENTD: eth1: Assoc 5C:CF:7F:57:D3:FD
Mar 28 09:22:23 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:22:24 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:22:28 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:22:30 WLCEVENTD: eth1: Disassoc 5C:CF:7F:57:D3:FD
Mar 28 09:22:34 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:22:36 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:22:45 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:22:46 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:22:55 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:22:56 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:22:58 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:23:06 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:23:08 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:23:11 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:23:21 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:23:39 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:23:42 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:23:49 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:23:52 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:23:53 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:23:55 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:24:03 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:24:05 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:24:17 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:24:19 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:24:27 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:24:35 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:24:45 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:24:57 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:25:07 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:25:20 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:25:23 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:25:30 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:25:33 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:25:41 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:25:51 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:25:52 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:25:54 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:26:02 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:26:04 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:26:16 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:26:26 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:26:34 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:26:44 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:26:44 WLCEVENTD: eth1: Assoc 5C:CF:7F:58:3D:95
Mar 28 09:26:47 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
Mar 28 09:26:54 WLCEVENTD: eth1: Disassoc 5C:CF:7F:58:3D:95
Mar 28 09:26:57 WLCEVENTD: eth1: Disassoc 2C:3A:E8:11:74:22
Mar 28 09:27:00 WLCEVENTD: eth1: Assoc 2C:3A:E8:11:74:22
These MAC addresses are the exact devices that are unable to connect to the router. Also This shows up on the wireless log:



Any idea what those logs really means? Looks like they can authenticate with the router but cannot get an IP.

Thanks for having me here!
 

RMerlin

Asuswrt-Merlin dev
Did you disable 802.11n support? All your devices are connecting using 802.11g only, which would surprise me in 2019.
 

Antonio

New Around Here
Did you disable 802.11n support? All your devices are connecting using 802.11g only, which would surprise me in 2019.
Hello! Thanks for you reply, I really appreciate it.

You are correct. Yesterday I was searching the web for answers if the problem was my router and stumbled upon a post about ESP chips that some devices have problems connecting to N networks so I was testing the wifi settings and set to "legacy" only. This problems was happening before that, with the this setting as "auto". I've testing configurations for many days now, this was my last attempt. I will revert it back since nothing has changed.

Is there a reason why the device shows without IP address and no valid information about the speed? More importantly, this associate/disassociate repeating logs is a possible problem on my router or the device itself?

Thanks again!
 

dave14305

Part of the Furniture
What if you tested using an SSID that doesn’t contain spaces (Antonio e Roberta)?
 

Antonio

New Around Here
What if you tested using an SSID that doesn’t contain spaces (Antonio e Roberta)?
Hello sir!

My other Asus set as router has an SSID without spaces and have the same problem:



Code:
Mar 28 11:37:57 WLCEVENTD: eth1: Assoc 60:01:94:3F:06:E0
Mar 28 11:38:07 WLCEVENTD: eth1: Disassoc 60:01:94:3F:06:E0
Mar 28 11:38:23 WLCEVENTD: eth1: Assoc 48:5D:60:A2:E1:46
Mar 28 11:39:05 WLCEVENTD: eth1: Assoc B0:D5:9D:23:E9:9B
Mar 28 11:39:16 WLCEVENTD: eth1: Assoc B0:D5:9D:23:E9:9B
Mar 28 11:46:48 WLCEVENTD: eth1: Assoc B0:D5:9D:23:E9:9B
Thanks!
 
Last edited:

RMerlin

Asuswrt-Merlin dev
Is there a reason why the device shows without IP address and no valid information about the speed? More importantly, this associate/disassociate repeating logs is a possible problem on my router or the device itself?
According to the flags, those clients are failing to associate and/or authenticate. Try the usual wifi-related recommendations: disabling airtime fairness, beamforming, etc...

If a client has no A (Associated) or U (Authenticated) flag, then that client is failing to connect with your router. I see a "b" client in there for instance, these usually don't even support WPA2.
 

Antonio

New Around Here
Maybe
According to the flags, those clients are failing to associate and/or authenticate. Try the usual wifi-related recommendations: disabling airtime fairness, beamforming, etc...

If a client has no A (Associated) or U (Authenticated) flag, then that client is failing to connect with your router. I see a "b" client in there for instance, these usually don't even support WPA2.
Hello again.

These are my settings, if you could kindly take a look:





According to you last reply, looks like there a possible problem with my routers, correct?

Thanks a lot!
 

goatdog

Occasional Visitor
I notice recently that skynet firewall have default blocking IOT devices...and disable external SSH connections as soon as it detects it is enabled.... Not sure but worth looking into if you have skynet... I don't have ESP setup so can't say yea / nea..

[r] --> Reload Menu
[e] --> Exit Menu

[1-15]: 11

Select Setting To Toggle:
[1] --> Autoupdate | [Enabled]
[2] --> Banmalware | [daily]
[3] --> Debug Mode | [Enabled]
[4] --> Filter Traffic | [all]
[5] --> Unban PrivateIP | [Enabled]
[6] --> Log Invalid Packets | [Disabled]
[7] --> Ban AiProtect | [Enabled]
[8] --> Secure Mode | [Enabled]
[9] --> Fast Switch | [Disabled]
[10] --> Syslog Location | [Default]
[11] --> IOT Blocking | [Disabled]
[12] --> Stats Country Lookup | [Enabled]
 

Antonio

New Around Here
I notice recently that skynet firewall have default blocking IOT devices...and disable external SSH connections as soon as it detects it is enabled.... Not sure but worth looking into if you have skynet... I don't have ESP setup so can't say yea / nea..

[r] --> Reload Menu
[e] --> Exit Menu

[1-15]: 11

Select Setting To Toggle:
[1] --> Autoupdate | [Enabled]
[2] --> Banmalware | [daily]
[3] --> Debug Mode | [Enabled]
[4] --> Filter Traffic | [all]
[5] --> Unban PrivateIP | [Enabled]
[6] --> Log Invalid Packets | [Disabled]
[7] --> Ban AiProtect | [Enabled]
[8] --> Secure Mode | [Enabled]
[9] --> Fast Switch | [Disabled]
[10] --> Syslog Location | [Default]
[11] --> IOT Blocking | [Disabled]
[12] --> Stats Country Lookup | [Enabled]
Hello! Thanks for you reply. I don't have this firewall running. I've also disabled all features regarding network protection (firewal, A.I. Protect, and so on). Thanks!
 

RMerlin

Asuswrt-Merlin dev
These are my settings, if you could kindly take a look:
Nothing really specific coming up. Just to be safe, I would disable Universal Beamforming as well as TurboQAM - both are non-standard extensions.
 

RMerlin

Asuswrt-Merlin dev
I have a total of 37 wireless devices
What happens if you turn off some of the connected clients? Are those failing to connect now able to?

In general, it's recommended not to go over 32 clients per AP, for performance reasons. Maybe there's some low-level limitation in there.
 

Antonio

New Around Here
What happens if you turn off some of the connected clients? Are those failing to connect now able to?

In general, it's recommended not to go over 32 clients per AP, for performance reasons. Maybe there's some low-level limitation in there.
Hello.

Those problematic clients still cannot connect to the AP if less devices are connected. I tough the problem would be a limit of DHCP leases, that is why I've bumped the address reservations to about 200 IPS...

I understand there is a recommended number of maximum connected clients but those devices are used for home automation, very cheap ESP8266 chips that sends and receive bytes of data a few times a day.

Also, I've not been clear about that: those 37 ESP devices are spread over two Asus Routers, here are the clients connect to the main router:



And these for the AP:



Thank you very much for your time.
 

Antonio

New Around Here
Are your IOT devices running tasmota firmware?
Hello!

No. I am currently using ESPHome with Home Assistant API. I’m trying to discover if the problem is within my router or the Sonoff Basic.

I was using Tasmota version 6.3 with Arduino core 2.3 before changing to ESPHome.

Thanks for asking!
 

EventPhotoMan

Very Senior Member
Hello!

No. I am currently using ESPHome with Home Assistant API. I’m trying to discover if the problem is within my router or the Sonoff Basic.

I was using Tasmota version 6.3 with Arduino core 2.3 before changing to ESPHome.

Thanks for asking!
Did you get this resolved?
 

miazza

Regular Contributor
I have a simliar issue with my 86U.
I have few SonOff (BASIC and POW 2) now flashed with ESP8266 Tasmota Firmware and they connect only the first time:

- after flashing the device connects immediately and so it remains until the device is disconnected from the mains.
- after power cycle, the devices continue to connect and disonnect and fail to authenticate on the AP (on the router I can see the device connecting with its IP for 15 seconds and after that it disappears; no chance to access the device at its IP address during the 15 seconds)
- If I reboot the router, all devices connect and are stable until the next power cycle (plug removed from the wall).

Among the different try, I discovered that it seems sufficient to switch OFF and than ON the 2.4 GHz to have stable connection.

This i quite annoying because every time I unplug one device I also have to reboot the router (or the wireless service).
 

Mattias

Regular Contributor
What helped me in this issue was found in some other forum, can't remember what. But with disabling this, seems to get tasmota devices to connect really fast and without issues. So far at least... Could take sometimes an hour or 10 minutes before they could attach, and I got a lot of those traces in the first post. Anyways, try this if it helps. Disable WMM No-Acknowledgement or any those WMM stuff, but for me only that one helped. Not really sure why , but it helped. Have tried to restart them a few times and ever time they connect and not strange logs/traces.
 

Fettkeewl

New Around Here
I have a simliar issue with my 86U.
I have few SonOff (BASIC and POW 2) now flashed with ESP8266 Tasmota Firmware and they connect only the first time:

- after flashing the device connects immediately and so it remains until the device is disconnected from the mains.
- after power cycle, the devices continue to connect and disonnect and fail to authenticate on the AP (on the router I can see the device connecting with its IP for 15 seconds and after that it disappears; no chance to access the device at its IP address during the 15 seconds)
- If I reboot the router, all devices connect and are stable until the next power cycle (plug removed from the wall).

Among the different try, I discovered that it seems sufficient to switch OFF and than ON the 2.4 GHz to have stable connection.

This i quite annoying because every time I unplug one device I also have to reboot the router (or the wireless service).
Came here basically to tell you that I have the same router, though dubbed Rt-Ac2900.
I'm having the exact same issues as you do and have posted on tasmota github about it here
https://github.com/arendst/Tasmota/issues/7770
 

Mattias

Regular Contributor
For me fixed that I disabled powersaving on the devices, wifi powersave to off. I haven't had any issues since.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top