What's new
  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
I'm not sold on upgrading from my current RT-AC68U to the RT-AC5300 but got an open box one for "cheaper" and thought I'd give it a try. And I did staring at 1am last night, so probably my failure is due to lack of sleep and not finding the right entry in this forum.

Here's what I did:
1) ran the latest (nvram-save-r24a) scripts on the AC68U while the AC5300 was booting up for the first time with my laptop plugged into one of the LAN ports
2) I could login fine to and go through the steps to say No to all settings, i.e. skipping as much as possible from the Setup Wizard (it asked me tons of times if I really wanted to leave the 3 WiFi channels open!)
3) as soon as I could get to the Firmware page, I selected RT-AC5300_380.66_4.trx and hit the flash button.
4) it took its time and said I had to reboot manually. I recall something about best way to do it was to power off and on; so I did that.
5) 10 mins later I still couldn't ping although at some points before (had `ping -t` running), it was apparently responding. As far as I recall, the 3 most-left LEDs were steady green, power and WiFi 2+5 but I could not see WiFi broadcasted to connect to.
6) My past experience is that sometimes you need to reboot a few times before things settle. Surprisingly the next 2-3 reboots ended up with different LEDs on, anywhere from just the Power one, to almost all of them with the Internet one staying solid red.
7) Past 2am and I did grab the Asus Firmware Restoration tool, pointed it to RT-AC5300_3.0.0.4_380_7627-gb433db3.trx, hit the Reset with a paper clip until the power LED started blinking. At that time I could again see ping replies from so I hit the Upload button. Thought the open box router might have been a demo for too long and the firmware was too old to jump directly to Asuswrt-Merlin.
8) After about 5 minutes the router rebooted and my browser opened the standard router.asus.com page, asking me to run the Setup Wizard.
9) Again, everything worked fine as in Step 2), I was back to square one, but on the latest original firmware.
10) Again, step 3, pushed RT-AC5300_380.66_4.trx and got the same experience - it won't boot up properly, not once, not twice.... gave up after a few more power off/on and let it run like this, hoping some magic will finish while I sleep.

This morning I was back to the 3 LEDs like in Step 5 above. Did a few searches in this forums, on the web in general, mainly looking for "signed version of firmware" that perhaps I needed to flash first before jumping to Merlin's 380.66_4, any specific 30/30/30 reset that I should do..... and here I am, asking for help.... or a confirmation that I have to run back to the store and tell them they gave me a half-brick.

At the time of typing this, I've hit the Firmware Restoration tool one more time and pushed RT-AC5300_3.0.0.4_380_7743-g2cf84e9.trx (the last-1 version from ASUS' site). It flashed fine, I've setup now the 3 channels and I'm playing with the new settings (those I didn't have on the AC68U) while I'm not connected to the WAN, nor do I have any clients on this router, apart from the LAN attached laptop but everything appears to be working fine.

I flashed my first Asuswrt-Merlin on the AC68U many years ago and don't recall doing an extra step but....

Can anyone point me to the missing step?

Thanks a lot!
Quite a few people took a look but no replies. Let me provide an update after another few attempts to see that would help you help me.

I've downloaded several original firmware versions from Asus, both standard and the Beta Version
Every firmware flash using the standard Asus *.trx files succeeded, both via the GUI and the Restoration tool.

Every attempt to flash @RMerlin via the GUI got my RT-AC5300 stuck upon reboot.

What did work is flashing @RMerlin older RT-AC5300_380.63_2.trx. I picked that one just because the size of the *.trx file was much larger (44K vs RT-AC5300_380.66_?.trx ones being around 35K).

@RMerlin - apart from what's in the Changelog.txt, did anything change in terms of how the firmware gets flashed from 380.63 to 380.66?

Also, if I go back to RT-AC5300_3.0.0.4_380_7627-gb433db3.trx I could successfully flash RT-AC5300_380.67_alpha2-g925f2ea.trx (latest alpha I could find).

Does anyone have an RT-AC5300 to try full reset, flash RT-AC5300_3.0.0.4_380_7743-g2cf84e9.trx (via Restore tool?) then flash RT-AC5300_380.66_4.trx (via GUI) and see if router would complete flashing? Rebooting doesn't change anything - still only the first 3 LEDs from the left come on but neither of the WAN (not connected, with ASUS firmware it stays red) or LAN (laptop still plugged in) would come on.

When I get the Asus RT-AC5300_3.0.0.4_380_7743-g2cf84e9.trx flashed and reset the router to defaults, I can't see N/AC mixed on the 5-2 channel. I see only Legacy, N only, and auto as many users have reported on Asus forums here.

I see users stating that they forced N/AC on the 5-2 channel somehow. Are there steps that need to be done to enable this? Or it's only available on some of the @RMerlin builds?
Nothing has changed, and I haven't had any other reports either. Myself I've flashed my own AC5300 with a few different versions these past couple of months to test a few things, no issue.

Size difference is because I no longer include those useless outdated Download Master packages - they get downloaded from Asus's download servers when you install them.
@RMerlin thank you! Upon flashing one of your builds and erasing nvram, how long does it take after boot (and going through the setup wizard) before you see all 3 SSIDs? Specifically 5-2? I saw a few posts from people in UK saying they had to wait 10, even 20 minutes due to DFS. I thought I was impatient, late night, kids running around but I left the router overnight after nvram erase and only 24 and 5-1 were broadcasting the next morning.

Either way, your previous answer is enough for me to pack the router and drop it off back at BestBuy.
If you are on a DFS channel and there is a radar in your area using that frequency, you might be blocked for extended period of time. You should avoid using any DFS channel unless you have no other option.
If you are on a DFS channel and there is a radar in your area using that frequency, you might be blocked for extended period of time. You should avoid using any DFS channel unless you have no other option.
Not sure what they have in Toronto but all I did in terms of setup after erasing the NVRAM was to go over the Wizard and enter a password for the 3 default SSIDs, then I let it sit overnight. All I was seeing next morning were the 24 and 5-1 channels; the 5-2 wasn't broadcasting, not seen via inSSIDer. I went to the WiFi setting and everything was on Auto for all 3 channels, with 2.4 and 5-1 picking channels 6 and 48, if I recall correctly. I could force 2.4 and 5-1 to whatever other channel I wanted. Yet, the 5-2 was on "channel 0", had no N/AC as a setting and I could not pick any channels, 0 was the only option.

My understanding was that after a clean flash (let's say of your alpha build) and doing the minimal steps on the Setup Wizard, I should see 3 channels broadcasting, even if it took 5, 10, 20 mins for the 5-2 to show up. I consistently got only 2.4 and 5-1 with the alpha build and the older, larger build. Flashing the current 380.66_4 would never quite complete.
Canada doesn't use DFS channels. So unless you bought an European version of the router, it doesn't apply to Canada.

Radio stopping broadcasting might be a hardware issue. Try doing a complete power reset first:

1) Turn off the router
2) Unplug the power
3) Turn it on, to drain any leftover charge
4) Turn it back off
5) Plug it in
6) Turn it back on, and let it boot
I was picking up something else at the BestBuy warehouse in Mississauga when I saw 2 AC5300's demo/open box there and grabbed one. It has the /CA in the name, so it should be the Canadian version.

My first set of test was on Fri night when I came home, then I had it unplugged for a day when I got frustrated with the flashing not completing and did more test in the "basement lab" on Sat and Sun. It has been unplugged for hours at least a couple of times. What i don't recall is if I turned it off from the button before or after unplugging; even less if I had pressed the button to power it on while it was disconnected.

It's been back in the box since last Monday with the RMA attached. I was going to pass by CanadaPost some time tomorrow and ship it back, assuming it was broken. Frankly, I'm not sure I want to unpack to try your 6 steps more carefully. If you have interest in me running some more test, for whatever reason, I'll do that and send you logs or whatever might help the community. If that's of no use to anyone, I'll just ship it back.

Thanks again for your help!
To put a closer on this for someone who might stumble into my similar issues.

I went back to BB and they had another open box in the store. I swapped mine for that one, brought it home, powered it one and saw all 3 SSIDs fine. Went over the mandatory steps in the Wizard, flashed RT-AC5300_380.66_4.trx and everything worked fine.

I've been on 380.67 since last evening and so far, so good, with 50+ devices of all kinds connecting mainly fine.

I wish I had RMA-ed it sooner as Asus is not known for good QA.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!