QoS not working on latest version 386.3

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

macster2075

Senior Member
As the title says. QoS stopped working for me on v386.3. I've done several clean installs and it still doesn't work.
I've tried Adaptive and Bandwidth Limiter... nothing happens.

It appears to only work if I select Traditional QoS.

Tried turning it off/on, but still doesn't do anything. I guess I can use Traditional, but I prefer the other two.
Any suggestions?
 

SomeWhereOverTheRainBow

Part of the Furniture
As the title says. QoS stopped working for me on v386.3. I've done several clean installs and it still doesn't work.
I've tried Adaptive and Bandwidth Limiter... nothing happens.

It appears to only work if I select Traditional QoS.

Tried turning it off/on, but still doesn't do anything. I guess I can use Traditional, but I prefer the other two.
Any suggestions?
mine works i wonder if it is model specific, we may need someone else using at RT-AC68P to test if their adaptive and bandwidth limiter QoS are working. @Tech9 - Do you have an RT-AC68P on this version of firmware?
 

macster2075

Senior Member
It's strange because it's been working great all past versions. Besides clean install, I don't know what else to try.
 

macster2075

Senior Member
Actually, I take that back.. I am using it.. I had turned it off, but I just checked and it was on.
 

geobernd

Occasional Visitor
RT-AC68P here running 386.3 with Adaptive QoS + FlexQoS up and running with no problems or any changes to how it previously worked.
I do use fq_codel in FlexQoS - in case that makes a difference...
 

Tech9

Very Senior Member
@Tech9 - Do you have an RT-AC68P on this version of firmware?

I do have 3 different variants of this router, but I haven't tried 386.3 yet since it's mostly about VPN Director feature. I can test the QoS in next few days, if no solution is found. I don't see this issue reported in 386.3 thread though.

I've done several clean installs and it still doesn't work.

What exactly is not working? Do you always get the line speed despite Manual Settings? Do you get bufferbloat in online tests? What to look for?
 

SomeWhereOverTheRainBow

Part of the Furniture
I do have 3 different variants of this router, but I haven't tried 386.3 yet since it's mostly about VPN Director feature. I can test the QoS in next few days, if no solution is found. I don't see this issue reported in 386.3 thread though.



What exactly is not working? Do you always get the line speed despite Manual Settings? Do you get bufferbloat in online tests? What to look for?
Yea I couldn't spot anything about this issue either in the main 386.3 thread's. Two things I could think of
A) The user has somehow not hit agree to TrendMicros privacy disclaimer which controls whether or not Adaptive QoS will work (TrendMicro Lockdown On Steriods).
B) Something occured to how the TrendMicro code is handled for this model causing an issue with QoS.

I tend to lean to the issue being problem (A).
 

Tech9

Very Senior Member
A) The user has somehow not hit agree to TrendMicros privacy

Unlikely. The agreement pops up the moment you activate anything TrendMicro related. I think I found how to bug the Adaptive QoS, but let's see what config @macster2075 has. For example, if Dual WAN is enabled and the primary WAN is assigned to LAN port, Manual Settings do nothing - I'm getting full line speed and corresponding bufferbloat on DSLReports. This is on RT-AC1900P and Asuswrt 386_43129.
 

macster2075

Senior Member
I do have 3 different variants of this router, but I haven't tried 386.3 yet since it's mostly about VPN Director feature. I can test the QoS in next few days, if no solution is found. I don't see this issue reported in 386.3 thread though.



What exactly is not working? Do you always get the line speed despite Manual Settings? Do you get bufferbloat in online tests? What to look for?
I still get the full speeds...they are not throttled at all... only if I use Traditional QoS
 

SomeWhereOverTheRainBow

Part of the Furniture
Unlikely. The agreement pops up the moment you activate anything TrendMicro related. I think I found how to bug the Adaptive QoS, but let's see what config @macster2075 has. For example, if Dual WAN is enabled and the primary WAN is assigned to LAN port, Manual Settings do nothing - I'm getting full line speed and corresponding bufferbloat on DSLReports. This is on RT-AC1900P and Asuswrt 386_43129.
one quick way to debunk the TrendMicro theory is to verify via the Gui that the options are present.

1627441491197.png
 

SomeWhereOverTheRainBow

Part of the Furniture
Should I hit Withdraw?
Dont actually withdraw, just verify it is present. Make sure it list them there if it gives you the option to withdraw then that means you have properly accepted the disclaimer, but if you dont see the withdraw option, then you are not properly accepting the privacy disclaimer.
 

macster2075

Senior Member
Another weird thing I've noticed when this started is that I can't see some of the computers connected to the router.. they don't show up at all under network map. Can it be that Qos is not working properly because those computers are not being added to the network map?
 

SomeWhereOverTheRainBow

Part of the Furniture
Along with the @Tech9 theory, I would like to add that this condition could possibly occur in a double NAT situation as well where ISP Router/modem is used as a Router, and asus router is used as a Router behind the ISP router.
 

Tech9

Very Senior Member
What else is running on this router, @macster2075?
Network Map not showing some of your devices is completely different issue, not QoS related.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top