Hi guys,
I have an Asus RT-AC68U (A1 version), currently using merlin FW, but this device is now in EOL.
I'm thinking about install FreshTomato, but I need to be sure it's 100% compatible with my ISP requirements.
My ISP is Movistar Spain. I have FTTH service 1Gb, with VoIP and IPTV services.
It uses a Triple Play config (triple VLAN). 6 for internet, 2 for IPTV and 3 for VoIP.
The IPTV service, works with IGMP Proxy on vlan2, and it require some special setup like:
A static IP for vlan2
A DHCP server option 240 to connect the TV Box to the OPCH.
A DHCP server matcher for identifying the TV Box with the vendor code IAL
A special DNS server only for the TV Box
RTSP protocol for VOD content
My TV Box is connected through wifi, so wifi need to do multicast
For example, this is how the ISP is configured in Mikrotik routers:
Do you think FT can run this setup?
I have an Asus RT-AC68U (A1 version), currently using merlin FW, but this device is now in EOL.
I'm thinking about install FreshTomato, but I need to be sure it's 100% compatible with my ISP requirements.
My ISP is Movistar Spain. I have FTTH service 1Gb, with VoIP and IPTV services.
It uses a Triple Play config (triple VLAN). 6 for internet, 2 for IPTV and 3 for VoIP.
The IPTV service, works with IGMP Proxy on vlan2, and it require some special setup like:
A static IP for vlan2
A DHCP server option 240 to connect the TV Box to the OPCH.
A DHCP server matcher for identifying the TV Box with the vendor code IAL
A special DNS server only for the TV Box
RTSP protocol for VOD content
My TV Box is connected through wifi, so wifi need to do multicast
For example, this is how the ISP is configured in Mikrotik routers:
Code:
/interface/bridge
set 0 igmp-snooping=yes
/interface/vlan
add interface=ether1 name=vlan2-iptv vlan-id=2
add interface=ether1 name=vlan3-telefono vlan-id=3
add interface=ether1 name=vlan6-internet vlan-id=6
/interface/pppoe-client
add add-default-route=yes disabled=no interface=vlan6-internet \
name=internet use-peer-dns=yes user=adslppp@telefonicanetpa \
password=adslppp
/interface/list
add comment=vlans-iptv-voip name=VLANs2&3
/interface/list/member
set [find where interface=ether1 and list=WAN] interface=internet
add interface=vlan2-iptv list=VLANs2&3
add interface=vlan3-telefono list=VLANs2&3
/ip/dhcp-server/option
add code=240 name=opch-imagenio value="':::::239.0.2.29:22222'"
/ip/pool
set [find name=default-dhcp] ranges=192.168.88.10-192.168.88.239
add name=iptv-dhcp ranges=192.168.88.241-192.168.88.254
/ip/dhcp-server/matcher
add address-pool=iptv-dhcp code=60 name=descos server=defconf \
value="[IAL]"
/ip/dhcp-server/network
add address=192.168.88.240/28 comment=iptv-network \
dhcp-option=opch-imagenio dns-server=172.23.101.98 \
gateway=192.168.88.1 netmask=24
/ip/dhcp-client
add interface=vlan3-telefono add-default-route=no \
use-peer-ntp=no use-peer-dns=no
/ip/address
add address=*MyIPTVstaticIP" interface=vlan2-iptv
/ip/firewall/filter
add action=accept chain=input comment="vlans: accept voip and iptv vlans" \
in-interface-list=VLANs2&3 place-before=\
[find where comment="defconf: drop all not coming from LAN"]
/ip/firewall/nat
add action=masquerade chain=srcnat comment="VLANs2&3: masquerade" \
out-interface-list=VLANs2&3
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=4 out-interface=\
"vlan2-iptv" passthrough=yes
add action=set-priority chain=postrouting new-priority=5 out-interface=\
"vlan3-telefono" passthrough=yes
add action=set-priority chain=postrouting new-priority=1 out-interface=\
"internet"
/ip/firewall/service-port
set [find name=rtsp] disabled=no
/routing/igmp-proxy
set quick-leave=yes
/routing/igmp-proxy/interface
add alternative-subnets=0.0.0.0/0 interface=vlan2-iptv upstream=yes
add interface=bridge
/routing/rip/instance
add afi=ipv4 disabled=no name=rip
/routing rip interface-template
add instance=rip interfaces=vlan2-iptv,vlan3-telefono mode=passive
Do you think FT can run this setup?