R7800 AP mode keep rebooting after update to the latest firmware (stock and Voxel)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

droople

New Around Here
Hi there
I'm using my R7800 in AP mode, after I update to the latest firmware 1.0.2.80, I notice the router became very unstable, always rebooting, I changed to Voxel's 1.0.2.82SF (resetted), same situation.
I'm just wondering that anyone have the same issue?

Cheers
 

codemonster

New Around Here
I'm running two R7800s in AP mode with firmware 1.0.2.80.7SF without additional software like Kamoj's add-on: Both have been running stable for a little over a week now.

Before that I had firmware 1.0.2.81.1SF running and both devices rebooted frequently. I should note that I also used kamojs add-on (v5.4b16) at the same time and could not yet determine the exact reason for the problem.

Since I don't want to blame the work of either of these two great developers for no reason, please treat my statement with caution. ;)
 

droople

New Around Here
I'm running two R7800s in AP mode with firmware 1.0.2.80.7SF without additional software like Kamoj's add-on: Both have been running stable for a little over a week now.

Before that I had firmware 1.0.2.81.1SF running and both devices rebooted frequently. I should note that I also used kamojs add-on (v5.4b16) at the same time and could not yet determine the exact reason for the problem.

Since I don't want to blame the work of either of these two great developers for no reason, please treat my statement with caution. ;)

It must be NG modified some code related to AP mode.
 

OcramSagev

Occasional Visitor
I'm having exactly the same issue, it is also being reported in the NG community forums and I have not been able to find the cause or solution. Did you also have the problem with .81 (not .81.1SF) version?
 

kamoj

Very Senior Member
You can try this (from the kamoj add-on FAQ.txt):
Code:
Q: Is there a way to do a "better" factory reset than from stock GUI?
A: WARNING: This might brick your router
   Yes, but be sure you know what you are doing, and I take no responsibility
   if you brick your router.

   1). Download 2 different firmware's:
   ------------------------------------------------
      Voxel: http://www.voxel-firmware.com/Downloads/Voxel/html/index.html
      Netgear: https://www.netgear.com/support/download/

   ------------------------------------------------
   2). Unzip the image files from the downloaded firmware zip files

   ------------------------------------------------
   3). CHANGE firmware to a not wanted one:
       It is NOT enough to flash same firmware again! Not from GUI and not even using tftp.
       You must alternate the version, e.g. between Stock/Voxel or two different Voxel:
       Router GUI: Administration: Firmware Update: Locate and select the upgrade file on your hard disk: Browse
  
   4). CHANGE firmware to the wanted one:
       Router GUI: Administration: Firmware Update: Locate and select the upgrade file on your hard disk: Browse
   ------------------------------------------------
    
   5). Erase all configuration data:

      R7800: Run these commands from a router shell/prompt:
      nvram default
      nvram commit
      mtd erase netgear
      reboot

      R8900/R9000: Run these commands from a router shell/prompt:
      nvram default
      nvram commit
      ngmtd="$(awk -F: '/"netgear"$/ {print $1}' /proc/mtd | grep mtd)"
      [ -n "$ngmtd" ] && flash_erase /dev/"$ngmtd" 0 0
      reboot
  
   ------------------------------------------------
   6). Save the Router configuration file:
       Router GUI: Advanced: Administration: Backup Settings: Save a copy of current settings: Back Up
       Make sure the file size is less than 100Kb
 

OcramSagev

Occasional Visitor
You can try this (from the kamoj add-on FAQ.txt):
Code:
Q: Is there a way to do a "better" factory reset than from stock GUI?
A: WARNING: This might brick your router
   Yes, but be sure you know what you are doing, and I take no responsibility
   if you brick your router.

   1). Download 2 different firmware's:
   ------------------------------------------------
      Voxel: http://www.voxel-firmware.com/Downloads/Voxel/html/index.html
      Netgear: https://www.netgear.com/support/download/

   ------------------------------------------------
   2). Unzip the image files from the downloaded firmware zip files

   ------------------------------------------------
   3). CHANGE firmware to a not wanted one:
       It is NOT enough to flash same firmware again! Not from GUI and not even using tftp.
       You must alternate the version, e.g. between Stock/Voxel or two different Voxel:
       Router GUI: Administration: Firmware Update: Locate and select the upgrade file on your hard disk: Browse
 
   4). CHANGE firmware to the wanted one:
       Router GUI: Administration: Firmware Update: Locate and select the upgrade file on your hard disk: Browse
   ------------------------------------------------
   
   5). Erase all configuration data:

      R7800: Run these commands from a router shell/prompt:
      nvram default
      nvram commit
      mtd erase netgear
      reboot

      R8900/R9000: Run these commands from a router shell/prompt:
      nvram default
      nvram commit
      ngmtd="$(awk -F: '/"netgear"$/ {print $1}' /proc/mtd | grep mtd)"
      [ -n "$ngmtd" ] && flash_erase /dev/"$ngmtd" 0 0
      reboot
 
   ------------------------------------------------
   6). Save the Router configuration file:
       Router GUI: Advanced: Administration: Backup Settings: Save a copy of current settings: Back Up
       Make sure the file size is less than 100Kb
I've tried all Voxel's firmware starting with .68, everything works well until .79. I did perform the erase configuration data steps. I even used a command to erase the Kamoj settings after the app was uninstalled (can;'t find it right now).
STEPS
.68->.79: No issues.
.80X: Reduces my wifi speeds significantly (half, tested with iperf3).
.81X,.82X: Router reboots randomly and I'm even unable to find a pattern. It could happen in the middle of the night.
Note: Non-AP mode does not show these issues.

Current config:
R7800/Kamoj 5 (kamoj-addon_191214-083737-1_ipq806x), AP Mode (DFS 64) attached to a EdgeRouterX (Ubiquiti)
 

kamoj

Very Senior Member
There would be no need to erase Kamoj settings, since ALL settings are lost/erased if you follow the procedure.
Don't make the mistake to restore previously saved settings after reset of the router.
I've tried all Voxel's firmware starting with .68, everything works well until .79. I did perform the erase configuration data steps. I even used a command to erase the Kamoj settings after the app was uninstalled (can;'t find it right now).
STEPS
.68->.79: No issues.
.80X: Reduces my wifi speeds significantly (half, tested with iperf3).
.81X,.82X: Router reboots randomly and I'm even unable to find a pattern. It could happen in the middle of the night.
Note: Non-AP mode does not show these issues.

Current config:
R7800/Kamoj 5 (kamoj-addon_191214-083737-1_ipq806x), AP Mode (DFS 64) attached to a EdgeRouterX (Ubiquiti)
 

codemonster

New Around Here
I also have new information about this problem. I am sure that Kamoj addon is not the culprit for the reboots.

The last stable FW for me is 1.0.2.80.7SF. Survived a solid 2 weeks in AP Mode without rebooting. Yesterday evening I installed the current version 1.0.2.82.1SF (AP Mode, no kamoj addon) and counted 5 reboots so far. Thanks to Home Office, I was able to track that pretty well.

I too used the most effective method ( erase netgear partition, etc) to reset the router. No backups, everything set up from scratch.

Have now installed kamoj addon again and configured the router to save the logs on a usb stick. Tomorrow evening I will evaluate the logs.
 
Last edited:

OcramSagev

Occasional Visitor
There would be no need to erase Kamoj settings, since ALL settings are lost/erased if you follow the procedure.
Don't make the mistake to restore previously saved settings after reset of the router.
I didn;'t know the Kamoj settings were store in the backup settings.. thank you for the notice :)
 

codemonster

New Around Here
Okay, I have evaluated my logs, but can do little with the findings.

Thursday evening the R7800 crashed 4 to 5 times within an hour during a Skype call. Then switched to my second R7800 (FW V1.0.2.80.7SF, AP Mode) and the remaining 1:30 hours of Skype call went without a hitch.

The following messages from dmesg.log caught my eye:
  • [ 8.767353] Error - Duplicate Interface CB Registered for interface 107
  • [ 9.032895] msm_hsusb_host msm_hsusb_host: unable to find transceiver
  • [ 12.145017] Build_for__Netgear_R7500v2_k3.4.103_2015-04-10_lke_9.4.4_b3
  • [ 41.205592] WARNING: Fragmentation with HT mode NOT ALLOWED!!
  • [ 42.441080] __ieee80211_smart_ant_init: Smart Antenna is not supported
  • 2021-02-11 17:31:45 [Warning] skb_warn_bad_offload!!!
  • 2021-02-11 17:31:45 msm_nand_read_oob 0 800 0 failed -74, corrected 0
  • 2021-02-11 17:31:45 msm_nand_read_oob c80000 800 0 failed -74, corrected 0
I am happy to send the log files to voxel or kamoj if needed. Information like SSID or MAC were removed by me.

PS: I have seen Voxel has discovered that a bug fix (net-lan init script bug) is not present in firmwares after 80F. Maybe this solves the reboot problem.
The other suggestion (nocloud/nokwit) may have made the system a bit more stable, but I already had a reboot.
Source: http://www.snbforums.com/threads/cu...v-1-0-2-82sf-v-1-0-2-82-1sf.69449/post-662763
 

rjames

New Around Here
Okay, I have evaluated my logs, but can do little with the findings.

Thursday evening the R7800 crashed 4 to 5 times within an hour during a Skype call. Then switched to my second R7800 (FW V1.0.2.80.7SF, AP Mode) and the remaining 1:30 hours of Skype call went without a hitch.

The following messages from dmesg.log caught my eye:
  • [ 8.767353] Error - Duplicate Interface CB Registered for interface 107
  • [ 9.032895] msm_hsusb_host msm_hsusb_host: unable to find transceiver
  • [ 12.145017] Build_for__Netgear_R7500v2_k3.4.103_2015-04-10_lke_9.4.4_b3
  • [ 41.205592] WARNING: Fragmentation with HT mode NOT ALLOWED!!
  • [ 42.441080] __ieee80211_smart_ant_init: Smart Antenna is not supported
  • 2021-02-11 17:31:45 [Warning] skb_warn_bad_offload!!!
  • 2021-02-11 17:31:45 msm_nand_read_oob 0 800 0 failed -74, corrected 0
  • 2021-02-11 17:31:45 msm_nand_read_oob c80000 800 0 failed -74, corrected 0
I am happy to send the log files to voxel or kamoj if needed. Information like SSID or MAC were removed by me.

PS: I have seen Voxel has discovered that a bug fix (net-lan init script bug) is not present in firmwares after 80F. Maybe this solves the reboot problem.
The other suggestion (nocloud/nokwit) may have made the system a bit more stable, but I already had a reboot.
Source: http://www.snbforums.com/threads/cu...v-1-0-2-82sf-v-1-0-2-82-1sf.69449/post-662763
I can confirm this, also having this issue with firmware past 80.7
Seems to only reboot when starting to push some bandwidth. Light web browsing is fine but once I start streaming videos it reboots. Will try to post some logs when I get time.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top