R7800 No Wifi

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Slowikowski

Occasional Visitor
Hello!

I am trying my luck here, I know that this is a fairly active community. I went to sleep a few days ago with the internet out because it was storming fairly hard, and I woke up and found that my WiFi has cut itself off.

The radio signal is on, claiming that the signals are able to be put out. But there is no 2.4Ghz or 5Ghz being output. This randomly happened 2 nights ago. I have factory reset the router. So 1. Holding down the reset button for 30 seconds. I have 2. Held the Power button for 30 seconds(this was suggested when I called netgear :) ) 3. I have reset it within the GUI.

After calling netgear, The person I spoke with said that I would need to pay $50 for a 3 month subscription to their service so that they can fix it. The gentlemen claimed that it was an easy fix and that he needed to update something, then went on and backtracked and claimed he needed to diagnose something, then apply it to all of the devices, and that this was somehow my ISP's fault?

I have tried many things, one of which mentioned above. I have tried to set the firmware back to version 1.0.2.62 to see if the light would appear. No luck. I have tried to change the firmware to Voxel's R7800-V1.0.2.81.1SF, but again no avail with outputting a wifi signal. The rightmost buttons are on. They are white, which from my understanding meaning that the radio signals are available to be turned on.

I have attatched images that prove what I think that the WiFi should be turned on, but the router is recognizing it is off.

Any help would be greatly appreciated.
 

Attachments

  • no internet here.png
    no internet here.png
    39.4 KB · Views: 31
  • wifienabled.png
    wifienabled.png
    153.7 KB · Views: 38

Kitsap

New Around Here
Hello!

I am trying my luck here, I know that this is a fairly active community. I went to sleep a few days ago with the internet out because it was storming fairly hard, and I woke up and found that my WiFi has cut itself off.

The radio signal is on, claiming that the signals are able to be put out. But there is no 2.4Ghz or 5Ghz being output. This randomly happened 2 nights ago. I have factory reset the router. So 1. Holding down the reset button for 30 seconds. I have 2. Held the Power button for 30 seconds(this was suggested when I called netgear :) ) 3. I have reset it within the GUI.

After calling netgear, The person I spoke with said that I would need to pay $50 for a 3 month subscription to their service so that they can fix it. The gentlemen claimed that it was an easy fix and that he needed to update something, then went on and backtracked and claimed he needed to diagnose something, then apply it to all of the devices, and that this was somehow my ISP's fault?

I have tried many things, one of which mentioned above. I have tried to set the firmware back to version 1.0.2.62 to see if the light would appear. No luck. I have tried to change the firmware to Voxel's R7800-V1.0.2.81.1SF, but again no avail with outputting a wifi signal. The rightmost buttons are on. They are white, which from my understanding meaning that the radio signals are available to be turned on.

I have attatched images that prove what I think that the WiFi should be turned on, but the router is recognizing it is off.

Any help would be greatly appreciated.

Have you checked on the Advanced -> Advanced Setup -> Wireless Settings page?

Screenshot 2020-12-26 174100.jpg
 

kamoj

Very Senior Member
First try this:

Q: My WiFi can not be switched on. It's on in ADVANCED: Advanced Setup: Wireless Settings,
but the BASIC page and the Kamoj add-on Router Information shows it as off.
Also there really is no WiFi available to connect. What can I do? (@Giudi001)
A: This is a Netgear bug that can also happen when you update the Firmware or at other times...
Run these commands, one by one, from a router shell/prompt:
wlan up
wlan down
wlan toggle
wlan up

If still not working, you can try this:

Q: I have tried different Firmware (Netgear / Voxel / DD-WRT / LEDE / OpenWRT) and now
I can't switch on the WiFi! What can I do?
A: This is a Netgear bug that can happen randomly to anyone when updating any firmware.
Erase all configuration data:
R7800: Run these commands from a router shell/prompt:
nvram default
nvram commit
mtd erase netgear
reboot

R8900/R9000: Run these commands from a router shell/prompt:
nvram default
nvram commit
ngmtd="$(awk -F: '/"netgear"$/ {print $1}' /proc/mtd | grep mtd)"
[ -n "$ngmtd" ] && flash_erase /dev/"$ngmtd" 0 0
reboot
 
Last edited:

Slowikowski

Occasional Visitor
Q: I have tried different Firmware (Netgear / Voxel / DD-WRT / LEDE / OpenWRT) and now
I can't switch on the WiFi! What can I do?
A: This is a Netgear bug that can happen randomly to anyone when updating any firmware.
Erase all configuration data:
R7800: Run these commands from a router shell/prompt:
nvram default
nvram commit
mtd erase netgear
reboot

R8900/R9000: Run these commands from a router shell/prompt:
nvram default
nvram commit
ngmtd="$(awk -F: '/"netgear"$/ {print $1}' /proc/mtd | grep mtd)"
[ -n "$ngmtd" ] && flash_erase /dev/"$ngmtd" 0 0
reboot

Q: My WiFi can not be switched on. It's on in ADVANCED: Advanced Setup: Wireless Settings,
but the BASIC page and the Kamoj add-on Router Information shows it as off.
Also there really is no WiFi available to connect. What can I do? (@Giudi001)
A: This is a Netgear bug that can also happen when you update the Firmware or at other times...
Run these commands, one by one, from a router shell/prompt:
wlan up
wlan down
wlan toggle
wlan up

This may be a dumb question, and I apologize. I am trying to learn as I go.
How would I go about accessing the router shell/prompt?
 

LeKeiser

Regular Contributor
Hey Kamoj,

It seems silly, but whatever reason I am having issues installing the addon. I am using windows 10, following along, but it says that there are collected errors.
Have you experienced this before?
View attachment 28829
Hello,

Windows 10 has nothing to do with it.

Once you're logged on the 7800, type :

cd /
cd opt
mkdir scripts
cd scripts
wget --no-check-certificate https://voxel-firmware.com/Downloads/kamoj-addon_191214-083737-1_ipq806x.ipk
/bin/opkg install --force-overwrite kamoj-addon_191214-083737-1_ipq806x.ipk
reboot

And then you'll see the Kamoj addons when the router is back online.
 

Slowikowski

Occasional Visitor
Hey LeKeiser,

I seem to be missing a piece of the puzzle because even when running these commands, I only get to about the second one before I have an error thrown up saying that this is a read only system. I figured that this is a Linux based system, and frankly I am not too familiar with it.

I have attached screenshots below to hopefully allow for more troubleshooting.

Thank you all for your massive amounts of help.
1609087222158.png

1609087242402.png
1609087259405.png
1609087280673.png
 

LeKeiser

Regular Contributor
You're not in the directory /opt obviously. You're at the root of the FS so you cannot download a file there.

Please type (in bold)

[email protected]:$ cd /
[email protected]:$ cd opt
[email protected]:$ pwd

and show us the result.

You shoud have

[email protected]:$ cd /
[email protected]:/$ cd opt
[email protected]:/opt$
[email protected]:/opt$ pwd
/opt
[email protected]:/opt$ ls
dirlist kamoj rcagent xagent
filelist leafp2p remote version

Then, from there :
[email protected]:/opt$ mkdir scripts
[email protected]:/opt$ cd scripts
[email protected]:/opt/scripts$ wget --no-check-certificate https://voxel-firmware.com/Downloads/kamoj-addon_191214-083737-1_ipq806x.ipk
[email protected]:/opt/scripts$ /bin/opkg install --force-overwrite kamoj-addon_191214-083737-1_ipq806x.ipk
[email protected]:/opt/scripts$ reboot

The scripts directory is the place I like to store the addon. Just cleaner :)
 

Slowikowski

Occasional Visitor
You're not in the directory /opt obviously. You're at the root of the FS so you cannot download a file there.

Please type (in bold)

[email protected]:$ cd /
[email protected]:$ cd opt
[email protected]:$ pwd

and show us the result.

You shoud have

[email protected]:$ cd /
[email protected]:/$ cd opt
[email protected]:/opt$
[email protected]:/opt$ pwd
/opt
[email protected]:/opt$ ls
dirlist kamoj rcagent xagent
filelist leafp2p remote version

Then, from there :
[email protected]:/opt$ mkdir scripts
[email protected]:/opt$ cd scripts
[email protected]:/opt/scripts$ wget --no-check-certificate https://voxel-firmware.com/Downloads/kamoj-addon_191214-083737-1_ipq806x.ipk
[email protected]:/opt/scripts$ /bin/opkg install --force-overwrite kamoj-addon_191214-083737-1_ipq806x.ipk
[email protected]:/opt/scripts$ reboot

The scripts directory is the place I like to store the addon. Just cleaner :)


Heres what I get just doing those 3 commands.
1609088904587.png
 

kamoj

Very Senior Member
- You don't need to install the add-on to give the "wifi on" commands.
- You can download to the / root!
- If you want install the addon do:
Code:
curl -k -R -O https://voxel-firmware.com/Downloads/kamoj-addon_191214-083737-1_ipq806x.ipk
/bin/opkg install --force-overwrite kamoj-addon_191214-083737-1_ipq806x.ipk
reboot
- if you want to on WiFi:

Code:
wlan up
wlan down
wlan toggle
#And finally if Wifi still not working:
wlan up
 

Slowikowski

Occasional Visitor
- You don't need to install the add-on to give the "wifi on" commands.
- You can download to the / root!
- If you want install the addon do:
Code:
curl -k -R -O https://voxel-firmware.com/Downloads/kamoj-addon_191214-083737-1_ipq806x.ipk
/bin/opkg install --force-overwrite kamoj-addon_191214-083737-1_ipq806x.ipk
reboot
- if you want to on WiFi:

Code:
wlan up
wlan down
wlan toggle
#And finally if Wifi still not working:
wlan up

So I get this issue below. It seems no matter which angle I attack from. I cannot Do a thing because Im in read only mode, and I cannot access write mode.
1609092146271.png
 

HELLO_wORLD

Very Senior Member
To go to opt, it is
Code:
cd /opt

Also, to first check if opt exists, what is the result of this:
Code:
cd /
ls -l
 

kamoj

Very Senior Member
You have got a corrupt router/file system then.
You can try to recover with these commands (erasing all your data):
Code:
nvram default
nvram commit
mtd erase netgear
reboot
If this is not working you need to install a new firmware.
I suggest you then first install a Netgear firmware,
and then the latest Voxel firmware.
Install is done from router web-page.

As last resort you can perform a "tftp-installation".
PS
Sorry, if I missed something, but why do "we" need to go to "opt" at all?


So I get this issue below. It seems no matter which angle I attack from. I cannot Do a thing because Im in read only mode, and I cannot access write mode.
 

Slowikowski

Occasional Visitor
You have got a corrupt router/file system then.
You can try to recover with these commands (erasing all your data):
Code:
nvram default
nvram commit
mtd erase netgear
reboot
If this is not working you need to install a new firmware.
I suggest you then first install a Netgear firmware,
and then the latest Voxel firmware.
Install is done from router web-page.

As last resort you can perform a "tftp-installation".
PS
Sorry, if I missed something, but why do "we" need to go to "opt" at all?

Kamoj. You are a magician. My lights are on!
I cannot thank you enough for your help.

So from what you are saying, I had a corrupt router/file system, which caused my router to go to waste?

Also do I need to do anything after running that code? Or is there anything else that I need to follow up with?

I figured after reading through the forums, dont allow netgear to update itself or it will screw with the router more, and then every so often keep up to date with the firnware itself.
 

kamoj

Very Senior Member
You can thank me enough if you want!
Just try the "Like" button beneath the message you like"

Yes, you had a corrupt filesystem.
But now you seem to be fine!
I suggest you try to install the kamoj add-on as well. :cool:
It gives you some information and insights about the router.
(There will be a more modern add-on version in the near future as well, so keep your eyes here in the forum!

Just stay with Voxel firmware, never Netgear firmware!
Voxel firmware will not auto-update.

Kamoj. You are a magician. My lights are on!
I cannot thank you enough for your help.

So from what you are saying, I had a corrupt router/file system, which caused my router to go to waste?

Also do I need to do anything after running that code? Or is there anything else that I need to follow up with?

I figured after reading through the forums, dont allow netgear to update itself or it will screw with the router more, and then every so often keep up to date with the firnware itself.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top