R8000 Throughput Issues with Fiber

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

jehud

New Around Here
Model: R8000
Firmware: Latest
OS: multiple(win, osx)

So I got fiber installed at my house and I'm noticing major issues with the max wired bandwidth on the Nighthawk R8000. Plugged in I peak at roughly 450 mbps, which is obviously very disapointing given the cost and quality of the router. Plugged in direct to CenturyLink's wifi router I get 900+ mbps wired no problem. If you look at the comments section of the below link you'll see lots of people with this issue. Is there anything that can be done to fix this? Otherwise this router seems sort of unusable with fiber.

http://kmwoley.com/blog/bypassing-needless-centurylink-wireless-router-on-gigabit-fiber/
 

avtella

Very Senior Member
I believe the issue is NAT acceleration/CTF, which gets turned of if incompatable features like PPPoE, QoS and Traffic Metering are activated, this is a Broadcom specific thing. Same occurs on other router brands utilizing their Northstar/XStream chipset. Most people are not bothered by this as most have much slower internet speeds but those like yourself with such a fast connection would be notice.

Best thing is to let the CenturyLink C2000A/T modem do the PPPoE and disable QoS and Traffic Metering and you should be fine. Only other alternative if you hate CenturyLink's Actiontec or Technicolor modem is to buy a Qualcomm chipset based router like the R7500v2 or R7800.

Read this, it should help you understand better:
http://www.snbforums.com/threads/broadcoms-hardware-acceleration.18144/
http://routerguide.net/nat-acceleration-on-or-off/

Here is a thread on DSLReports with someone using an Asus AC87U AC3200 router having the same issue on CenturyLink, my posts are under the id avx.
https://www.dslreports.com/forum/r3...s-with-CenturyLink-Fiber-ASUS-RT-AC87U-Merlin
 
Last edited:

jehud

New Around Here
I believe the issue is NAT acceleration/CTF, which gets turned of if incompatable features like PPPoE, QoS and Traffic Metering are activated, this is a Broadcom specific thing. Same occurs on other router brands utilizing their Northstar/XStream chipset. Most people are not bothered by this as most have much slower internet speeds but those like yourself with such a fast connection would be notice.

Best thing is to let the CenturyLink C2000A/T modem do the PPPoE and disable QoS and Traffic Metering and you should be fine. Only other alternative if you hate CenturyLink's Actiontec or Technicolor modem is to buy a Qualcomm chipset based router like the R7500v2 or R7800.

Read this, it should help you understand better:
http://www.snbforums.com/threads/broadcoms-hardware-acceleration.18144/
http://routerguide.net/nat-acceleration-on-or-off/

Here is a thread on DSLReports with someone using an Asus AC87U AC3200 router having the same issue on CenturyLink, my posts are under the id avx.
https://www.dslreports.com/forum/r3...s-with-CenturyLink-Fiber-ASUS-RT-AC87U-Merlin

Yeah I had read about those things so I turned off traffic metering for instance which put the nighthawk into an infinite reboot loop for 30 minutes or so (which was fun :). I factory reset it and turned it into an AP using their UI option to do so, this turns off QoS & Traffic Metering also. Even as an AP I see the same limits wired in I can't get more than 450 mbps or so which shouldn't be the case. Even after I set it as an AP I went in and tried disabling WMM on each radio, this destroyed the WiFi perf and didn't change the wired perf at all. Given that I factory reset it and I made it an AP it feels like there might be something defective with the product.
 

avtella

Very Senior Member
Can't you just put the R8000 in the C2000A/T's DMZ to avoid the double NAT? Is there a specific reason to avoid the CL modem?

As for AP mode that is odd, I will look into that.
 

jehud

New Around Here
Yeah I tried to do that also but didn't see a difference. When it's in AP mode basically everything is turned off and it should perform well but still stuck at 400 mbps max.
 

Razor512

Very Senior Member
With the way netgear routers do their AP mode, you still lose the acceleration. The only way I found to get the benefits of AP mode, and not lose throughput, is to change the router's IP to something else, (e.g., from 192.168.1.1 to 192.168.1.10), then disable the DHCP server on the router, and then do a LAN to LAN connection.

This allows the WiFi radio to still function normally, as well as the network shares, and you still be able to log into the router, and not lose any performance.
 

jehud

New Around Here
but in AP mode DHCP is disabled already so why wouldn't I see the perf increase then? Have you done this with the nighthawk R8000 specifically? I tried turning off DHCP (not in AP mode) on my nighthawk before and opening the NAT but I didn't see any performance difference. The only thing I didn't do was change the ip manually of the router, why does that help?
 

Razor512

Very Senior Member
It is for when you are doing a LAN to LAN connection (not using the physical WAN port on the router).

I have not tried the R8000, but I will try to demonstrate this using the R7000 router.
 

jehud

New Around Here
Ah I see what you are saying you are suggesting I don't plug my fiber router into the internet(aka WAN) port of the nighthawk but just into a normal port. Then leave the nighthawk not in AP mode but with NAT open and DHCP off with a static ip. Correct?
 

Razor512

Very Senior Member
Pretty much, you will not be using the built in AP mode.


Here are the benchmarks.

AP mode (Ethernet cable connected to WAN port) http://i.imgur.com/eTwaj5X.jpg

Now here is the same router, but instead of AP mode, I simply change the IP from 192.168.1.1 to 192.168.1.10, then disable DHCP,and then connect it to the R6300 v2 in a LAN to LAN config (WAN port left empty) http://i.imgur.com/1nhmXKX.jpg

Results will not be very clean since my network is mostly being actively used, and I did not disable the other devices during the test, and I simply swapped the routers, I needed to do it anyway since I was planning on giving the tomato firmware another change on the R7000, mainly for its bandwidth monitoring functions.
 

jehud

New Around Here
Very cool, I'll try this tonight. This is still extremely lame given the cost of the router :(.
 

jehud

New Around Here
I'd bet it's just an issue with their routers + broadcom chipset. I think they've been lucky to hide the issue because fiber is very rare still / expensive in the US. If most people had fiber & 1 gig / s connections every new purchaser would have seen it. On my old 100 mbps connection I of course never saw any issues.
 

jehud

New Around Here
That worked sorta, wired on my wife's laptop I'm now getting 700mb or so down, while wired from her laptop into the century link router I get 930 + mbps. My wireless performance seems to have dropped also, I'm now peaking at ~330 mbps and before I was getting closer to 400+ mbps. My upload speed over wifi though is around 600 mpbs now.
 

Razor512

Very Senior Member
hmm, strange, when connected in a LAN to LAN config, it should essentially function like an unmanaged switch, with the AP portion being essentially another device on that switch.

If you have a wired connection to one of the Ethernet ports on the R8000, another LAN side Ethernet port connected from the R8000, to the century link router, then it should function the same as if you had an unmanaged switch connected to the century link router.
 

jehud

New Around Here
What wireless performance are you seeing on yours when it's a dumb switch vs AP? As a dumb switch I'm maxing on the 5ghz channel at ~330 mbps when 4ft from the router.
 

NETGEAR Guy

Senior Member
By design, CTF is Broadcom's proprietary mechanism to accelerate packets forwarded by hardware.

With CTF disabled, packets are sent via the CPU and the CPU will process packet forwarding.
However, performance will be limited to the CPU capability.

With CTF enabled, packets are forwarded directly without intervention by the CPU and therefore performance is not degraded.

CTF has the ability to bypass the packets that should go to the upper layer originally by HW acceleration, which can improve the throughput.

If functionality such as “Traffic Meter, ACL”, etc, are enabled, upper layer CPU code will be required to process the packets, therefore, CTF will be auto disabled.

The goal is to enable CTF with the above functions enabled and the NETGEAR engineering team are currently working on code optimisation to enhance the coordination work between the CPU and CTF.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top