What's new

Register Your Product Greyed out

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Senior Member
I registered my first GT-AX6000 just fine a couple of weeks ago. Now I got a second one but I am not able to register it under my account.

I entered the serial number correctly 100% and even tried a few methods substituting the 1 with an I or the 0 with a O but I am sure when I am entering is correct as I see the 1's look different than the I.

Asus customer support is your next stop.
Asus customer support is your next stop.
I emailed ASUS customer support, but since they didn't reply (I know it's only been one day) I called ASUS Dubai. The agent I spoke to was rude and sounded like he didn't wanna work. I explained the issue and he said there is nothing he can do and I needed to send an email with screenshots detailing the issue. I told him I did that then he told me to just wait.

Anyway, today, I just thought of searching for "register ASUS product" on Google and got a different URL which I've never tried before >>>> https://www.asus.com/support/Product/APRP/?lang=1033

It looked like a different page, so I entered my router's serial number and the fields below it automatically were filled (ie. Router, GT-AX6000). Then I simply selected the date of purchase and it got registered.

I then checked my account on the website I was trying to register on before ( https://account.asus.com/myproducts.aspx ) and now my router is registered!

I hope this helps if anyone was facing the same issue.

Last edited:
On the other hand, I never register anything. I don't want my name/info being tracked to the products I buy/use (some, for just a limited time).

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!