Reinstalling DNSCrypt2 (Solved)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

TsukiKanade

New Around Here
Hello! I'm not sure if this is the proper place to ask this, and if it isn't, I apologize.

I've seem to run into an issue where, using Kamoj's excellent addon, I get the error message "DNSCrypt v2 is not running, but is enabled" under DNSCrypt v2 Servers on my R7800. No problem. Searching through the boards, I tried doing the following to reset dnscrypt through telnet

Code:
nvram set dnscrypt2=0
nvram commit
reboot

#Then after reboot
nvram set dnscrypt2=1
nvram commit
reboot
After doing this, I then am no longer able to browse on the internet despite seeing all the LEDs properly lit up; I'd get the "Server not found" error message. The only way I'd be able to access the internet again is by disabling dnscrypt once more. Oddly enough, running the command /etc/init.d/dnscrypt-proxy-2 restart gives me the error that it does not exist when dnscrypt2 is enabled in nvram.

With this said, I imagine I messed up somewhere and would like to try and reinstall a fresh build or so of dnscrypt into my router. Reinstalling the latest firmware from Voxel didn't seem to help, nor did performing a factory reset.

If you made it this far, thank you for reading through this and for any help you can offer.
 
  • Like
Reactions: KW.

Voxel

Very Senior Member
After doing this, I then am no longer able to browse on the internet despite seeing all the LEDs properly lit up; I'd get the "Server not found" error message. The only way I'd be able to access the internet again is by disabling dnscrypt once more.
Try to check why it fails (from telnet/ssh):
Code:
cat /var/log/dnscrypt-proxy-2.log | more
Maybe wrong your own custom DNSCrypt server?

幸運を

Voxel.
 
Last edited:
  • Like
Reactions: KW.

TsukiKanade

New Around Here
Try to check why it fails (from telnet/ssh):
Code:
cat /var/log/dnscrypt-proxy-2.log | more
I did try that command and got... a nearly blank file. I attached a screenshot of it.

Maybe wrong your own custom DNSCrypt server?
I do have the stock servers. Attached a screenshot of it as well! Thank you so much for the help thus far.
 

Attachments

  • Like
Reactions: KW.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top