[Release] Asuswrt-Merlin 384.17 (and 384.13_8) are now available

Status
Not open for further replies.

sirzur

Occasional Visitor
I have a RT-AC86U running on this latest Merlin firmware. This morning, I encountered a curious problem that the experts here may be able to explain. It may be (un)related to the latest firmware but I have not seen the problem before, through the various iterations of the stabel version I had installed.

So the missus was trying to join a zoom meeting via an Android phone (Nokia 6 with latest update) and could not because of an Error code 5003 from zoom. That error is for a blocked connection (whether from firewall or proxy, which I do not have set up). These are the things I tried to get zoom working, with various outcomes as below

- uninstalled the zoom app on Android phone and re-installed it from playstore - no success
- restarted my Nord VPN connection - no success. My Nord VPN is not a sophisticated set up. Just diverts a couple of fixed internal IP address devices to WAN, bypassing VPN. No other routing. Both my wife's Android phone and my Android phone goes through the Nord VPN when connected to home wifi
- browser on phone to try to connect to https://zoom.us. While the browser could connect to google search page and perform searches, it could not connect to that address
- my desktop PC on Windows 10, which is connected to the router via ethernet COULD connect to the zoom website and start zoom
- my phone which is another Android device also could not connect to zoom website
- booted up a Microsoft surface device on Windows 10 and it could connect to the zoom website (and also allow zoom meeting)

While I was looking at the network map, I noted that both the Android phones were wifi connected via 5 Ghz, but the Microsoft surface device was using 2.4 GHz frequency.

So my question is why I am able to connect to a particular website (zoom in this case) via ethernet and 2.4 GHz , but not through 5 GHz. All the devices I tried would have been going through my Nord VPN connection.

I suspect a DNS server issue, but am at a loss why the 5GHz device would use a different DNS server than the other network connected devices (and what DNS server they could be using). Is it possible that they use the phone network DNS provider (because obviously these devices would be taken out of the house and use the phone network provider's DNS server when outside)

I managed to finally get the Android devices connected by rebooting the router, but want to be able to prevent this from happening again

I forgot to add that all devices mentioned goes through the VPN
 
Last edited:

adampk17

Senior Member
I have a RT-AC86U running on this latest Merlin firmware. This morning, I encountered a curious problem that the experts here may be able to explain. It may be (un)related to the latest firmware but I have not seen the problem before, through the various iterations of the stabel version I had installed.

So the missus was trying to join a zoom meeting via an Android phone (Nokia 6 with latest update) and could not because of an Error code 5003 from zoom. That error is for a blocked connection (whether from firewall or proxy, which I do not have set up). These are the things I tried to get zoom working, with various outcomes as below

- uninstalled the zoom app on Android phone and re-installed it from playstore - no success
- restarted my Nord VPN connection - no success. My Nord VPN is not a sophisticated set up. Just diverts a couple of fixed internal IP address devices to WAN, bypassing VPN. No other routing. Both my wife's Android phone and my Android phone goes through the Nord VPN when connected to home wifi
- browser on phone to try to connect to https://zoom.us. While the browser could connect to google search page and perform searches, it could not connect to that address
- my desktop PC on Windows 10, which is connected to the router via ethernet COULD connect to the zoom website and start zoom
- my phone which is another Android device also could not connect to zoom website
- booted up a Microsoft surface device on Windows 10 and it could connect to the zoom website (and also allow zoom meeting)

While I was looking at the network map, I noted that both the Android phones were wifi connected via 5 Ghz, but the Microsoft surface device was using 2.4 GHz frequency.

So my question is why I am able to connect to a particular website (zoom in this case) via ethernet and 2.4 GHz , but not through 5 GHz. All the devices I tried would have been going through my Nord VPN connection.

I suspect a DNS server issue, but am at a loss why the 5GHz device would use a different DNS server than the other network connected devices (and what DNS server they could be using). Is it possible that they use the phone network DNS provider (because obviously these devices would be taken out of the house and use the phone network provider's DNS server when outside)

I managed to finally get the Android devices connected by rebooting the router, but want to be able to prevent this from happening again

I’d suspect the Zoom app on the android devices or the VPN before the router or wireless band.

You didn’t mention if the surface device or desktop PC goes through the VPN.

Do the android phones connect to zoom with Wi-Fi turned off, on cellular?

I’d try to access zoom without the VPN on the android devices just for the heck of it.
 

adampk17

Senior Member
I forgot to mention that all devices mentioned go through the VPN. And I edited the post above to also mention that

What about trying the android devices on cellular - or connecting them to the 2.4 GHz network to test your theory?
 

Selectaa

New Around Here
Dirty flash from previous on AX88U and AC86U in mesh setup. Everything works as expected, and one bug was resolved when flashing; I can now see ethernet devices connected to the Mesh client. So great job once again!

The only bug I'm still struggling with is local IPv6 DNS server. For IPv4 it works great, but I can't for the life of me get the Asus DHCP server to pass the configured local IPv6 DNS server. Has anyone seen any form of workaround for this? I found some threads, but none with any answer.
 

sirzur

Occasional Visitor
What about trying the android devices on cellular - or connecting them to the 2.4 GHz network to test your theory?

Yeah, I think I am going to have to do some troubleshooting the next time it happens, but I was under pressure to get the zoom connection up on the Android phone, so re-booted the router after a couple of troubleshooting steps. But I am still curious why multiple devices connected through the same VPN would appear to use different DNS servers. Also it might be co-incidental that it only affected the 5GHz wifi devices
 

MDM

Senior Member
Yeah, I think I am going to have to do some troubleshooting the next time it happens, but I was under pressure to get the zoom connection up on the Android phone, so re-booted the router after a couple of troubleshooting steps. But I am still curious why multiple devices connected through the same VPN would appear to use different DNS servers. Also it might be co-incidental that it only affected the 5GHz wifi devices
Unless you FORCE DNS with ROUTER in DNSFilter setting, many and especially Android devices will force their DNS (Googles one for them)...
 

kamnosh

Occasional Visitor
Asus AX88U 384.16 /17
Hi,
I have a question for all of you who have more experience, I have a fiber line at the rate of 500/500 Mbps for download / upload. I'm still running version 15, I installed both versions 16 and 17 when they came out, but on both versions the speed of WIFI goes down to below 100 Mbps, but when downgrading to version 15 everything goes back to normal and I get about 500/500 when I measure the speed. I wondered if it was just me or someone else experiencing the same thing.
I have to mention that my hardware is the same and I haven't made any changes.
I appreciate your feedback.
 
Last edited:

adampk17

Senior Member
Asus AX88U 384.16 /17
Hi,
I have a question for all of you who have more experience, I have a fiber line at the rate of 500/500 Mbps for download / upload. I'm still running version 15, I installed both versions 16 and 17 when they came out, but on both versions the speed of WIFI goes down to below 100 Mbps, but when downgrading to version 15 everything goes back to normal and I get about 500/500 when I measure the speed. I wondered if it was just me or someone else experiencing the same thing.
I have to mention that my hardware is the same and I haven't made any changes.
I appreciate your feedback.

How are you measuring the speed, wireless devices only or any wired devices?
 

RMerlin

Asuswrt-Merlin dev
Ever since I installed 384.13_8 on my AC-3200 I have to reboot at least once or twice a day because the 2.4 GHz radio seems to go down... (If I look at the connected devices, 5ghz devices are connected but nothing 2.4ghz)a reboot and all my 2.4ghz devices will then connect. Reverting back to the previous version for now, hopefully a fix is forthcoming.

The RT-AC3200 wifi code hasn't changed in over a year. Your issue is unrelated to this firmware release.

Code:
[email protected]:~/amng$ git log --oneline 384.13_6..384.13_8
17bd9a773a (tag: 384.13_8) Bumped revision to 384.13_8
a3948a2e1d Updated documentation
9d01afac21 Updated documentation
876788f384 dropbear: Fix CBC_MODE can't be fully disabled
c028423274 dnsmasq: backport asus patches
c0a0f7a01d dnsmasq: update to 2.81 (2.81-32-g93cb543-openssl)
9e7d2312b5 dnsmasq: update to 2.81rc5-31-gdb028b0-openssl
4f131755f8 dnsmasq: update to 2.81rc4-33-g7558f2b-openssl
4985d890ac dnsmasq: update to 2.81rc3-29-g495e518-openssl
76e536deb7 dnsmasq: update to 2.81rc1-29-g5b6f222
5d5c38acc1 dnsmasq: dhcpv6: revert ntp server, use sntp server option instead
82e5a4ab5a dnsmasq: update to 2.80-148-g3ce803d-openssl
545af52e81 openssl: update to 1.1.1g
01bebe7b62 openvpn: updated to 2.4.9
d4a9fc47b3 webui: completely remove Feedback page to ensure nobody is misusing it.
dec5dd464e Fix typo during TM signature update
0e6481d885 Bumped revision to 384.13_7
 

Viktor Jaep

Very Senior Member
Have you done the factory reset recommended for this version?

I didn't read that a factory reset was recommended for this version? I typically do a dirty flash, and seems to work OK. If I continue seeing issues, I'll probably go that route. Thanks!
 

Pitchounet

Occasional Visitor
I didn't read that a factory reset was recommended for this version? I typically do a dirty flash, and seems to work OK. If I continue seeing issues, I'll probably go that route. Thanks!

It's in the changelog:

"384.17 (26-Apr-2020)
Updating some models (like the RT-AC88U) from stock firmware
3.0.0.4.384_81790 and newer will require a factory default reset
after flashing Asuswrt-Merlin, due to a change in how Asus

stores the admin password starting with 384_81790."

and precized on one of rmerlin post:

It depends on the models. As noted in the changelog, the latest RT-AC88U release (and now also RT-AC3100 and RT-AC5300) will encrypt their passwords.

All AX models have already been using encrypted password since day one, so nothing changed for these.

don't forget all possible backups before the factory reset. and to reput and check all your configs after. I've done it for my RT-AC88U. (and so seems needed too for your model)
 
Last edited:

immi803

Senior Member
Hello everyone,
I previously had mesh setup for RT-AC88U as main router + AC68U as node (wireless), both on 384.16 previously and now on 384.17, just few days back i added AC66U-B1 as node as well and obviously on asuswrt 384.17 as well.
Now setup is Ac88u attached wireless to Ac68u and Ac66u-b1 as wired node to Ac68u, initially , it shows Ac68u connected wirelessly as node and Ac66u-b1 as Lan node, they work perfectly fine till yesterday i found Ac66u-b1 performing very badly. After checking nodes status , i found Ac66u-B1 connected wirelessly to Ac68u instead of Lan mesh node and obviously the distance between them is long, it was a bad wireless node with very weak strength, though everything was in place already, i-e Lan cable from Ac68u to Ac66u-B1, i was unable to track why it shifted to wireless when lan was all set previously and was working fine.

I removed Ac66u-B1 mesh node and added it again and it added fine as Lan mesh node again and was working fine till this afternoon it again went wireless like prior incident, removed node again and added again and it was back again at Lan, Can anyone give me any clue why this could happen? Is it something needs fine tuning in 384.17 (Can't tell about previous versions as it was not in this setup previously)

Any help is highly appreciated
@RMerlin
 
Last edited:

sirzur

Occasional Visitor
Unless you FORCE DNS with ROUTER in DNSFilter setting, many and especially Android devices will force their DNS (Googles one for them)...


I currently have DNS Filter turned off. So I should turn this on and apply "No Filtering", in order to force the DNS specified by router or router itself (according to definition of No Filtering"
 

MDM

Senior Member
I currently have DNS Filter turned off. So I should turn this on and apply "No Filtering", in order to force the DNS specified by router or router itself (according to definition of No Filtering"
No, "Router" it is. How could you misinterpret the written definition...?
Annotation 2020-05-07 031000.png
 

Svenskmat

Regular Contributor
Update - not sure if has anything to do with this release but in a crowded 2.4 G neighbourhood and I am running 4 Nest cameras, the auto channel does not seem to choose the best option. Manually choosing 2.4 channel for now. Also had very slow speed on one of the 5 G networks- reboot fixed this. Both of these may have nothing to do with this release.
Update again... lost all of my IOT 2.4 clients other than the Nest Cams. No way to get it back. Hard Reset and running 3 separate SSID's and all is good. Will "try" not to tinker with the settings for at least for 48 hours and see if the 2.4 is stable before it make changes.
 
Status
Not open for further replies.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top