[Release] Asuswrt-Merlin 384.18 and 384.13_10 is now available

Status
Not open for further replies.

joegreat

Very Senior Member

Marvin

New Around Here
Dirty upgrade from .17 to .18 on AC88U
Clean log, on .17 had regular ppp connections drops with "ppp0 does not exist" error messages (I'm obviously on PPPoE connection).
Very smooth and steady build, thank you RMerlin!
 

tuntun

Occasional Visitor
Hope you can make ver 384.18 for RT-AC87U as well soon so that we can get same features as other models. I am aware this model is limited supports but hopefully...Thanks Eric
 

RMerlin

Asuswrt-Merlin dev
Hope you can make ver 384.18 for RT-AC87U as well soon so that we can get same features as other models.

That's impossible, the 384.18 code is no longer compatible with the closed source components Asus provides for this model.
 

tgab_b

Occasional Visitor
Since I have upgraded to 384.18, I am facing below issue of "This account already exists, Please enter a different name" whenever I try to make any change to Administration>System tab. Though, I have not put my cursor on login section:

upload_2020-7-5_14-43-17.png
 

dave14305

Part of the Furniture

MDM

Senior Member
That's impossible, the 384.18 code is no longer compatible with the closed source components Asus provides for this model.
I guess he hopes for ASUS to come around and issue a FW in line with the newer Code...
I sure hope too! (hope dies last) ;)
 

Asad Ali

Very Senior Member
Make sure you check which unit (0 or 1) got called.

There are multiple WAN events during boot.

This is my wan-event script, apparently at boot time it executes on both WANs (0 and 1) without looking if Wan0 is down or not. I dont get any issues and the scripts execute as expected and on proper events after the first boot.

Code:
#!/bin/sh

# Determine FL-UP
if [ "$1" = "0" ] && [ "$2" = "connected" ]; then
/jffs/scripts/personal/Fiberlink/FL-Connected
fi

# Determine FL-Down
if [ "$1" = "0" ] && [ "$2" = "disconnected" ]; then
/jffs/scripts/personal/Fiberlink/FL-Disconnected
fi

# Determine Jazz-UP
if [ "$1" = "1" ] && [ "$2" = "connected" ]; then
/jffs/scripts/personal/Jazz/Jazz-Connected
fi

# Determine Jazz-Down
if [ "$1" = "1" ] && [ "$2" = "disconnected" ]; then
/jffs/scripts/personal/Jazz/Jazz-Disconnected
fi

@RMerlin Were you able to reproduce this issue?
 

RMerlin

Asuswrt-Merlin dev
I guess he hopes for ASUS to come around and issue a FW in line with the newer Code...

From what info I have, this won't be happening, hence my decision to stop waiting and to pull the plug now.

@RMerlin Were you able to reproduce this issue?

The script is doing what it's meant to do: it gets executed whenever there is a WAN-related event done by the router. So, multiple calls are normal. You will need your script to be intelligent about it, and to pay attention to which specific event and for which unit it got called.
 

Asad Ali

Very Senior Member
From what info I have, this won't be happening, hence my decision to stop waiting and to pull the plug now.



The script is doing what it's meant to do: it gets executed whenever there is a WAN-related event done by the router. So, multiple calls are normal. You will need your script to be intelligent about it, and to pay attention to which specific event and for which unit it got called.

My WAN0 is PPPoE and WAN1 is USB dongle working over DHCP, so I believe what's happening is on reboot the router initializes WAN1 faster than WAN0 since it doesn't need to dial and authenticate it from my ISP, thus the call of WAN1 event just before WAN0. I'll do some testing to find out the exact time difference and manipulate my scripts to take that into consideration.

Thank you for your time.
 

JIPG

Regular Contributor
I have done a dirty update in my RT-AC87U to FW 384.13_10, and so far so good (as usual :)).

Thank you RMerlin (and themiron ...).
 

reerden

Regular Contributor
Just as a heads-up for people using access restriction on the system page, it does not work when you select 'HTTPS' only as the authentication method. HTTP remains active, and the access restriction code assumes it is disabled. Therefore HTTP remains accessible for everyone on the network.

Selecting BOTH properly filters HTTP.
 

Makaveli

Very Senior Member
Just as a heads-up for people using access restriction on the system page, it does not work when you select 'HTTPS' only as the authentication method. HTTP remains active, and the access restriction code assumes it is disabled. Therefore HTTP remains accessible for everyone on the network.

Selecting BOTH properly filters HTTP.

When I have it set to HTTPS only.

I cannot access http.
 

reerden

Regular Contributor
When I have it set to HTTPS only.

I cannot access http.

Hmm, that's strange. I did set an alternative port for HTTP. It's also a fresh install with a factory reset and manual reconfigure. I couldn't get HTTP to be restricted. Only setting it to BOTH solved the issue for me.

EDIT: seems this happens if the HTTP port field has anything but 80 in it. I guess some of httpd code checks for that instead of the http_enable NVRAM value.
 
Last edited:

grifo

Senior Member
From what info I have, this won't be happening, hence my decision to stop waiting and to pull the plug now.
Yeah, they're too busy developing stuff no one wants like open nat ;)

Soon I'll swap my RT-AC87U with the RT-AC68U I got second hand for 50 euros and now running in AP mode. Not going to buy another new Asus router after having been able to use my 87U as a router for only 3 years. Amazon was selling it new only last year and Asus own firmware was already basically dead. Poor IMO.
 
Status
Not open for further replies.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top