What's new

Solved Removing that dreaded UPnP port...

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Viktor Jaep

Part of the Furniture
Hi All...

I thought I had disabled UPnP everywhere, but it's still showing up as a listening UDP port no matter what. What can be done to remove this?

I have UPnP disabled on the WAN...
1685796841379.png


I have the UPnP Media Server (USB Application -> Servers -> Media Server) disabled:
1685796898394.png


I don't have QoS enabled, which could also introduce some UPnP issues:
1685796958131.png


But yet, when I run an nmap on my WAN0, this is what comes up, showing UPnP listening and unfiltered:
1685797064408.png


Running ps | grep pnp yields no results... so nothing is running.

I even went through my nvram, and searched for UPnP that might have something to do with this, and have no other leads to go on to figure out how to shut this down:
Code:
upnp_clean=1
upnp_clean_interval=600
upnp_clean_threshold=20
upnp_enable=0
upnp_max_lifetime=86400
upnp_max_port_ext=65535
upnp_max_port_int=65535
upnp_min_lifetime=120
upnp_min_port_ext=1
upnp_min_port_int=1024
upnp_mnp=1
upnp_pinhole_enable=0
upnp_port=0
upnp_secure=1
upnp_ssdp_interval=60
vts_upnplist=
wan0_upnp_enable=0
wan1_upnp_enable=0
wan_upnp_enable=0
wl0_wmf_ucast_upnp=0
wl1_wmf_ucast_upnp=0
wl_wmf_ucast_upnp=0

Do I seriously have to force an iptable DROP to forcefully close this?
Code:
iptables -A INPUT -p udp --dport 1900 -j DROP

If anyone have any other good ideas on how to get rid of this open port hanging out there, that I can't seem to get rid of? (Oh, and yes... I rebooted as well) :p Thanks in advance!!
 
Last edited:
Right near that QOS setting, on your router do you have a "enable geforce NOW QOS UPNP" toggle that is defaulted to on. Toggle it off if so. Not sure about your model, some don't have this setting.
 
Right near that QOS setting, on your router do you have a "enable geforce NOW QOS UPNP" toggle that is defaulted to on. Toggle it off if so. Not sure about your model, some don't have this setting.
Thanks for the suggestion... I looked for that as well initially, but I figured my router doesn't support that feature. Normally this is off, but when I slide it to ON, this is what I get...

1685798912748.png


Or if you talking about this (screengrab from google), no, I don't have this setting either:
itperf-asus-ax86-qos-upnp-01-jpg.31904
 
Last edited:
Run netstat -nlp | grep 1900. If it shows nothing listening on that port then there's something wrong with your testing method.
This is what I get back...

1685798993009.png
 
Try testing your ports at Shields Up see what that shows.

I have no doubt that nothing is responding to this port, no services running etc... it just IRKS me that the port remains open for some reason.

1685799129792.png


Why on earth have you got all that stuff running ?

LOL. It's quite lean compared to what you find others running in this forum. ;)
 
I have no doubt that nothing is responding to this port, no services running etc... it just IRKS me that the port remains open for some reason.

If the port was open it would have failed the test.
 
If the port was open it would have failed the test.
I know nothing is going to respond from it... nothing seems to be running. I just want to get rid of this port. It's open, it's sitting there... it shouldn't be. I blame my OCD for wanting things clean and tidy. ;)
 
So that port is being used by the wireless system, not UPnP. My guess is that it's part of AiMesh as I don't see that on my stand-alone router.
I don't use AiMesh (unless something is enabled in the background by default?)... and why would it only be present for UDP on WAN0?
 
@Viktor Jaep can run anything because he knows what it is and how to fix when in breaks.

Some other users have no good answer to this question and run it because they see guys like Viktor running it.
LOL this better not devolve into RTRHTR v1.1 again. :p
 
I don't use AiMesh (unless something is enabled in the background by default?)... and why would it only be present for UDP on WAN0?
Sorry, I don't know anything about your setup or how you're testing this. Your signature says you're using AiMesh so I assumed you were.
 
Sorry, I don't know anything about your setup or how you're testing this. Your signature says you're using AiMesh so I assumed you were.
LOL... close! Google Nest Wifi PRO Router + 3 PRO Mesh Nodes (Prod) ;)

This is the command I'm running:

Code:
nmap -sU <insert WAN IP> | grep "open"
 
As I said in post #9, it's your wireless subsystem, hostapd. You probably have WPS enabled.
OMG... @ColinTaylor to the rescue... THANK YOU!

It was WPS... how could I have overlooked that big gaping security hole... :(

New results:
1685816527484.png
 

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top