Requesting assistance // New RT AX86U - Unable to connect IOT devices //

Smvb64

New Around Here
Hello All,

I am running into some trouble connecting IOT devices. I want to ask you guys for assistance.

I recently purchased an AX86U to replace my aging AC68U. I updated the router to the latest stock firmware the installed the latest build of ASUS WRT Merlin (386.7)

For the IOT's I want to have them on a guest network not to connect to my local network/server.


1656875944634.png


1656875983174.png


1656876045077.png


1656876082080.png


These are my current setting, I adjust some settings as recommended online to help with IOT devices.

At the moment I am trying to connect a Nano Leaf panel and Lenovo smart clock. Both devices do connect to the network but the phone isn't able to access them. It recommends having AP isolation disabled which it is. I have these devices on the network but with no way to access them

On my older router, it did connect but was very finicky where it would lose connection often.

Any suggestions I should try?

Thanks, guys

Best,
Sm
 

bbunge

Part of the Furniture
First, go back to the default WIFI settings. Use Dual Band SmartConnect, 2.4 on Auto channel at 20/40 MHz (or just 20 MHz if you are in an area with lots of router "neighbors"), 5 GHz on Auto channel at 20-40-80-160 MHz (enable DFS channels if you want). Newer iOS devices will support WPA3 do set Authentication Method to WPA2/WPA3-Personal. Shorten the SSID to eight to ten alpha/numeric characters (no special characters or spaces) and use a WPA Pre-Shared Key of eight to ten alpha/numeric characters (again no special characters or spaces). If you have older devices as I have set a guest WIFI with just WPA2-Personal.

I have iPhone, iPod Touch and Mac Mini as well as WIndows and Linux devices. All work well with these settings. I feel that the more WIFI settings are changed the more people have trouble. Also, if DFS channels are enabled it can take several minutes for the router to clear RADAR and even longer for clients to switch from 2.4 GHz to 5 GHz but it will happen.
You spent the big bucks for a good router. Let it work for you!
 

Tech9

Part of the Furniture
Any suggestions I should try?

After installing Asuswrt-Merlin I would reset the router to factory default + initialize, do minimum configuration, format jffs in System, reboot. Then I would use Guest Network 2 instead and disable in Professional the following:

Roaming Assistant
TX Bursting
WMM APSD
Modulation Scheme to 802.11n
Beamforming

If no legacy G devices are expected to connect to the 2.4GHz band, set N Only for Wireless Mode in General.

Setting USB Mode to USB 2.0 may reduce the interference with 2.4GHz Wi-Fi a bit, if you have USB attached storage.

Ignore @bbunge advice above for SmartConnect, Auto channel, DFS channels, 160MHz and WPA3 in order to save further trouble and frustration. :)
 

Tech9

Part of the Furniture
I have these devices on the network but with no way to access them

You wanted them isolated from your Main network. Your phone is connected to your Main network. YazFi script may help you.
 

OzarkEdge

Part of the Furniture
At the moment I am trying to connect a Nano Leaf panel and Lenovo smart clock. Both devices do connect to the network but the phone isn't able to access them.

Is the phone connecting to the same guest WLAN (no intranet access) as the IoT?

OE
 

Smvb64

New Around Here
After installing Asuswrt-Merlin I would reset the router to factory default + initialize, do minimum configuration, format jffs in System, reboot. Then I would use Guest Network 2 instead and disable in Professional the following:

Roaming Assistant
TX Bursting
WMM APSD
Modulation Scheme to 802.11n
Beamforming

If no legacy G devices are expected to connect to the 2.4GHz band, set N Only for Wireless Mode in General.

Setting USB Mode to USB 2.0 may reduce the interference with 2.4GHz Wi-Fi a bit, if you have USB attached storage.

Ignore @bbunge advice above for SmartConnect, Auto channel, DFS channels, 160MHz and WPA3 in order to save further trouble and frustration. :)
Thank you all for your advice - I did a factory format - format Jiff - use Guest network 2 and disabled the following
Please see below


1656882763343.png



1656882929125.png

Unfortunately, I get the same error message
1656883604492.png


I currently connect to my guest network on my phone to communicate with the IOT devices.

Best
SM
 

Attachments

  • 1656883085202.png
    1656883085202.png
    65.5 KB · Views: 23
Last edited:

Crimliar

Regular Contributor
While I'm good at being stupid at times, it would seem to me that the initial situation could have arisen from "Access Intranet: Disabled". That setting would have prevented the device you were using to set up the IoT devices from being seen! If you switch to using YazFi, you'll at least need to allow full intranet access (with the phone you use for the setup logged into the same guest WiFi) while you set the IOT devices up. Once set up, you can flick intranet access switch to a suitable setting.
As I said I'm good at being stupid, being wrong, and reading what I want to read, rather than what's been written...
 

Smvb64

New Around Here
While I'm good at being stupid at times, it would seem to me that the initial situation could have arisen from "Access Intranet: Disabled". That setting would have prevented the device you were using to set up the IoT devices from being seen! If you switch to using YazFi, you'll at least need to allow full intranet access (with the phone you use for the setup logged into the same guest WiFi) while you set the IOT devices up. Once set up, you can flick intranet access switch to a suitable setting.
As I said I'm good at being stupid, being wrong, and reading what I want to read, rather than what's been written...
Interestingly enough, on my initial setup, I did have it enabled but had the same error message. After the factory reset and changes above were made, enabling it did work! Thanks man. I think I'm going to look into using YazFi as well. Looks like it gives a ton of more control.
 

Tech9

Part of the Furniture
enabling it did work!

Well... with Access Intranet enabled this Guest Network turns into just another SSID of your main network.
 

Smvb64

New Around Here
Well... with Access Intranet enabled this Guest Network turns into just another SSID of your main network.
For sure - after the initial setup was complete - I disabled it again, now it's off the local network and I am to use the clock and panels with my voice. If I need to update or configure the IOTs from my phone, ill enable the intranet for a few moments.

That being said can the YazFi script help me always have access to the IOTs? I don't mind doing it the way I mentioned but would be neat to always have access
 

Tech9

Part of the Furniture
That being said can the YazFi script help me always have access to the IOTs?

Check it out and see if you can use it in your case. I remember options for one way communication to guest network. It's in AMTM.
 

Smvb64

New Around Here
Check it out and see if you can use it in your case. I remember options for one way communication to guest network. It's in AMTM.
Perfect, thank you, I'll give it a try.

One question regarding 2.4ghz changes

Roaming Assistant
TX Bursting
WMM APSD
Modulation Scheme to 802.11n
Beamforming

Should I mirror these changes on the 5GHZ network as well?
 

Tech9

Part of the Furniture
No. I'm assuming you have AX mode enabled:

Disabled:
Roaming Assistant
TX Bursting
Universal Beamforming

Enabled:
WMM APSD
Modulation Scheme to MCS 11
User MU-MIMO
OFDMA/802.11ax MU-MIMO
802.11ax/ac Beamforming
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top