Ring doorbell strange issues (laggyness and wacky ping results)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Make WiFi Great Again

Regular Contributor
So I have a few problem with a Ring first generation doorbell.

First problem is that during doorbell setup DHCP mode fails every time. only static works. static ip would be ok except it means the doorbell doesnt show up on asus device list on the main index.asp page so I would really like to have it using dhcp mode. However I think I might be barking up the wrong forum-tree and I may need to find a Ring forum to get help for these problems. Reason for posting this here was that I hoped a might throw a Heil-Mary and one of yous gents might have recognized my problems and had an easy solution. So this is that pass.

Second problem, is that after setup in static mode the Ring doorbell works ok but it is massively laggy and has poor quality video and sound which probably means a low quality wireless link. And i have this wacky ping results. Check out the MS response time slowly creep up. Ive never seen this before.


________________________________________________________________________________________________________
This is me at my laptop on a 866mbps WiFi link pinging the Ring Doorbell.

[email protected]:~$ ping 192.168.120.9
PING 192.168.120.9 (192.168.120.9) 56(84) bytes of data.
From 192.168.120.16 icmp_seq=1 Destination Host Unreachable
From 192.168.120.16 icmp_seq=2 Destination Host Unreachable
From 192.168.120.16 icmp_seq=3 Destination Host Unreachable
64 bytes from 192.168.120.9: icmp_seq=4 ttl=128 time=1176 ms
64 bytes from 192.168.120.9: icmp_seq=5 ttl=128 time=152 ms
64 bytes from 192.168.120.9: icmp_seq=6 ttl=128 time=173 ms
64 bytes from 192.168.120.9: icmp_seq=7 ttl=128 time=195 ms
64 bytes from 192.168.120.9: icmp_seq=8 ttl=128 time=218 ms
64 bytes from 192.168.120.9: icmp_seq=9 ttl=128 time=242 ms
64 bytes from 192.168.120.9: icmp_seq=10 ttl=128 time=267 ms
64 bytes from 192.168.120.9: icmp_seq=11 ttl=128 time=290 ms
64 bytes from 192.168.120.9: icmp_seq=12 ttl=128 time=313 ms
64 bytes from 192.168.120.9: icmp_seq=13 ttl=128 time=337 ms
64 bytes from 192.168.120.9: icmp_seq=14 ttl=128 time=361 ms
64 bytes from 192.168.120.9: icmp_seq=15 ttl=128 time=385 ms
64 bytes from 192.168.120.9: icmp_seq=16 ttl=128 time=409 ms
64 bytes from 192.168.120.9: icmp_seq=17 ttl=128 time=432 ms
64 bytes from 192.168.120.9: icmp_seq=18 ttl=128 time=456 ms
64 bytes from 192.168.120.9: icmp_seq=19 ttl=128 time=480 ms
64 bytes from 192.168.120.9: icmp_seq=20 ttl=128 time=504 ms
64 bytes from 192.168.120.9: icmp_seq=21 ttl=128 time=16.7 ms
64 bytes from 192.168.120.9: icmp_seq=22 ttl=128 time=39.0 ms
64 bytes from 192.168.120.9: icmp_seq=23 ttl=128 time=62.7 ms
64 bytes from 192.168.120.9: icmp_seq=24 ttl=128 time=85.7 ms
64 bytes from 192.168.120.9: icmp_seq=25 ttl=128 time=109 ms
64 bytes from 192.168.120.9: icmp_seq=26 ttl=128 time=132 ms
64 bytes from 192.168.120.9: icmp_seq=27 ttl=128 time=158 ms
64 bytes from 192.168.120.9: icmp_seq=28 ttl=128 time=180 ms
64 bytes from 192.168.120.9: icmp_seq=29 ttl=128 time=204 ms
64 bytes from 192.168.120.9: icmp_seq=30 ttl=128 time=228 ms
64 bytes from 192.168.120.9: icmp_seq=31 ttl=128 time=253 ms
64 bytes from 192.168.120.9: icmp_seq=32 ttl=128 time=276 ms
64 bytes from 192.168.120.9: icmp_seq=33 ttl=128 time=299 ms
64 bytes from 192.168.120.9: icmp_seq=34 ttl=128 time=324 ms
64 bytes from 192.168.120.9: icmp_seq=35 ttl=128 time=347 ms
64 bytes from 192.168.120.9: icmp_seq=36 ttl=128 time=370 ms
64 bytes from 192.168.120.9: icmp_seq=37 ttl=128 time=394 ms
64 bytes from 192.168.120.9: icmp_seq=38 ttl=128 time=417 ms
64 bytes from 192.168.120.9: icmp_seq=39 ttl=128 time=443 ms
64 bytes from 192.168.120.9: icmp_seq=40 ttl=128 time=465 ms
64 bytes from 192.168.120.9: icmp_seq=41 ttl=128 time=488 ms
64 bytes from 192.168.120.9: icmp_seq=42 ttl=128 time=512 ms
64 bytes from 192.168.120.9: icmp_seq=43 ttl=128 time=24.1 ms
64 bytes from 192.168.120.9: icmp_seq=44 ttl=128 time=576 ms
64 bytes from 192.168.120.9: icmp_seq=45 ttl=128 time=87.2 ms
64 bytes from 192.168.120.9: icmp_seq=46 ttl=128 time=96.0 ms
^C
--- 192.168.120.9 ping statistics ---
46 packets transmitted, 43 received, +3 errors, 6.52174% packet loss, time 136ms
rtt min/avg/max/mdev = 16.665/301.804/1175.816/200.706 ms, pipe 4

[email protected]:~$

Ping times are very similar if i SSH into the Main router and ping the ring Doorbell. Just a little bit lower overall. ping times are normal for everything else.

Main router/Aimesh Master= 68u on Merlin 386.2_1
1 Wireless Aimesh node = 68u on Merlin 386.2_1
1 Wireless Repeater = 68u on Johns fork 47EB
1 Wired Access Point = Fresh Tomato 2021.1

Thank you in advance.
 

brummygit

Very Senior Member
I have a number of ring devices on my network. Firstly I find them to be generally quite poor with regard to their WiFi implementation - Ring advise you to gave RSSI readings that are only achievable if the device is sat next to your wireless router - something that just isn't possible with externally mounted devices such as cameras and doorbells.

Having said that I do have mine working quite well now. Here are some of my thoughts:

  • Ring wifi is as deaf as your 105 year old grandma - make sure you have a wifi transmitter close enough to get a half reasonable signal
  • Most Ring devices work on 2.4Ghz wifi only - other than my Doorbell Pro, all my devices are 2.4Ghz
  • I've had some issues with AiMesh 2.0 on 2.4Ghz giving poor performance. Appalling speed test results and packet loss - the forums have numerous posts about similar problem, they are not Merlin specific and only occur on some models. This will cause big problems for your ring devices so make sure a PC or phone can work well on your 2.4Ghz network
  • On my iPhone I have a second Ring app called "Rapid Ring" and this seems to be much better at getting Live Stream activated - I still have issues from time to time with Live Stream on my laptop or using the normal Ring app on my iPhone
  • If I use QoS (I like Cake) I find it causes more issues with Live Stream - not sure why, but if I have my download bandwidth set to unlimited things are better
  • Ring devices don't like busy networks - if you can isolate the device, or put it in a guest network that can't see your main network, things work a lot better
  • Live Stream is not directly from the Ring device to your phone/laptop but instead traffic goes up to the internet servers and back down - this means that isolating the ring devices won't prevent it working
  • I searched the internet and tried lots of setting changes - to be honest most are just snake oil. You just need a fighting chance at a decent wifi signal and your 2.4Ghz network to provide a reasonable connection in terms of throughput and packet loss. I think lots of other traffic (including broadcast) causes them problems so isolation, and possibly using IGMP Snooping can ease the problems
I actually found that my ISP router works better with my Ring devices than my Asus AiMesh setup - I think this is mainly due to the recent 2.4Ghz throughput issues which I hope will be resolved along with Guest Network 1 in an Asus firmware release sometime soon.
 

brummygit

Very Senior Member
Just to add....

All of my Asus devices have wired backhaul so I found the following:

  • Configuring them all as Wired APs back to the main router fixed /the 2.4Ghz issues and was much better - but I lost the benefits of AiMesh roaming and single view of my network for all devices I have
  • Configuring them as routers (without NAT) from my main router was even better as each had less broadcast or multicast traffic - but each was on it's own IP subnet so even worse than using APs as far as roaming and management of my entire network is concerned
  • I tried to use guest networks - but was bitten by the current Asus bug
  • As per my previous post Live Stream is not directly from the Ring device to your phone/laptop but instead traffic goes up to the internet servers and back down - so pings between your laptop and your Ring devices don't tell you the whole story
 

ttgapers

Senior Member
I have my Ring devices on Guest Network 2 - for IoT devices on 2.4 Ghz. I do also use Cake for QoS - however I think much of the flakiness with Ring is the proximity and the chime wifi extender network as you mentioned. I have my Ecobee on the same network and have little to no issues.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top