Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

[ROG Rapture GT-AC5300] Issue mounting USB HDD (cannot see data via Samba) after unmount via GUI

Discussion in 'ASUS AC Routers & Adapters' started by shadeyhk, Sep 13, 2017.

  1. shadeyhk

    shadeyhk New Around Here

    Joined:
    Sep 13, 2017
    Messages:
    1
    Previously connected a USB3 WD My Passport 3TB HDD (exFAT4 formatted) to the GT-AC5300 Wanted to have a networked HDD on the router. Installed Download Master to the HDD and downloaded a lot of Torrents. Shared it in Samba over the network to Window 7 64Bit OS computers. Copied a lot of data to the HDD from the network.

    [Noticed some Issues here]
    [ A ] The data transfer to the HDD over the network was limited to only 12 megabytes per second].

    [ B ] The user access to Samba share only permits read and write, so you can move, write and read the data but cannot delete files or folders. I used telnet to access the SSH and chmod some of the folders to allow deleting in the Download2 folder (default directory structure used by Download Master)


    I wanted to readjust the cabling around the router so I selected unmount USB HDD via the router GUI. After the unmount, I disconnected the HDD. Tried to re-mount. The router wasn't having it. It detected the HDD but the status was unmounted. Fine, so I soft reset the router and tried reconnecting the HDD, nope still no mounting. OKAY, power-off reset and reconnected the HDD router spent 20 minutes trying to mount, during this time the router GUI was inaccessible. Eventually, the HDD was mounted BUT here comes the real problem.

    [ 1 ] The router does not detect the previous instance of Download Master (DM) on the HDD, so the option to re-enable DM is not available, I can only select install DM to HDD. (So not done that yet)

    [ 2 ] The data (torrents/stuff copied over) on the router is no longer accessible via Samba after sharing.

    [ 3 ] The little bar that indicates HDD capacity usage is working and correctly indicates the rough percentage of capacity usage at the point of unmounting. So the data seems to be there but cannot access.

    [ 4 ] The data is definitely still on the HDD as browsed by using DiskInternals utility to read the exFAT4 partition in Windows OS, so copying the data back over to a computer is not an issue.

    I just want to reconnect the HDD and get DM detectable and working along with all the data accessible via Samba. It appears somehow the file permissions on the drive has changed so the Linux OS on the router is not allowing reading, but that is my assumption.

    Have not resulted to a factory reset. It seems silly that the router cannot read the state HDD as at unmount point.

    Would appreciate alternative insights and solutions.
     
    Last edited: Sep 13, 2017

Share This Page