[Root Cause Found] RT-AX88U Can't get link speed over 866.7Mbps with AX210 or AC-9260 WIFI in laptops (160MHz)

vdemarco

Senior Member
That's so weird! Channels 120 to 128 are legal in the US. It's as if they gave you the nerfed Canadian versions and depriving you of the 160MHz band in channels 100 to 128.
I ran the wifi radar and i see my neighbors (mostly) not using channels from 100 to 128 either. Is there some way to check if we have a Canadian version??
 

disjt

Occasional Visitor
I ran the wifi radar and i see my neighbors (mostly) not using channels from 100 to 128 either. Is there some way to check if we have a Canadian version??
Maybe it's just an AX88U thing. The set of available DFS channels varies by routers given business decisions. For example (in Canada from memory):
1. the AX86U has the full legal set of DFS channels 52-64, 100-112, 116, 132-144
2. the AX92U only has 100-112, 116, 132-144
3. the AX82U only has 52-64
4. the AX68U doesn't support DFS

I only know of 2 way to check the region lock: checking the nvram values by ssh'ing into your router, or looking at the box and finding the address (there will be the Taiwan and the Canadian addresses). But, since 2 US-purchased routers lack those channels, it's more than likely that it might just be an AX88U thing.
 

disjt

Occasional Visitor
Well that is part of the problem, my control channels are Auto, 36, 40, 44, 48 then it jumps to 149, 153, 157, 161, 165 and that is it. How do I force 52-64?

TY.
Oh, it doesn't let you choose any of the DFS channels. That's weird. This post shows what you should be seeing (maybe without the 100-128 channels since you don't have 120-128).
 

Hawk

Very Senior Member
Well that is part of the problem, my control channels are Auto, 36, 40, 44, 48 then it jumps to 149, 153, 157, 161, 165 and that is it. How do I force 52-64?

TY.
If these are the only channels you have access to, then you will not have access 160 Mhz wide channel. Thus link rate you see is max for two stream radio at 80MHz wide channel.
 

disjt

Occasional Visitor
If these are the only channels you have access to, then you will not have access 160 Mhz wide channel. Thus link rate you see is max for two stream radio at 80MHz wide channel.
His wireless log was showing 52-64. So he should technically be able to get 160MHz if no radar is being detected. Is there a way to force the router to listen on the DFS channels? I believe the "DFS status: state IDLE time elapsed 0ms radar channel cleared by DFS none" part of the log shows that the router isn't even checking.
 

Hawk

Very Senior Member
His wireless log was showing 52-64. So he should technically be able to get 160MHz if no radar is being detected. Is there a way to force the router to listen on the DFS channels? I believe the "DFS status: state IDLE time elapsed 0ms radar channel cleared by DFS none" part of the log shows that the router isn't even checking.
I was going by channel he posted, few posts back.
 

kittmaster

Occasional Visitor
Oh, it doesn't let you choose any of the DFS channels. That's weird. This post shows what you should be seeing (maybe without the 100-128 channels since you don't have 120-128).
I saw that image in the quest to figure out what is going on. I don't understand why the list isn't complete. From what people are saying thus far, those channels seem to be allowable to use, but the router isn't letting them.

I just verified, I bought the router from Newegg on 4/9/2020. Not sure if that plays into anything or not?

I hear they are not region specific, but could it be? Is there some way to check the label to determine if I have an out of region unit? I thought I read that the firmware determine where it is and reacts accordingly.

If it is a region thing, that may explain this wonkyness......and I will be unhappy of course.
 

vdemarco

Senior Member
Maybe it's just an AX88U thing. The set of available DFS channels varies by routers given business decisions. For example (in Canada from memory):
1. the AX86U has the full legal set of DFS channels 52-64, 100-112, 116, 132-144
2. the AX92U only has 100-112, 116, 132-144
3. the AX82U only has 52-64
4. the AX68U doesn't support DFS

I only know of 2 way to check the region lock: checking the nvram values by ssh'ing into your router, or looking at the box and finding the address (there will be the Taiwan and the Canadian addresses). But, since 2 US-purchased routers lack those channels, it's more than likely that it might just be an AX88U thing.
I went into my router and did this


Code:
[email protected]:/tmp/home/root# nvram show | grep country
modem_country=
wl0_country_code=US
wl0_country_rev=823
wl1_country_code=US
wl1_country_rev=823
size: 77896 bytes (53176 left)
wl_country_code=US
wl_country_rev=823
[email protected]:/tmp/home/root#


It all looks like its from US to me.
 

dev_null

Senior Member
I will share an anecdotal observation: on my AX86U, I always force a DFS channel (either 100/104/108) because our neighborhood is chock full of non-DFS APs (thanks Xfinity!). On occasion, the router picks up a "signal" (likely not real, since I'm not near any airports or other radar-generating facilities) and kicks me to 36/80 or 149/80. I have a script that notifies me of the change and will go back in and re-choose the channel and width.

One time however, when I logged back to revert the channel, all the DFS channels were missing - no longer on the list of available channels. And nothing I could do would convince the router to give them back, short of a reset (even a cold reboot didn't help).

So the lesson might be: reset (more granularly: backup then reset; that way if the reset doesn't help you can restore to your current working condition).
 

kittmaster

Occasional Visitor
Yes, but part of my problem is I've never even seen the blocked off channels to be able to have them as a selection to be able to restore.

I'm unclear as I've left it on channel 36 for the last 18 hours and nothing has changed....still at 866.7Mbps.

I could see if the channels where saying like above: reset and wait for XXX minutes.....I've never even seen that...I'm scratching my head as to why it doesn't even "try" to use the 160MHz or where is the "Extended NSS" feature that even Asus is telling people to activate as part of the process....my router doesn't have that option.....so what gives......errrrrrrrr.
 

disjt

Occasional Visitor
The extended NSS might just have been a canned-answer from tech support since there's a mention on the support page. It is not in the AX88U user manual. It might be device specific and it seems to be for 160 MHz compatibility only. It shouldn't prevent your router from doing 160 MHz.
 

kittmaster

Occasional Visitor
The extended NSS might just have been a canned-answer from tech support since there's a mention on the support page. It is not in the AX88U user manual. It might be device specific and it seems to be for 160 MHz compatibility only. It shouldn't prevent your router from doing 160 MHz.
I had seen it here:


Which is why I thought it might have been an issue.
 

OzarkEdge

Part of the Furniture

kittmaster

Occasional Visitor
RT-AX88U....

Directly from the tech support email, they specifically told to be enable the setting "Extended NSS" within the email....soooooooooo. That is why started looking around and landed here after I tried the Merlin Firmware to see if it may have fixed the issue. Some say it works, others say it doesn't..... from all that has been said it should be working even with the DFS bands showing....but it isn't.

Their own tech support told me to enable the option which means there may be an issue somewhere that has been missed and i've told them that the option doesn't exist on my router....hopefully they can help me sort it out.....or you folks with more experience about it.

So that is why I pointed to that link because it is exactly what Asus told me to do within their support email.
 

ColinTaylor

Part of the Furniture
No one has yet to point out the added question about " What about the missing Extended NSS" option?
I suspect the reason it's missing is because that FAQ is for the RT-AX89X which is a Qualcomm device. I'm guessing that option is not applicable to the other models which are Broadcom devices.

EDIT: We can see here that that option only appears for devices with an internal modelid of GT-AXY16000 or RT-AX89U.
 
Last edited:

synapse46

Occasional Visitor
So I was just about to make a post about my AX86S and saw this thread. I could not get my laptops to connect above 866 when I first got the router, figured well enough. Today I decided to try turning on 802.11ax / WiFi 6 mode, my laptop then would only connect at 54, so I turned 802.11ax / WiFi 6 mode off and now two of my laptops are connecting at 1.7Gbps. Not sure if this helps you any. I was going to post a thread to see if anybody has an idea what happened.
 

paulbates

Regular Contributor
That's so weird! Channels 120 to 128 are legal in the US. It's as if they gave you the nerfed Canadian versions and depriving you of the 160MHz band in channels 100 to 128.
I live less than 6 linear miles from DTW, one of the largest airports in the US. All of the channels are open to me and my details have reported the same as OP (et al) since I set up AX88 a over a week ago. I've not yet caught it temporarily disabling a channel in the details or the main log. I have been leaving it alone mostly, I'll keep an eye on the "radar channel cleared" and see if I can catch it happening.. no reason to believe it is but don't know.

This thread is very helpful.


Channel Information
----------------------------------------
Channel 36 A Band
Channel 40 A Band
Channel 44 A Band
Channel 48 A Band
Channel 52 A Band, RADAR Sensitive
Channel 56 A Band, RADAR Sensitive
Channel 60 A Band, RADAR Sensitive
Channel 64 A Band, RADAR Sensitive
Channel 100 A Band, RADAR Sensitive, Passive
Channel 104 A Band, RADAR Sensitive, Passive
Channel 108 A Band, RADAR Sensitive, Passive
Channel 112 A Band, RADAR Sensitive, Passive
Channel 116 A Band, RADAR Sensitive, Passive
Channel 120 A Band, RADAR Sensitive, Passive
Channel 124 A Band, RADAR Sensitive, Passive
Channel 128 A Band, RADAR Sensitive, Passive
Channel 132 A Band, RADAR Sensitive, Passive
Channel 136 A Band, RADAR Sensitive, Passive
Channel 140 A Band, RADAR Sensitive, Passive
Channel 144 A Band, RADAR Sensitive, Passive
Channel 149 A Band
Channel 153 A Band
Channel 157 A Band
Channel 161 A Band
Channel 165 A Band


I just verified, I bought the router from Newegg on 4/9/2020. Not sure if that plays into anything or not?
I've had mine just over a week (B&H), and do not have that option either. Its hard to know how old the unit on anyone's shelf it.
I think that chipset explanation is the most logical and Asus's KM is out of sync for this.
 

kittmaster

Occasional Visitor
So I was just about to make a post about my AX86S and saw this thread. I could not get my laptops to connect above 866 when I first got the router, figured well enough. Today I decided to try turning on 802.11ax / WiFi 6 mode, my laptop then would only connect at 54, so I turned 802.11ax / WiFi 6 mode off and now two of my laptops are connecting at 1.7Gbps. Not sure if this helps you any. I was going to post a thread to see if anybody has an idea what happened.
I just turned it off here and the bw went back to 20/40/80....on Ch36. connects at 866.7. Will wait to see if anything changes
 

paulbates

Regular Contributor
I just turned it off here and the bw went back to 20/40/80....on Ch36. connects at 866.7. Will wait to see if anything changes

I have it set to AX and set to 160 in the drop down. Clients that can connect at 160 do, and the rest adjust to what they can do. I'm surprised by the ipad, its pretty old.

1642861346251.png



I wouldn't lose site of actual throughput, testing at the app level on the client (speedtest, etc). Adjusting for speed at this level doesn't change a whole lot, at least for me. That older Familyroom windows workstation at the top won't use half of the 1GB posted, not matter how I set 5ghz settings. And the Pixel smokes the lot of them by far... 600mb service and its clocked over 700, again, 5ghz settings don't really change that; I guess it depends on the ISP service you have.
 

Attachments

  • 1642861303879.png
    1642861303879.png
    50.1 KB · Views: 55

kittmaster

Occasional Visitor
I have it set to AX and set to 160 in the drop down. Clients that can connect at 160 do, and the rest adjust to what they can do. I'm surprised by the ipad, its pretty old.

View attachment 38791


I wouldn't lose site of actual throughput, testing at the app level on the client (speedtest, etc). Adjusting for speed at this level doesn't change a whole lot, at least for me. That older Familyroom windows workstation at the top won't use half of the 1GB posted, not matter how I set 5ghz settings. And the Pixel smokes the lot of them by far... 600mb service and its clocked over 700, again, 5ghz settings don't really change that; I guess it depends on the ISP service you have.

What does your wireless log look like? Does it have radar sensitive channels active as I have or totally clear? Just trying to get a handle why this thing won't connect any of my AX devices at 160Mhz....all max at 866.7 or 1200 ish... Thanks for the images, at least I know it "should" work.... LOL.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top