1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Router running VPN Server - Can't access router page or devices

Discussion in 'VPN' started by bizzaro, May 23, 2019.

  1. bizzaro

    bizzaro New Around Here

    Joined:
    May 23, 2019
    Messages:
    4
    I'm trying to set up a VPN server on my router so that I can access my router settings and devices on my lan while I'm away. I followed the instructions here. My current settings look like this. I exported the config file and was able to connect and could access the internet on both my phone and laptop, but if I try to access the router page it just loads and loads. Is there a setting there that I'm missing or got wrong?
     
  2. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,397
    First, hit the Default button on the bottom of the page.

    Only change the following leaving all other defaults as-is.

    Set RSA Encryption to 2048 bit, and set Manage Client Specific Options to Yes. Set Allow Client to Client to Yes.

    Hit Apply and then Export the OpenVPN Configuration file.

    This is all that is needed.

    Test that the above works and customize past this while testing and keeping notes of your changes.

    After successfully creating a configuration that works as you want, leave the router running for about 15 minutes afterward and then reboot and test again. The reboot will ensure you have the most stable server/router possible. :)
     
  3. bizzaro

    bizzaro New Around Here

    Joined:
    May 23, 2019
    Messages:
    4
    I did as you said and added a username and password to the list. I tried connecting using the OpenVPN app on my iphone with the wifi turned off, but now it won't even connect to the server.
     
  4. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,397
    Is your phone on LTE and not on WiFi? Did you download the latest ovpn file you created on it?
     
  5. bizzaro

    bizzaro New Around Here

    Joined:
    May 23, 2019
    Messages:
    4
    Yes and yes. After about a minute or two of trying to connect it tells me "There was an error attempting to connect to the selected server."

    From the log:
    "Transport Error: DNS resolve error on 'nextcloud' for UDP session: DNS/RRset does not exist"

    So maybe it has something to do with the DDNS script I'm running? I'm using this.
     
  6. bizzaro

    bizzaro New Around Here

    Joined:
    May 23, 2019
    Messages:
    4
    Oh, right. I needed to edit the config file and correct the host name.

    Sweet, I got it working and I can now access the router page, as well as the device I was trying to reach. Thanks!
     
    L&LD likes this.