RT-86U slow DHCP resolution? *RESOLVED*

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

tommyv2

Regular Contributor
Had this device for a few months. Had stock firmware and now on Merlin 384.4, but the behaviour is all the same. I'm getting slow DHCP resolution on several Windows computers, slow enough that I can log in and get to the desktop and they still won't have a network connection. These are all hardwired, Intel NICs, Windows 10, etc, etc.

My previous 87U and 68U didn't seem to have an issue and Windows always showed network available right at the login screen. Any thoughts?
 

joegreat

Very Senior Member
Had this device for a few months. Had stock firmware and now on Merlin 384.4, but the behaviour is all the same. I'm getting slow DHCP resolution on several Windows computers, slow enough that I can log in and get to the desktop and they still won't have a network connection. These are all hardwired, Intel NICs, Windows 10, etc, etc.

My previous 87U and 68U didn't seem to have an issue and Windows always showed network available right at the login screen. Any thoughts?
Maybe related to the topic discussed here?
You apply the suggested dnsmasq.postconf user script - my enhanced one (I had two lines to remove) below - and then you can re-check the speed of getting an IP address.

I have the feeling that now the DHCP and network search is much faster... :cool:

Code:
#!/bin/sh
CONFIG=$1
source /usr/sbin/helper.sh

pc_delete "dhcp-option=252,\"\n\"" $CONFIG
pc_delete "dhcp-option=lan,252,\"\n\"" $CONFIG
PS.: if you want to run the script manually use this syntax: ./dnsmasq.postconf /etc/dnsmasq.conf - and: do not forget to restart dnsmasq by executing: service restart_dnsmasq
 
Last edited:

tommyv2

Regular Contributor
Maybe related to the topic discussed here?
You apply the suggested dnsmasq.postconf user script - my enhanced one (I had two lines to remove) below - and then you can re-check the speed of getting an IP address.

I have the feeling that now the DHCP and network search is much faster... :cool:

Code:
#!/bin/sh
CONFIG=$1
source /usr/sbin/helper.sh

pc_delete "dhcp-option=252,\"\n\"" $CONFIG
pc_delete "dhcp-option=lan,252,\"\n\"" $CONFIG
PS.: if you want to run postconf script manually use this syntax: ./dnsmasq.postconf /etc/dnsmasq.conf - and: do not forget to restart dnsmasq by executing: service restart_dnsmasq
Thanks for the info! I'm not really sure how to try this, as it looks a bit over my head. Hopefully this fix goes into a future version that will be a bit easier to use for us non-advanced users.
 

ColinTaylor

Part of the Furniture
If what @joegreat has described is your problem you can try fixing it in Windows.

Go to Control Panel > Internet Options > Connections > LAN Settings and un-check "Automatically detect settings".
 

tommyv2

Regular Contributor
If what @joegreat has described is your problem you can try fixing it in Windows.

Go to Control Panel > Internet Options > Connections > LAN Settings and un-check "Automatically detect settings".
Thanks. That can't be it; I've always had that disabled on all my computers.

Super annoying, as even an older (but freshly formatted and SSD) Dell Optiplex 780 is able to boot, auto-login and sit at the desktop and still not have an IP address in time.

Is there a command I can put into the router to test this, or having it run the conf file is the only way?
 

joegreat

Very Senior Member
Is there a command I can put into the router to test this, or having it run the conf file is the only way?
Read above posting 'til the END!
Hopefully this fix goes into a future version that will be a bit easier to use for us non-advanced users.
As discussed in the original thread here (reading helps) Merlin promised to do the change in one of his next firmware releases.
 

tommyv2

Regular Contributor
Read above posting 'til the END!

As discussed in the original thread here (reading helps) Merlin promised to do the change in one of his next firmware releases.
Well, my reading comprehension requires me to understand the content, which I don't. The instructions the GitHub give me an idea of how it works, but not how to actually do it as I'm lost without screenshots.

Anyway, thank you for your time and help, but I'll just have to wait it out for it to be fixed some other way.
 

ColinTaylor

Part of the Furniture
You could try this as an experiment to see whether it is your problem. Log on to the router with SSH and issue the following commands:

sed -i "/dhcp-option=252/d" /etc/dnsmasq.conf
sed -i "/dhcp-option=lan,252/d" /etc/dnsmasq.conf
grep "252" /etc/dnsmasq.conf
killall dnsmasq
dnsmasq --log-async


Now reboot your PC and see if it makes any difference.
 

tommyv2

Regular Contributor
You could try this as an experiment to see whether it is your problem. Log on to the router with SSH and issue the following commands:

sed -i "/dhcp-option=252/d" /etc/dnsmasq.conf
sed -i "/dhcp-option=lan,252/d" /etc/dnsmasq.conf
grep "252" /etc/dnsmasq.conf
killall dnsmasq
dnsmasq --log-async


Now reboot your PC and see if it makes any difference.
Awesome, thank you! I'll try this as soon as I get home.
 

tommyv2

Regular Contributor
You could try this as an experiment to see whether it is your problem. Log on to the router with SSH and issue the following commands:

sed -i "/dhcp-option=252/d" /etc/dnsmasq.conf
sed -i "/dhcp-option=lan,252/d" /etc/dnsmasq.conf
grep "252" /etc/dnsmasq.conf
killall dnsmasq
dnsmasq --log-async


Now reboot your PC and see if it makes any difference.
It WORKED! Thanks SO much!
 

ColinTaylor

Part of the Furniture
It WORKED! Thanks SO much!
OK that's interesting and appears to confirm the issue linked to by @joegreat .

Bear in mind that this was just a test and if you reboot your router the changes will be lost. But I see from the source code that @RMerlin has applied the fix 4 days ago so it should be picked up with the next firmware release.
 
Last edited:

tommyv2

Regular Contributor
OK that's interesting and appears to confirm the issue linked to by @joegreat .

Bear in mind that this was just a test and if you reboot your router the changes will be lost. But I see from the source code that @RMerlin has applied the fix so it should be picked up with the next firmware release.
It's excellent. Network is ready well before I can type in the password at all times now. Glad this is getting fixed permanently, because it was the one mysterious issue that's disappointed me about the new router. All the other devices at home are Apple (and on a Ubiquiti, as I don't use the wireless from the Asus) so they've been immune, but the Windows 10 portion has been painful.

Thanks again for the commands!
 

_robodoc_

Occasional Visitor
RT-AC86U, from stock firmware to Merlin (now 384.10_2). After 2 months I encountered the same or similar problem: waiting a noticeably time for connecting to the network. Finally I flashed the latest stock firmware and restored to factory default without success. An additional observation: to access the router by PuTTY I have to add a period after the routers name from now on.

Thanks for help
 

ColinTaylor

Part of the Furniture
An additional observation: to access the router by PuTTY I have to add a period after the routers name from now on.
That indicates that DNS is not setup correctly on your network.
 

ColinTaylor

Part of the Furniture
@_robodoc_ It's possible that your problem is not the same as the one discussed in this thread. You said the problem only occurred "after 2 months", so it seems unlikely that it's anything to do with the router. What changed after 2 months?

Your DNS problem is something different.

Is this slowness effecting all of your devices or just one? If it's a Windows PC can you post the complete output of this command:
Code:
ipconfig /all
 

_robodoc_

Occasional Visitor
I noticed nothing special before the slowness happened. After discovering the problem on my Windows Laptop I restored a backup image from 2018. Since the slowness persists I suspected the router. As confirmation a occasionally used Windows PC connected to the router by cable showed same slowness.

Here the output of ipconfig /all of my Laptop (IP address of my router is 192.168.0.1)
unfortunately in german

Windows-IP-Konfiguration
Hostname . . . . . . . . . . . . : E7450
Prim„res DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein
Ethernet-Adapter Bluetooth-Netzwerkverbindung:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Bluetooth-Ger„t (PAN)
Physikalische Adresse . . . . . . : 60-57-18-5C-C5-6E
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Drahtlos-LAN-Adapter Drahtlosnetzwerkverbindung 3:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter #2
Physikalische Adresse . . . . . . : 62-57-18-5C-C5-6A
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Drahtlos-LAN-Adapter Drahtlosnetzwerkverbindung 2:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
Physikalische Adresse . . . . . . : 62-57-18-5C-C5-6B
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Drahtlos-LAN-Adapter Drahtlosnetzwerkverbindung:
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 7265
Physikalische Adresse . . . . . . : 60-57-18-5C-C5-6A
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::58f7:991a:158e:189f%12(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 192.168.0.59(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Lease erhalten. . . . . . . . . . : Montag, 15. April 2019 21:58:27
Lease l„uft ab. . . . . . . . . . : Dienstag, 16. April 2019 21:58:27
Standardgateway . . . . . . . . . : 192.168.0.1
DHCP-Server . . . . . . . . . . . : 192.168.0.1
DHCPv6-IAID . . . . . . . . . . . : 358635288
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-1D-A5-8A-E6-34-E6-D7-33-D3-55
DNS-Server . . . . . . . . . . . : 192.168.0.1
NetBIOS ber TCP/IP . . . . . . . : Aktiviert
Ethernet-Adapter LAN-Verbindung:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Intel(R) Ethernet Connection (3) I218-LM
Physikalische Adresse . . . . . . : 34-E6-D7-33-D3-55
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Tunneladapter isatap.{307ADF9A-3689-4F7C-869A-C9C2616B2780}:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #3
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Tunneladapter Teredo Tunneling Pseudo-Interface:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Tunneladapter isatap.{3572D7E3-A61D-4F98-8A62-3A78313A74C0}:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #11
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Tunneladapter isatap.{0233FDBD-0ECC-440A-BE04-B136AB42031B}:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #17
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Tunneladapter isatap.{EEFE2DA3-7F70-4CBB-95B0-DD3B5EEB5E80}:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #18
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Tunneladapter isatap.{F6369A24-5A6C-4045-849B-144D884FC60C}:
Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #19
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja


Thank you for dealing with my problem
 

ColinTaylor

Part of the Furniture
That all looks correct. Can you explain in more detail exactly what the problem is.

Do you have any other routers, access points, extenders or repeaters connected to your LAN?

Have you made any changes at all, to either the router or the PC, that would effect DNS or DHCP? That would be things like DNSFilter, VPN, etc.

What version of Windows are you using?

EDIT: Log onto your router and go to "Tools > Other Settings > Advanced Tweaks and Hacks" and change the value of "dhcpd: send empty WPAD with a carriage return". Now reboot your devices and see if it makes a difference.

EDIT 2: Regarding your PuTTY issue, go to "LAN > DHCP Server" and set something as the "Domain Name". I suggest trying "home.lan". Now reboot your PC and try using PuTTY without the ".".
 
Last edited:

_robodoc_

Occasional Visitor
Sorry for my late answer, I was blocked during writing a reply.

The PuTTY issue seems to be resolved. I set home.lan as the Domain Name. No period necessary after rebooting. After that I set the Domain Name to blank as before. Surprisingly the issue keeps resolved.
The remaining problem is a delay of about a minute for connecting to the network (spinning blue circle over the network bars in the taskbar).
Changing the value of "dhcpd: send empty WPAD with a carriage return" makes no difference.
Using Windows 7 Enterprise SP1 64bit.
I have a TP-Link TL-WA890EA Media Bridge connected. I already made sure that the built-in DHCP Server is disabled.
I did not made changes effecting DNS or DHCP.
The occasionally used PC has a dual boot configuration: same Windows 7 (affected) and
Windows XP SP3 32bit (not affected).
A Linux Laptop of a Family member is not affected too.
 

ColinTaylor

Part of the Furniture
Do you experience the same problem with the PC connected directly to the router via Ethernet cable?

Otherwise all I can suggest is that you look in the Windows Event Log and the router's syslog for clues.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top