[RT-AC3100] Internet Speed very slow

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

elrengo

Regular Contributor
Hi, I've two Asus router: RT-AC3100 as my principal router with Asus Merlin, also I run in this device rTorrent, Diversion and media server, the second is a RT-AC66U_B1 also with a Merlin firmware. Both router are wire connected. The second is configured as AP with Media Sharing both HDD connected with USB.

Last Monday the Internet Connection start to be very slow. After some test the issue is in RT-AC3100. If my laptop is connected to my ISP Cablemodem I've full internet speed (300Mb/30Mb) but with wired connection to my RT-AC3100 the speed go down to 30Mb~40Mb.
I upgrade the firmware in RT-AC3100 from Merlin firmware 384.17 move forward to 386.1 Beta 3. After do the following steps:

Before flashing new firmware.

Make a backup cfg file and label it with the firmware version currently running on the router. (I save this with the associated trx firmware file in a safe place, along with the next item, if needed).
Save any custom settings to the jffs partition in a safe place.
Remove all USB devices from the router.
Reboot via the gui and let it settle for 5 minutes after it comes up again.

Flash new (or existing) firmware.

Flash new firmware (and in some cases, re-flash the existing firmware if any random, unexplained glitches are still causing issues).
Reset to factory defaults via the gui.
After the router has rebooted (point above), do a hard reboot:

1. Turn the router off.
2. Press and hold the "WPS" button and turn the router on.
3. Power light is on (keep holding the WPS button).
4. Release the WPS button after the power LED light starts flashing.
5. Power light stops flashing and the router will automatically reboot

wait a couple of minutes and then power it up again.

After new firmware loaded.

Use the wizard to connect to your ISP.
Use new ssid's for all bands and radio's (most likely easier to do after the wizard completes for dual 5GHz band radio's capable routers). You can reuse the old passwords though.
Disable media server.
Disable network share.
Disable NFSD.
Disable FTP.
Change device name (if needed), set Force as Master Browser and indicate the Work Group name (these steps are optional for some home users).
Disable WPS.
Disable WDS.
Uncheck Xbox and B/G protection (Both bands). (B/G protection in Auto Mode is not possible to disable but yes XBOX)
Wireless Mode: Auto (default).
Control Channel: set manually after testing each channel.
Preamble Type: Short.
Spanning Tree Protocol: Disabled.
IPv6: Disabled.
Enable DoS protection: Disabled.
Set time zone to your area.
Format JFFS partition at next boot: Yes.

Also in this M&M Config I turned off:
After a wired connection between my laptop, connected to AC, and RT-AC3100 (1Gbps) the test with Internet is the same result. Also I use the SpeedTest include in new Firmware and the internet speed is diferent. The AC3100 has no wire connection except my laptop, new SSID that is not shared with noone.

Today I redo the Firmware update with the same Firmware: Merlin 386.1 Beta3. All Steps again, new SSID for Wireless, only my laptop with wired connection, no HDD Connected to the device. I feeling that has a better performance when is working on GUI but Internet Speed Test has the same result.

1609697907609.png


1609698044768.png


I do not know what is happened. Last week works fine!
Thanks for your help!
 

L&LD

Part of the Furniture
What laptop are you using? What OS? What Wi-Fi adaptor? Is the driver, and the computer fully up to date?

Is the driver for the LAN port on the laptop fully up to date? Is it the recommended driver (from the laptop's manufacturer)?

Are you powering down the modem/ONT for at least 20 minutes before plugging in the router and then turning both on? (This will reset the connection between you and your ISP).

Can you test with the RT-AC66U_B1 and see if it gives the same symptoms?

Have you checked the temperature for the wireless and the processor for the router?

Have you checked what the WAN and LAN Port connection speeds are (via the GUI)?

Can you test with another power adaptor?

Can you test with another LAN Port?

Can you test with different Cat5e or better Ethernet cables? Both between the modem/ONT and the router and between the router and the laptop.

Can you test with a switch between the LAN port and the laptop (and quality Cat5e cables on both ends)?

You may want to try another reset with either of these two links too.


 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top