RT-AC5300 & 5 GHz-2 Failure

Homith

New Around Here
Good Evening Everyone,
I have picked up second hand a Chinese import RT-AC5300. I did not understand the problems I would be faced with when getting this. Apart from strange Chinese menu items, even when changing to English, it now seems like my 5 GHz-2 band is totally non functional. Tried on both stock firmware and Merlin with the same results;

I do not even have a MAC address showing on the 5 GHz-2 band (within Network Map / System Status / System). I have made my region set to Australia (my country) and tried shutting down 5 GHz-1 and changing 5 GHz-2 to 20, 40 , 80 & 20/40/80 MHz channel bandwidth with no success at all.

Within the channel selection menu for the 5 GHz-2 band option I do not get any change to manually select anything as shown;

However for the 5 GHz-1 band I have the following channels to select from;

Here are the Professional setting for both the 5 GHz-1 & 5 GHz-2 bands in case I have missed anything;

Just wanted to reach out to you all to see if anyone knows of a trick or method to 'jump start' the 5 GHz-2 band back into life. I have performed countless resets including trying different firmware revisions with nil success.

Thanks in advance,
Cheers
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top