RT-AC5300 no UI after firmware upgrade

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

BL_BL

Occasional Visitor
Upgraded my RT-AC5300 to 3.0.0.4.384.82072 and now I cannot access the UI or rather after entering my credentials I don't get the rest of the UI with the status page etc.

App (Android) doesn't seem to be able to properly communicate either (it can fetch the firmware version etc. but not do much).

5GHz and wired seems to work fine and with full throughput.

I've power-cycled a couple of times to now avail.

Any way of fetching my settings before doing a factory reset? Have no recent backup of the settings and DHCP table etc.


TIA!
 

ATLga

Senior Member
Never had a UI issue after a Factory FW upgrade. Merlin 386.x FW takes a "minute or hours" depending on the model, but haven't seen any issues with Factory FW. I'd try another browser perhaps.

And are you saying you can login with credentials, then it displays nothing. Sounds like a browser issue, but you tried with the app too so that does sound a little wonky. Force close the android app and open it again and see if it changes.
 

BL_BL

Occasional Visitor
Thanks to both of you for your replies! :) I have the UI now. For some reason it took a lot of time before it worked. Can't seem to remember that this ever happened to any of my like 7-8 different ASUS routers I have/had after a firmware update. It wasn't a browser issue.

Now I need to update my 4 x AiMesh nodes as well (RT-AC68U).
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top