RT-AC5300 not getting gigabit speed on ethernet

setroc6

New Around Here
Hey there guys, so I recently upgraded to gigabit internet. The Ac5300 router I have had for a while now and followed some online guides to get it set up to get some decent speeds on wifi. I am getting about 450-530 Mbps on wifi on my phone and only 110 Mbps wireless on my laptop. So I tried hooking up the laptop via ethernet and still only get 560 Mbps. I am unsure if it has something to do with the settings I changed in the router or the settings in the network cards on my laptop. My laptop is a Dell Inspiron 7559 and the phone I am using for the speed tests is a Samsung Galaxy Note 10 plus. I would like to get the highest speed possible on both wired and wireless but mainly wireless. the settings I changed on the router were based on a network where there is sometimes a lot of devices connected at once. Please let me know if I am missing important information to diagnose my issue. Also, the router is on stock firmware and up to date. Thank you!

The laptop has an Intel Dual Band Wireless-AC 3165 card and the advanced settings are as follows:
802.11a/b/g Wireless mode= Dual-band 802.11a/b/g
802.11n/ac wireless mode= 802.11ac
ARP offload for WoWLAN= Enabled
Channel width for 2.4GHz= Auto
Channel width for 5GHz= Auto
Fat Channel Intolerant= Enabled
GTK rekeying for WoWLAN= Enabled
MIMO Power Save Mode= No SMPS
Mixed Mode Protection= RTS/CTS Enabled
NS offload for WoWLAN= Enabled
Packet Coalescing= Enabled
Preferred Band= Prefer 5GHz band
Roaming Aggressiveness= Medium-low
Sleep on WoWLAN Disconnect= Disabled
Throughput Booster= Enabled
Transmit Power= Highest
U-APSD support= Disabled
Wake on Magic Packet= Enabled
Wake on Pattern MAtch= Enabled

For the ethernet it has a Realtek PCIe GbE 8168 controller and the advanced settings are as follows:
Advanced EEE= Enabled
ARP offload= Enabled
Auto Disable Gigabit= Disabled
Energy Efficient Ethernet= Enabled
Flow Control= Rx & Tx Enabled
Green Ethernet= Disabled
Interrupt Moderation= Enabled
IPv4 Checksum Offload= Rx & Tx Enabled
Jumbo Frame= 9KB MTU
Large Send Offload v2 (IPv4)= Enabled
Large Send Offload v2 (IPv6)= enabled
Maximum Number of RSS Queues= 4
Network Address= Not Present
NS Offload= Enabled
Power Saving Mode= Enabled
Priority & VLAN= Priority & VLAN Enabled
Receive Buffers= 512
Receive Side Scaling= Enabled
Shutdown Wake-On-Lan= Disabled
Speed & Duplex= 1.0 Gbps Full Duplex
TCP Checksum Offload (IPv4)= Rx & Tx Enabled
TCP Checksum Offload (IPv6)= Rx & Tx Enabled
Transmit Buffers= 128
UDP Checksum Offload (IPv4)= Rx & Tx Enabled
UDP Checksum Offload (IPv6)= Rx & Tx Enabled
Wake on Magic Packet= Enabled
Wake on Magic Packet when system...= Disabled
Wake on pattern match= Enabled
WOL & Shutdown Link Speed= 10 Mbps First

Here are screenshots of the settings on my router:
https://imgur.com/a/HHtQoJw
 

Greg72

Senior Member
Swap out the old wifi card in your laptop for the 7260. The 3165 has some major issues. It was made when mfg’s thought that it would help with battery life but in turn killed modern day users speeds.
 

ColinTaylor

Part of the Furniture
I run this on my router https://github.com/sivel/speedtest-cli/blob/master/README.rst

Will show you if the problem is NAT related or not (as it goes direct to WAN).
Does this give you accurate results? I've always found that an on-router speed test gives unrepresentative results because the router cannot use hardware acceleration. For example, my LAN client can get ~360Mbps whereas the same command issued from the router only gives ~100Mbps. I would imagine the discrepancy would be even larger at gigabit speeds.
 

ColinTaylor

Part of the Furniture
You said you upgraded to "gigabit internet". Does that mean that they're actually supplying you with 1Gbps or is the 560Mbps you're seeing more realistic?

Can you plug your computer directly into the ISP's internet feed (i.e. without an intervening router) and test the "raw speed" that way?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top