1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT-AC56U firmware upgrade issue

Discussion in 'ASUS AC / AX Routers & Adapters' started by kernt, Oct 8, 2018.

  1. kernt

    kernt New Around Here

    Joined:
    Oct 8, 2018
    Messages:
    1
    I'm presently running DD-WRT v3.0-r35452 std (03/20/18). I've upgraded the firmware many times using the .trx file downloaded from ftp://ftp.dd-wrt.com/betas/ and the upgrade procedure from the DD-WRT menu.
    Suddenly I cannot do this. The first step in the upgrade process is the uploading of the .trx file to the router. The progress indicator stalls at 1% and goes no further. The file is never uploaded and the upgrade never occurs. At this point I just close the window on the laptop to clear the stalled process and manually restart the router right back to 35452.
    It's like I'm unable to write the file to the router. No error messages. Tried everything I could think of. Any ideas what might be the cause?
    If this cannot be solved I'd abandon DDWRT and go to stock ASUS. Where can I get a procedure for this?

    Thx
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. Easy Limits

    Easy Limits Occasional Visitor

    Joined:
    Jul 16, 2015
    Messages:
    44
    Location:
    WA, USA
    You should be able to download the latest stock firmware from Asus web site. Unzip the firmware file and upload to your router.
     
    ApexRon likes this.
  4. ApexRon

    ApexRon Regular Contributor

    Joined:
    Jun 17, 2018
    Messages:
    195
    Location:
    Apex, NC
    I concur with Easy Limits but I would add that the primary reason to install ASUS firmware is to validate the router hardware. Should you be successful in loading ASUS firmware then there is something wrong with the other firmware.
     
  5. LagIsPain

    LagIsPain New Around Here

    Joined:
    Oct 8, 2018
    Messages:
    4
  6. Marin

    Marin Regular Contributor

    Joined:
    Sep 15, 2015
    Messages:
    180
    Converting from DDWRT to stock FW is no easy task and you have to be very patient when you do this. Few steps to consider:

    1. Make sure that you disable Wi-Fi

    2. Assign your computer a static IP

    3. Clear your computer’s cache, browser Hx before and every time you attempt this.

    4. Connect an Ethernet cable from the computer to your router (use LAN ports-it is ok to use LAN 1 port with AC5300)

    5. With router power OFF, press the reset button for approx 5 seconds.

    6. While holding the reset button pressed, turn ON your router. Keep the reset button pressed for another 5 seconds.

    7. When the CFE window pops up, clear NVRAM settings (by clicking the link) and reboot tour router (click the other link).

    8. Repeat steps 1-6.

    7 . Wait for the CFE window to load up and load your .trx file and patiently wait until it loads completely.


    Sent from my iPhone using Tapatalk
     
  7. jontalk

    jontalk Regular Contributor

    Joined:
    Oct 8, 2014
    Messages:
    122
    Location:
    Mill Valley, CA
    I've been running stock FW on my 56U from the beginning and it's functioned flawlessly. It will download new versions if available as well :)
     
    ApexRon likes this.
  8. Pierino

    Pierino Very Senior Member

    Joined:
    Jul 13, 2012
    Messages:
    891
    Location:
    Columbus Ohio
    As I suggested on the dd-wrt forum, try a different browser.
    Or you can hold the reset button in while powering the router on. Hold it in till the power led flashes.
    Then open your browser to 192.168.1.1 and upload the firmware using the cfe mini web server, tftpd32 or the firmware restoration tool.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!