RT-AC57U V3 Merlin support

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Epi

Occasional Visitor
Hi!
I am currently running RT-AC68U + RT-AC57U V3 in AiMesh.
Based on https://www.asuswrt-merlin.net/ Asuswrt-Merlin will work only on RT-AC68U. There is no RT-AC57U V3 support.
Should I upgrade the AC57U V3 router to a different one with Asuswrt-Merlin support OR I can use still it as a node with original ASUS firmware and Merlin on AC68U?
(Wired connection between both, node used as a network extension, same wifi name etc.)
 

L&LD

Part of the Furniture
What version firmware is the RT-AC57U running?

If they're both running 386.xxx AiMesh v2.0, you should be okay. If not, time for another RT-AC68U, RT-AC66U_B1, or best, RT-AC86U (to be used as your main router).
 

Epi

Occasional Visitor
AiMesh router
RT-AC68U
Current Version : 3.0.0.4.386_41634-g08f88ae

AiMesh Node
RT-AC57U V3
Current Version : 3.0.0.4.386_21649-g7401a04

They are both 386.xxx, but I don't know is it AiMesh v2.0 or any other version.
So, pretty much I just need to upgrade my RT-AC68U to Merlin and reconnect the node? I will still get all the Merlin features (I really need Selective/Policy Routing for OpenVPN)?
 

L&LD

Part of the Furniture
No, a full reset to factory defaults is required for the most stable and reliable experience.

Please look at my last few posts for the best practice 2021 link for specifics.
 

Epi

Occasional Visitor
I did not understand your answer.
So if I will reset and put Merlin firmware on RT-AC68U and make it act as a main router and keep original firmware on RT-AC57U V3, reset it and connect it as AiMesh. Will it work? Will I be able to access all the features of Merlin? Or do I need to buy another supported router to also have it run Merlin and only then connect is as a node?
 
Last edited:

L&LD

Part of the Furniture
Sorry, I couldn't reply as fully as I should have earlier. I hope the following is clearer.

After flashing RMerlin firmware to a router with stock firmware, a full reset is highly suggested (I would state 'required').

Flash the firmware you want to use on them first, then, remove all Ethernet cables, USB devices, and the AC power plug from the router and the wall plug, and then use the appropriate method in the link below to perform the WPS Button reset method for your routers (both).

[Wireless] ASUS router Hard Factory Reset | Official Support | ASUS Global

Make sure to do the same steps above for your AiMesh node (and then after resetting it, leave it untouched and waiting for the following to be completed, below).

After doing the above, follow the suggestions below to get your main router secure, connected to your ISP, and at a good/known state (with the defaults suggested).

Best Practice Update/Setup Router/AiMesh Node(s) 2021


With the router and the network working as expected, use the appropriate section of the same link above to connect the AiMesh node to the network.


Use the link below to configure a USB drive for use with amtm on the main (RMerlin powered) router. Do not 'install' amtm as the (old) guide suggests. Since RMerlin firmware 384.15_0 amtm has been included 'built-in' to the firmware (simply type amtm to start it at an ssh command prompt as described in the guide below).

amtm Step-by-Step https://www.snbforums.com/threads/amtm-step-by-step-install-guide-l-ld.56237/#post-483421
 

Epi

Occasional Visitor
1. I did an Asuswrt-Merlin installation on main router AC68U
2. After installation node was still active, could see it on the network
3. Did a factory reset for main router
4. Did a software update on node
5. Did a factory reset to node
6. Since that I'm unable to connect it. I tried trough wired connection (same setup, it did work before), I tried via wireless connection. Tried to connect it straight after factory reset on node, and also after logging in to node and setting it up as a node in administration menu. Also tried to get back to original firmware on main router and set up from there. Anyhow, best I get is ~17% or sometimes 60-70% installation process and then this error appears.

Please help.

1614037560698.png

1614037618413.png

Ca34234234234234pture.PNG


WPS is on, on both devices
1614037966561.png

1614038079658.png
 
Last edited:

octopus

Very Senior Member
? :)
I do understand how to manage the nodes when they are connected. I have a problem connecting one.
I dont think so, you show you turn on WPS on node. Not necessary if you doing it right. First WPS reset and after press reset pin on back. Then put it in AiMesh nod and search.
 

Epi

Occasional Visitor
I dont think so, you show you turn on WPS on node. Not necessary if you doing it right. First WPS reset and after press reset pin on back. Then put it in AiMesh nod and search.
Tried like this as well. Same result.

Also,
When RT-AC57U is just set up as a node in "Administration", I'm able to find it and start aimesh process on main router, during which it crashes. After that, node cannot be found any more and I need to reset node router again for another attempt. Don't know is it relevant or not.

Still looking for help with this as half of my house is without internet connection.
 

octopus

Very Senior Member
When RT-AC57U is just set up as a node in "Administratint or not.
Try with aimesh node, don't try from Admin Page. Use first WPS factory reset and when that come up again reset with "reset pin"
on back of aimesh router and follow instructions to setup aimesh.

Make sure WPS is "on" on main router.
 

Epi

Occasional Visitor
1. Did a reset on node router trough the button on the back side
2. Logged into node and did a factory reset trough gui
3. Rechecked that main router has WPS on
4. Logged in to node router and followed instructions to set it up as aimesh
5. After node aimesh setup is complete, it asked to connect to main router to finish the process
6. No node SSID broadcast starting from this point, also don't see node on the network trough main router, despite router being online and based on lights on it, working both in 2.4GHz and 5GHz
7. Connect to main router, started a search, node not found, removed the wired connection between routers
8. Restarted the search, nothing found again
9. After some 10 minutes node started to broadcast SSID again, connected to it (it did a factory reset, as requested password to be set up again)
10. In node admin chose AiMesh Node operation again, applied settings 0-100%, as requested connected to main router, saw node
1614078088624.png

11. This time went from 0 to 100% and got an error again
1614078275594.png

12. Search again, the process starts, gets to 70 to 80% then again shows same error. After couple of tries node is not seen on the network again...
 
Last edited:

Epi

Occasional Visitor
I don't think I'm doing something wrong. There must be some kind of firmware issue or incapability. Maybe I should try different firmware version on both or any specific router? Can someone confirm which stable version works well?
 

Epi

Occasional Visitor
Allright, I've figured it out.
When it comes to main router, there is no difference either its original firmware or Merlin.
But node firmware Version 3.0.0.4.386.21649 2020/09/22 is the one to blame. I did a downgrade to Version 3.0.0.4.386.21647 2020/03/17 and was able to connect AiMesh successfully.
1614086193936.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top