RT-AC66U B1 bricked, I think

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Worldknown

New Around Here
Hey guys so I tried to flash the firmware and now it’s only showing two lights. Pictures attached.

Here are the steps I followed:
Downloaded the Asus Firmware Restoration Tool first, downloaded the firmware I wanted to flash 380.70, Unplugged the power, held down the Reset button, and plugged in the power plug. Wait ten seconds and the power LED was flashing slowly. Use the installed utility and now it just shows two lights on the router. Can’t connect via 192.168.1.1

please advise

i tried to flash back to old ASUS firmware and that didn’t work either, even though the tool says it worked successfully . Never had this issue before with a router.
 

Attachments

  • 81E95561-0E39-429D-8E80-1E74CD406CA4.jpeg
    81E95561-0E39-429D-8E80-1E74CD406CA4.jpeg
    82.2 KB · Views: 23

eibgrad

Very Senior Member
FWIW, I've used ASUS routers extensively over the years, and one of its greatest virtues is just how difficult they are to brick. So don't give up on it too quickly. I've had my share of what appeared to be a lost cause, only to eventually get past the problem, either by trying other builds, third-party firmware, using tftp rather than the ASUS utility, etc. In one rare instance (WL-500gP v2), I had to open the case and short a pin on the board. But that was the worst case.

P.S. It can be VERY stubborn at times. In recent years, a few times I had to force a hard reset *after* the firmware upgrade to get past the problem. Basically holding down both the reset *and* WPS button while powering ON. IIRC, when all the LEDS flashed in unison, it finally rebooted.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top