RT-AC66U B1 - NTP Sync Failure


New Around Here
Hi - Love what you do here and was wondering if you guys could help me out

My RT-AC66U B1 has started playing up.
It's wired to my regular ISP Router and provides a UK VPN WIFI for all my devices that I use in my French holiday home.

However the TLS handshake now fails when it tries to connect to the VPN Server
I've upgraded the firmware to the latest version but the problem persists despite several hard reboots

So I've now moved on to addressing the system date/time disparity. For whatever reason, the ASUS router is failing to sync with the NTP.
How do I get it to work?

I've attached the system logs and a screen capture of the basic config.

Any assistance would be greatly appreciated


  • help.JPG
    108 KB · Views: 142
  • syslog (2).txt
    52.6 KB · Views: 107


Part of the Furniture
time sync failure is usually due to an invalid DNS server in WAN. If you use other than ISP assigned DNS Servers switch to something reliable like CloudFlare. You might also turn off Network Monitoring.


New Around Here
time sync failure is usually due to an invalid DNS server in WAN. If you use other than ISP assigned DNS Servers switch to something reliable like CloudFlare. You might also turn off Network Monitoring.

I'm back and ready to knock this issue finally on the head
I've come a long way (factory reset, uploaded latest firmware, checked network monitoring was off and manually entered DNS servers - see attached) and ended right back where I started - No System time update :-(

The DNS servers are the ones recommended by my VPN supplier - NordVPN

Any other ideas how I might diagnose what the problem is?


    113.6 KB · Views: 89


New Around Here
Firmware Version:

Love this forum, perhaps one of you guys could help.

I live in France and watch UK on-line media via the above router configured as a VPN client
However the current firmware version fails to synchronise with an NTP server and simply reverts to May 2018 every time I restart the router.
I wouldn't care but this causes TSL to fail which in turn causes my VPN connection to fail :-(

So I dig around and basically all of the on-line help points towards the Administration / System / Basic Config section being incorrectly set.
But as far as I can tell, all is fine
NTP Config.JPG

Eventually I gave up and forced a date/time reset from an SSH session using PuTTY
You can see in the attached logs how that then allowed the VPN to operate without exception

The trouble is that every time I perform a cold reboot, I have to manually reapply the date.

I would be sooooooo grateful if someone could help me put in place a proper fix.

Thanks in advance


  • syslog (6).txt
    187.5 KB · Views: 51


Part of the Furniture
pool.ntp.org is an unreliable time source. Try using time.cloudflare.com or time.windows.com and see if that makes a difference (reboot the router to check).

EDIT: I've noticed that time.cloudflare.com is now often not responding. I've replaced cloudflare with time.google.com.

Also, to confirm @bbunge's advice in post #2 don't use NordVPN's DNS servers in your WAN DNS settings. In my experience they are slow and unreliable when being accessed from the public internet.
Last edited:


New Around Here
Hi Colin - Thanks for reaching out
I've amended the time source to time.cloudflare.com and will reboot when the family traffic has subsided
Incidentally, I've already amended the WAN DNS settings to the CloudFlare DNS and as recomended

I'll let you know if the problem is fixed


New Around Here
Still no luck :-(

still no luck.JPG

I've attached the logs that cover the reboot and System date reset.
Can someone compare these startup logs to their own to see where the date is failing to be initialised at start up?


  • syslog_reboot.txt
    32.6 KB · Views: 50


Part of the Furniture
Your system log appears to show that the time sync worked after about 11 minutes. Or did you do some sort of manual intervention that is not apparent from the log?

I can see you manually restarting the VPN client but it would have done that itself a few minutes later.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!