[RT-AC68P] Having Problem updating signature version and firmware version

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Maverick44

New Around Here
All-

If this is somewhere else already, please provide me the link. I looked but and found some references but didn't a solution that worked for me. I'm running an RT-AC68P with signature version 2.156 (Updated 12/28/19) and firmware version 384.14.0. I wasn't aware that there had been updates and usually was checking the router for the "!" blinking in letting me know there were updates available to perform. It hasn't blinked in a bit and I didn't pursue further.

I'm having problems with my router updating the signature version as well as checking for an update. When I attempt to "Check", I get return messages with failures.

The one thing I haven't done yet is gone ahead under the "AIMesh router" line and manually updated. I'm thinking that I can do this as when I checked the configuration, it tells me I'm running in Default - Wireless Router Mode / AIMesh Router Mode.

Anyone else ever encounter this and was resolution I'm thinking what worked for them?

Thanks.

1599075095508.png
1599075140120.png
 

Maverick44

New Around Here
Thanks. Just coming back to this. I did perform the upgrade manually and it worked. It then allowed the signature version to be checked / updated and the process for checking for updates to work. Not sure of why it didn't work but it seems to have resolved with the manual update.
 

ASUSWRT_2020

Regular Contributor
Because the security reason, the update server transport layer security was upgraded and the old protocol was removed on July 1st
RT-AC68 series firmware version lower than 3.0.0.4.385.20253, need to manually update the firmware and the OTA function will become normal.
We had released push notice to asus router app recently and we will release the notice again with further security updates.
 

dave14305

Part of the Furniture
There was a strain of malware discussed a little while ago that changed the nvram vars to prevent signature and FW updates. You can check if it was present on your router by running this command over SSH:
Bash:
nvram get apps_wget_timeout | grep -q O && echo "Malware was here"
If nothing comes back, you're clean. If it prints Malware was here, you should reset to factory defaults and start fresh.

The current Merlin version allows the updates to happen even if the malware is present, so don't be overconfident that everything is fine now just because you were able to update successfully.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top