1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT-AC68U and ROKU issue

Discussion in 'ASUS AC / AX Routers & Adapters' started by caferacer73, Sep 15, 2018.

  1. caferacer73

    caferacer73 New Around Here

    Joined:
    Sep 15, 2018
    Messages:
    6
    Just got the RT-AC68U to replace a crappy TP-Link. I got everything setup correctly, but I'm having an issue with my Roku. The problem is when trying to watch Netflix. It will start a video and then stop playing. It says there's a problem with the network connections. I've checked the network connections and they are fine (I even redid the connection - running my Roku on WiFi). I've even rebooted it a couple of times.

    Has anyone experienced anything like this and what did you do to fix it?
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    623
    Location:
    USA
    Maybe disable Wireless\Professional\Airtime Fairness.

    OE
     
  4. caferacer73

    caferacer73 New Around Here

    Joined:
    Sep 15, 2018
    Messages:
    6
    The Airtime Fairness wasn't the issue. I decided to start over and review what I had done to the router during the initial setup. Every other device in the household worked fine except for the Roku. What was different about it? Then is dawned on me, I had setup Time Scheduling for it very early in the process. So that had to be it. I deleted the schedule and the Roku connected as it normally should.

    So why would it not connect when it was in the "allowed" hours on the schedule? Did something happen when I was setting it up and then made other changes to the router? Who knows? Is the Time Schedule on of this "reverse logic" where the "allow" time is really the "blocked" time? Are streaming devices handled differently that other devices? What I want to do is have the Roku blocked from 1am until 7am everyday. It shouldn't be that hard to do.

    What's weird is I tried playing with the Time Scheduling for another device earlier in the day and it worked exactly as it should. I wanted it turned off during 2pm & 3pm. The WiFi for that devices was shut off instantly, so I know this should work.
     
    OzarkEdge likes this.
  5. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    623
    Location:
    USA
    Thanks for letting us know what it was!

    OE
     
  6. ApexRon

    ApexRon Regular Contributor

    Joined:
    Jun 17, 2018
    Messages:
    139
    Location:
    Apex, NC
    I don't know the Roku as I have an AppleTV which is Ethernet attached. Anyway, I installed a speed test app on my AppleTV. I was wondering if you could do the same on your Roku. This could help you in the future.

    As a side note: I had AT&T internet at 24Mbps and Netflix would once and a while claim poor network connection. In June I installed Spectrum internet at 200Mbps. Netflix hasn't complained since and I get better quality movies as Netflix will lower picture quality if it thinks there is a slow connection.
     
    OzarkEdge likes this.
  7. caferacer73

    caferacer73 New Around Here

    Joined:
    Sep 15, 2018
    Messages:
    6
    I think my thought logic was wrong when I originally set up the parental control. I was thinking that "allow" was allowing access, but in router reality, "allow" means "allow to block" and "deny" means "deny to block". There is a difference between the web interface and the phone app of how this is looked at. I think the phone app is setup better in regards to the parental controls; pick the time block you want to block...done.

    Hmm, just checked the parental controls I set up on my phone app. It's blocking during the time period I want. Then pulled it up on the web interface and it's showing "deny" as "deny access" and "allow" as "allow access". Not what I was thinking in the paragraph above.

    I guess it doesn't matter how it works as long as it does what I need it to do.
     
    Last edited: Sep 16, 2018
    ApexRon likes this.
  8. caferacer73

    caferacer73 New Around Here

    Joined:
    Sep 15, 2018
    Messages:
    6
    Well crap. It seems that no matter how I setup the Parental controls, the router blocks my Roku when I want to watch it. All I want to do is block it from 1am to 7am. I've tried numerous ways to to block it, but the end result is always the same, blocked when I want it to be active.

    Are streaming devices treated differently?
     
  9. ApexRon

    ApexRon Regular Contributor

    Joined:
    Jun 17, 2018
    Messages:
    139
    Location:
    Apex, NC
    I would use only the MAC address. How about changing the NTP server to time.google.com .
     
  10. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    623
    Location:
    USA
    Is it a Roku2 (I think) with RF Remote? That Roku is said to interfere with local WiFi by broadcasting WiFi Direct for its Remote on the same WiFi channel and at a higher power... so that its RF Remote WiFi is guaranteed to interfere. Probably not it.

    OE
     
    ApexRon likes this.
  11. caferacer73

    caferacer73 New Around Here

    Joined:
    Sep 15, 2018
    Messages:
    6
    It's a Roku 3. I was able to block it with an old D-Link router (needed to upgrade this since it had very slow WiFi).
     
  12. ApexRon

    ApexRon Regular Contributor

    Joined:
    Jun 17, 2018
    Messages:
    139
    Location:
    Apex, NC
    Not sure if this is the issue or the remedy but perhaps worth a try:
    “Here are the instructions to fix it.
    1. Start up the Roku and get to the home screen.
    2. Press these 10 buttons quickly: HOME-HOME-HOME-HOME-HOME-FFWD-PLAY-REWIND-PLAY-FFWD
    3. Select “Wireless Secret Screen” from the menu choices
    4. Select “Interference” from the menu choices
    5. Choose “None””
     
  13. indark

    indark Regular Contributor

    Joined:
    Jan 17, 2014
    Messages:
    172
    check the system timer on the ac68u to see if it's properly configured?
    you will be able to see it @ systemlog
     
  14. sfx2000

    sfx2000 Part of the Furniture

    Joined:
    Aug 11, 2011
    Messages:
    13,303
    Location:
    San Diego, CA
    Hint on Netflix - log into your Netflix account on your PC...

    Under the account preferences, you'll find a selection for bandwidth - choose the one best for your WAN connection (or one lower if your ISP has a monthly cap)

    Watch out for Auto if you have a bandwidth cap...

    Screen Shot 2018-09-16 at 4.13.55 PM.png

    This actually can get better video quality these days - as they do adaptive transcoding for each session.
     
    Last edited: Sep 16, 2018
  15. caferacer73

    caferacer73 New Around Here

    Joined:
    Sep 15, 2018
    Messages:
    6
    So Asus is assigning some tech people to try to replicate my issue. I have to provide a copy of my settings and logs for them to dig through. Hopefully they can duplicate it and come up with a solution.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!