RT-AC68U Configured as AP br0 interface not seeing WIFI

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

memphis2k

Occasional Visitor
Hello,

I am working on setting up a Proximity script for my RT-AC68U (set to AP mode) to send REST commands to my Home Automation system, an ISY994i. Running the latest Merlin firmware. Ideally want this to run as "services-start"

if I run the command (found in the script)
"arp -i br0"
none of my WIFI devices are listed. Any way I can run a arp command to show my wifi devices so this script can tell when I'm home/away?

http://www.snbforums.com/threads/help-script-on-asus-wrt-merlin-not-working.31159/#post-246273
Above is the script.

Thanks
 

RMerlin

Asuswrt-Merlin dev
Code:
wl -i eth1 assoclist
wl -i eth2 assoclist

arp isn't really useful because disconnected devices would still show up there.
 

memphis2k

Occasional Visitor
Thanks,

I will try that. If I did the "arping" command proactively in the shell, essentially waked the device and then the "arp" commend ran by the script would see the phones and tell the automation that they are home. Otherwise monitoring the script, it would just say the phones were not home after a certain amount of idle on each device.
 

memphis2k

Occasional Visitor
Merlin,

How can I run multiple scripts from "services-start"? I"m no Linux/BASH expert. Thanks in-advance!

I tried:
#!/bin/bash

sh /jffs/scripts/wifi_check.sh
sh /jffs/scripts/ping.sh

--------------------------------
AND

#!/bin/bash

sh ./wifi_check.sh
sh ./ping.sh
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top