RT-AC68U drops connection constantly

TuffPoo

New Around Here
Hello!


So I have a problem and I don't know if my router is going bad or what. I will be on my laptop then out of nowhere I lose connection to the router and it takes forever to reconnect to my router. I have done 2 factory reset and used current firmware as well as merlin to no such luck. Its a RT-AC68U with 3 wireless mesh nodes all the same routers. This has been happening for 3 months on any device connected to the network I just want to know my next steps I have included a system log too! Thanks for your help!
 

SoCalReviews

Very Senior Member
I read a lot of posts recently about AC68Us that have been having similar problems. My aging AC68Us were having the same problem. I upgraded to new AX86Us and it's been smooth sailing. What you might try with your AC68U is change the Wifi settings to disable AirTime Fairness and a few other optional settings to help stabilize your Wifi device connections. I don't remember all of them at the time of this post but there are a number of them in the same settings configuration area that users have been posting in the forum.

Here you go. I just found them posted in this AC section courtesy of user @wouterv .

Advanced Settings - Wireless - Professional - 2.4 GHz
Modulation Scheme: Up to MCS 7 (802.11n)
Airtime Fairness: Disable
Explicit Beamforming: Disable
Universal Beamforming: Disable

Advanced Settings - Wireless - Professional - 5 GHz
Airtime Fairness: Disable
Universal Beamforming: Disable
 
Last edited:

TuffPoo

New Around Here
I read a lot of posts recently about AC68Us that have been having similar problems. My aging AC68Us were having the same problem. I upgraded to new AX86Us and it's been smooth sailing. What you might try with your AC68U is change the Wifi settings to disable AirTime Fairness and a few other optional settings to help stabilize your Wifi device connections. I don't remember all of them at the time of this post but there are a number of them in the same settings configuration area that users have been posting in the forum.

Here you go. I just found them posted in this AC section courtesy of user @wouterv .

Advanced Settings - Wireless - Professional - 2.4 GHz
Modulation Scheme: Up to MCS 7 (802.11n)
Airtime Fairness: Disable
Explicit Beamforming: Disable
Universal Beamforming: Disable

Advanced Settings - Wireless - Professional - 5 GHz
Airtime Fairness: Disable
Universal Beamforming: Disable
Thank You! I will try these settings I have had my routers for 5+ years and they been fine until recently. I was going to get a pair of ASUS ZenWiFi Whole Home mesh routers. Just trying to squeeze every last ounce until then.
 

wouterv

Very Senior Member
Nothing that stand out to me just constant connects and reconnects. Here is a pastebin of the log I cannot attach files for some reason https://pastebin.com/L0BceyCP
The System Log doesn't look default, it seems you changed the severity level.
A few basic steps to get things clear:
  1. Install the latest available firmware version.
  2. Reset to factory defaults.
  3. Do NOT load a configuration backup.
  4. Perform a manual configuration of the bare minimum only, as: router user name and password, SSID's and passphrases.
  5. Make WiFi settings as given in the previous post.
Test again.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top