RT-AC68U in Media Bridge Mode responding to DHCP requests

HariSeldon

Occasional Visitor
I posted this in the 384.6 thread, but figured it might need a separate post since this might be not related to that version.

Is there a way to manually disable DHCP server while in Media Bridge mode? Somehow my RT-AC68U is responding to DHCP requests, before the primary router can respond. I've tested by narrowing the DHCP scope in router mode, then disabling DHCP, and then converting over to Media Bridge mode. It still responds to DHCP requests from both wired and wireless clients. The address being handed out is definitely coming from the Media Bridge, not the main router it is connected to.

I'm looking for a command to run in shell, as there is nothing in the GUI related to DHCP in Media Bridge mode.

I'm not trying to run AI Mesh. The router I'm bridging from is not an Asus, but I don't think that should matter, right?
 

HariSeldon

Occasional Visitor
The DHCP service is most certainly running despite the GUI saying it is off. When I plugged my PC directly into the back it pulled a .60 address. Any idea how to manually disable DHCP, since the GUI appears to not be reflecting what is running? When connecting through the main router, it appears to be randomly hitting the media bridge, since when I renewed after moving my cable back, I got my reserved address from the other router. (.221)
 

EventPhotoMan

Very Senior Member
The DHCP service is most certainly running despite the GUI saying it is off. When I plugged my PC directly into the back it pulled a .60 address. Any idea how to manually disable DHCP, since the GUI appears to not be reflecting what is running? When connecting through the main router, it appears to be randomly hitting the media bridge, since when I renewed after moving my cable back, I got my reserved address from the other router. (.221)
I have no issues.

Try this, set it up as an access point first, then to bridge mode, just to realign all the parameter to turn off dhcp.
 
Last edited:

agilani

Very Senior Member
I've noticed this when the primary router is down. I typically have to reboot the remote repeater once or twice after the main router is up and running for the wireless devices to reset and get their DHCP reservations from the main router.
 

EventPhotoMan

Very Senior Member
I've noticed this when the primary router is down. I typically have to reboot the remote repeater once or twice after the main router is up and running for the wireless devices to reset and get their DHCP reservations from the main router.
Why I the primary one down?
 

agilani

Very Senior Member
Why I the primary one down?
If I'm updating the code or like when I lose power. I have to make sure the primary router is up and running and fully functioning then restart the two repeaters to make sure the wireless and wired devices get their dhcp addresses from the primary router. Not sure why, but if the repeaters come up first, the devices get rfc 1918 addresses that are not in the dhcp reservation for them. I haven't really sat down to troubleshoot what is going on. Either the repeater is giving out its own dhcp client addresses, or the primary is giving out addresses that are not part of the reservations.

I can usually tell when i lose access to my cameras that they haven't gotten their dhcp reserved address. I used to set them statically, but samung decided it was easier to remove the webui from the device than to fix their vulnerabilities.
 

HariSeldon

Occasional Visitor
I have no issues.

Try this, set it up as an access point first, then to bridge mode, just to realign all the parameter to turn off dhcp.

It took me a few days to be able to circle back to this. I was able to set up the device in AP mode wired to my main router. I tested connecting to the SSID successfully. I swapped from there to Media Bridge mode and it still is handing out DHCP addresses in the narrowed range I set up while it was in router mode.

There must be a way to manually disable the DHCP service and keep it from coming back up again, right? I did some googling and found the following command that appears to keep the DHCP from handing out addresses, however if there is a power outage or reboot, it will resume services I think.

service stop_dnsmasq

I have tried "disable" but the service still comes back after a reboot.

service disable_dnsmasq

I think I could probably set up a cron job to run the stop command repeatedly, but there must be a better way.
 

Klickachu

New Around Here
Have same issue on my Asus RT-AC87Us, have 3, 1 in Router mode, 2 in media bridge mode. After a network outage where I was reseting the one running in Router mode, I noticed that both bridges started handing out DHCP IPs with themselves as the default gateway (default setting, I assume). I tried the same approach before finding this thread. I switched the bridges to wireless and then AP mode to try to disable the DHCP setting with no changes despite the UI stating DHCP was disabled. I ended up manually stopping dnsmasq as well, but still looking for why its starting on boot when running in bridge mode. Thanks OP for work arounds.
 

agilani

Very Senior Member
Wonder if we should enter the reservations in the repeaters or media bridge devices as well. May stop the symptom even if does not fix the problem.
 

HariSeldon

Occasional Visitor
Wonder if we should enter the reservations in the repeaters or media bridge devices as well. May stop the symptom even if does not fix the problem.

That will not work because the router hands itself out as a default gateway. You will have an IP on the right subnet, but not route to the Internet.

I also have another issue that cropped up when trying to get these media bridges stable. For some reason they keep disconnecting. A suggestion was to set up a cron job to ping the main router, in my case 192.168.1.1, however when I SSH into my .2 bridge, I cannot ping it! I get destination host unreachable. This is the case for my .3 bridge as well. For both I can't get out to the Internet to ping Google or other sites. There was a brief moment I could ping Google on one router, but just a minute later I get errors.

Any ideas? NVRAM reset and reconfigure? I didn't realize this until trying to troubleshoot why my NTP update always failed.
 

Klickachu

New Around Here
I bet if you check the media Bridges, you will find they don't have a default gateway.

Set 192.168.1.1 as their default gateway and it should work. It won't survive a reboot, trying to find out why it's not taking it from main router DHCP settings.
 

HariSeldon

Occasional Visitor
I bet if you check the media Bridges, you will find they don't have a default gateway.

Set 192.168.1.1 as their default gateway and it should work. It won't survive a reboot, trying to find out why it's not taking it from main router DHCP settings.

Actually I am not using DHCP to hand out addresses to my media bridges. I did at one point, but went to statically assigning them when I did the setup. They are manually set to .2 and .3 respectively and the GUI shows a default gateway of .1, as well as DNS of .1. Oddly enough though if I do an ifconfig, it doesn't show a gateway address.

This website suggests setting a default route for the gateway. I'm going to try it and will report back.
https://danielmiessler.com/study/set_ip/
 

Klickachu

New Around Here
That's exactly what I did, set a manual gateway. I couldn't find where the config file was to set it perm though. It doesn't seem to set a default gateway when manually setting the IP on the media bridge and I can't get them to pick up a DHCP address anymore.
 

agilani

Very Senior Member
That's exactly what I did, set a manual gateway. I couldn't find where the config file was to set it perm though. It doesn't seem to set a default gateway when manually setting the IP on the media bridge and I can't get them to pick up a DHCP address anymore.

Pinging devices is a layer 2 issue and does not involve the default router. did you check the arp table to see if there are entries in the arp table for the ip addresses you are trying to access? Last time i had arp issues with this setup it ended up being a layer 2 channel conflict issue which i resolved by manually setting the channel for all wireless in my network.

I am able to regularly ping my remote repeaters / media bridge devices without any problems. What version of code are you running, and how are you doing the backhaul?

I am now running stock on both of my ac68 repeaters and merlin on my ac88 router. I am backhauling using 5ghz which has the least amount of channel conflict and have set all of my channels manually.
 

HariSeldon

Occasional Visitor
That's exactly what I did, set a manual gateway. I couldn't find where the config file was to set it perm though. It doesn't seem to set a default gateway when manually setting the IP on the media bridge and I can't get them to pick up a DHCP address anymore.

I think the GUI is funky with Media Bridge mode as it obviously doesn't reflect the actual router configuration. As a workaround you can set up the route as a startup script. I used this guide:
https://www.cyberciti.biz/faq/how-to-add-cron-job-on-asuswrt-merlin-wifi-router/

Here is my startup script, including pinging the gateway to hopefully keep the bridge connection from timing out. I also was unable to get the ntp settings to do anything in the GUI, so I added that to my startup, which I can confirm works.

/jffs/scripts/services-start
Code:
#!/bin/sh
service stop_dnsmasq
service disable dnsmasq
cru a pinggw "*/5 * * * * /bin/ping -c 10 -q 192.168.1.1"
route add default gw 192.168.1.1
ntpd -p pool.ntp.org

Don't forget

Code:
chmod a+rx /jffs/scripts/services-start

And enable at Admin->"Format JFFS partition at next boot = no" and "Enable JFFS custom scripts and config = yes"
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top