RT-AC68U LAN DNS issue

maniusng

New Around Here
Hi,

I've noticed one issue with current firmware (and the one before).

When setting DNS servers manually (WAN->DNS), static routes to DNS are defined using wan interface.
So this leaves no option to have a local DNS server which could be used by the router itself.
In firmware RT-AC68U_3.0.0.4_386_41634 it worked fine - no static routes.
Current firmware RT-AC68U_3.0.0.4_386_43137 - the static route is defined using external IP and external interface.

I've already reported this to Asus.
 

bbunge

Part of the Furniture
Your router needs an external DNS server in WAN - DNS Server 1 and 2 in order to set the time on the router on boot. Your internal DNS server IP address goes in LAN - DHCP Server - DNS Server. I run my Pi-Hole like this with no issues. In fact, with recent Internet DNS failures I have the router set to one upstream resolver, Cloudflare, and the Pi--Hole set to Quad9. The chance that both are down at the same time is slim.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top