Solved RT-AC68U local dns issue


New Around Here
Hello everyone,

I experience an issue with my AC-68u flashed with Merlin 386.3_2.
I configured some manually assigned IP address to some devices in LAN > DHCP SERVER settings and defined hostnames to be able to reach them this way: "mydevicehostname.local".

When I dig the hostname I get a positive answer, yet this can't be reached throughout the web browser for instance.

dig pve.local

; <<>> DiG 9.16.1-Ubuntu <<>> pve.local
;; global options: +cmd
;; Got answer:
;; WARNING: .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20708
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;pve.local.            IN    A

pve.local.        0    IN    A    192.168.X.X

;; Query time: 0 msec
;; WHEN: mer. oct. 13 13:29:21 CEST 2021
;; MSG SIZE  rcvd: 54

Same goes for nslookup:


Non-authoritative answer:
Name: pve.local
Address: 192.168.X.X

I can reach my "nas.local" address though in my browser with no issue.

Here is my configuration:
Activate DHCP Server: YES
Hide DCHP/RA queries: no
Local domain name: local
Default gateway: "empty"

DNS Server 1: "empty"
DNS Server 2: "empty"


Forward local domain queries to upstream: no

I looked for previous similar issues but could find something like I have.

Do you have any idea ? Where to look ?
Thanks by advance


Part of the Furniture
There's no such model as an AC-68u so I going to assume you mean RT-AC68U.

It's generally not a good idea to use .local as your local domain name as it conflicts with Apple's mDNS (Bonjour) naming and can create confusion. I suggest something like home.lan.

What OS are you using? What browser are you using? What error message is returned by the browser?

Is this only a problem when using the web browser? Have you tried a different browser? What about other (non-browser) applications, like SSH, FTP, etc?


New Around Here

Thanks for the answer. My bad, yes this is an RT-AC68u.
I should have been a bit more precise:
- dig / nslookup seems to recognize xxx.local names but neither of "ping", "ssh" work when I try to reach "xxx.local" whereas they do when I use the IP address
- No "xxx.local" address can be reach (appart from nas.local... weird) whatever the browser is (FF, Chrome, etc.) but that is not surprising as other tools can't either. They just can't reach the address (Address not found). Considering the first point, I don't think this is linked to the browsers

I'll give a try and change the local domain name.


Part of the Furniture
What OS are you using? Ubuntu?

Is this only effecting this one PC? What about other devices?


New Around Here

@ColinTaylor I though I tested from another device and experienced the same issue but in fact no... I tested from a phone and no issue at all...
I use Mint Linux 20.2
@Crimliar nice catch, it seems like dnsmasq is somehow running and interfering on my current device...
From what I saw, it's installed by default on Linux Mint to cache request. I'll see if there is a way to invalidate / renew the cache oetherwise I'll disable it


Part of the Furniture
Just one for ColinTaylor is:


It is for Ubuntu as by default it runs its own local forwarding DNS server (systemd-resolved). Personally I disable that. ;) But his nslookup's work so that's not the problem.


New Around Here
Totally right, I was about to correct after what netstat gave me:
tcp 0 0* LISTEN systemd-resolve 35825 1345/systemd-resolv
Seem like I can empty / renew cache. I'll try.
I'm totally network ignorant as you may have noticed :), but do you have any idea why it was able to resolve "nas.local" (probably in cache) but couldn't do it for "pve.local" ?

@ColinTaylor , here it is :
# This file is managed by man:systemd-resolved(8). Do not edit.
# ...

options edns0 trust-ad
search local


Part of the Furniture
Thanks, can you post the contents of /etc/nsswitch.conf


Occasional Visitor
Probably doesn't matter here, but the domain has been specifically reserved for residential networking.


New Around Here
@ColinTaylor , here it is `/etc/nsswitch.conf` :
# /etc/nsswitch.conf
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd: compat systemd
group: compat systemd
shadow: compat
gshadow: files

hosts: files mdns4_minimal [NOTFOUND=return] dns myhostname
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

@rotareneg I didn't know that. That sounds less informative than "local" or "lan" imo.


Part of the Furniture
@ColinTaylor , here it is `/etc/nsswitch.conf` :
Thanks. That appears to be one of the typical cock-ups related to Avahi (mDNS) and probably the cause of your issue.

There's probably at least four different ways to fix this, although I don't think any particular way is "more correct" than any other.

Try this. Edit that file and change the hosts: line to the following:
hosts: files dns myhostname mdns4_minimal


New Around Here
Yep that did the trick. I can now resolve my local names !
Thanks you all for you help, especially @ColinTaylor ! :)

(PS: should I rename the thread and it to be moved as it has nothing to do with Asus ?)


Part of the Furniture
(PS: should I rename the thread and it to be moved as it has nothing to do with Asus ?)
Just change the title prefix to Solved. Thanks.

Did you go with my suggested hosts: line or use something different?


Part of the Furniture
Thanks for the update.

P.S. There's a dropdown list of title prefixes which includes "Solved".;)

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!