RT-AC68U Mesh - How to stop Alexa roaming?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

banger

Senior Member
I have 2 RC-AC68U set up with the latest beta firmware which was a quick fix from release for security. One upstairs one downstairs in a 3 bed house. I have 2 echo speakers and a dot. The dot is upstairs next to my newest 2020 router which is the primary and in the next room is a speaker. Downstairs is the node in dining room connecting on 5ghz with signal strength -54dbm. Along with that is another echo speaker about 10 feet from the node in clear air in the kitchen.

I listen to streaming music on the everywhere group which is all 3 echo devices. This will now and again drop out and my diagnostics lead me to the kitchen speaker. Which is why I got the mesh in the first place. It seems to roaming from downstairs to upstairs then back. This process doesn't seem to be seamless so it drops the stream.

How can I stop the roaming? Roaming is set to -70 the default and I have found the roaming block list which I am now trying and monitoring. Binding the speakers to each router doesn't seem to make any difference. Here is the log entry when the connection drops

Apr 1 16:31:41 roamast: eth2: sta-ap-band-bind deauth [50:dc:**]
Apr 1 16:31:41 roamast: eth2: remove client [50:dc:e7:**] from monitor list
Apr 1 16:31:41 syslog: wlceventd_proc_event(491): eth2: Deauth_ind 50:DC:**, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3), rssi:0

50:DC** is the Kitchen Echo. Any ideas?
 

CaptainSTX

Part of the Furniture
I don't use a mesh setup but on the AP I do use a MAC filter set to reject devices including several Spots that I don't want connecting to the radios on the AP.
 

OzarkEdge

Part of the Furniture
I have 2 RC-AC68U set up with the latest beta firmware which was a quick fix from release for security. One upstairs one downstairs in a 3 bed house. I have 2 echo speakers and a dot. The dot is upstairs next to my newest 2020 router which is the primary and in the next room is a speaker. Downstairs is the node in dining room connecting on 5ghz with signal strength -54dbm. Along with that is another echo speaker about 10 feet from the node in clear air in the kitchen.

I listen to streaming music on the everywhere group which is all 3 echo devices. This will now and again drop out and my diagnostics lead me to the kitchen speaker. Which is why I got the mesh in the first place. It seems to roaming from downstairs to upstairs then back. This process doesn't seem to be seamless so it drops the stream.

How can I stop the roaming? Roaming is set to -70 the default and I have found the roaming block list which I am now trying and monitoring. Binding the speakers to each router doesn't seem to make any difference. Here is the log entry when the connection drops

Apr 1 16:31:41 roamast: eth2: sta-ap-band-bind deauth [50:dc:**]
Apr 1 16:31:41 roamast: eth2: remove client [50:dc:e7:**] from monitor list
Apr 1 16:31:41 syslog: wlceventd_proc_event(491): eth2: Deauth_ind 50:DC:**, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3), rssi:0

50:DC** is the Kitchen Echo. Any ideas?

What generation is the kitchen Echo speaker? A 2.4 GHz Echo might see interference from the microwave oven or perhaps some other appliance, causing it to reconnect.

You could try swapping it with the other speaker, in case they are different in some helpful way.

You could try Auto channels to let the router pick a better channel. Then set it fixed later.

You could raise (less negative) the band Roaming Assistant RSSI threshold by ~15 dBm in case both signals are too good in the kitchen... for your client device.

OE
 

banger

Senior Member
What generation is the kitchen Echo speaker? A 2.4 GHz Echo might see interference from the microwave oven or perhaps some other appliance, causing it to reconnect.

You could try swapping it with the other speaker, in case they are different in some helpful way.

You could try Auto channels to let the router pick a better channel. Then set it fixed later.

You could raise (less negative) the band Roaming Assistant RSSI threshold by ~15 dBm in case both signals are too good in the kitchen... for your client device.

OE
Looking at winfi the 5ghz signals are almost as strong as each other. The echo is 2nd generation but I have changed the password for 2.4ghz as the bedroom speaker would default to that and there is no way to forget the network on the Alexa app.

I have followed your setup guide for the AC86U. I will set -55 on the RoamAsst for 5ghz and monitor. The 5ghz channel is clear.
 

OzarkEdge

Part of the Furniture
Looking at winfi the 5ghz signals are almost as strong as each other. The echo is 2nd generation but I have changed the password for 2.4ghz as the bedroom speaker would default to that and there is no way to forget the network on the Alexa app.

I have followed your setup guide for the AC86U. I will set -55 on the RoamAsst for 5ghz and monitor. The 5ghz channel is clear.

My experience with the RA threshold suggests to ignore observed signals levels and instead adjust RSSI (roam sooner) until the client(s) connects reliably when having trouble with two good signals to choose from. The premise is that two performance nodes in the average home are quite likely to be flooding each other with their signals... 2.4 most definitely and 5.0 quite possibly. Fortunately, it's easy to test for, especially if Smart Connect is disabled and only connecting to one band/SSID i.e. SC is not a distraction to the RA threshold trials.

Also, beware a kitchen appliance/mass affecting the signal/path to the near node. Try moving node or client/speaker a bit to change the radio path.

OE
 

MvW

Senior Member
If you're using AiMesh (or willing to) you have the option to bind a device to specific node. I have a printer which roamed between two nodes, dropping print jobs half way. Since I've bound it to the node with the strongest signal, these annoyances belong to the past.

To bind a device to specific node, open AiMesh, find the device at the device list of the node that it's currently connected to, press the bind icon in the upper right corner (see second screenshot), select which node it should connect to and confirm.

Screenshot_2021-04-01 ASUS Wireless Router RT-AC86U - AiMesh 2.png


After confirming the bind icon will show inverted to indicated that the device is not able to roam freely anymore. To unbind, just press it again.

Screenshot_2021-04-01 ASUS Wireless Router RT-AC86U - AiMesh.png


Easy steps, saves you a lot of annoyances and dropping connections.

Best regards,
Marco
 

banger

Senior Member
If you're using AiMesh (or willing to) you have the option to bind a device to specific node. I have a printer which roamed between two nodes, dropping print jobs half way. Since I've bound it to the node with the strongest signal, these annoyances belong to the past.

To bind a device to specific node, open AiMesh, find the device at the device list of the node that it's currently connected to, press the bind icon in the upper right corner (see second screenshot), select which node it should connect to and confirm.

View attachment 32688

After confirming the bind icon will show inverted to indicated that the device is not able to roam freely anymore. To unbind, just press it again.

View attachment 32689

Easy steps, saves you a lot of annoyances and dropping connections.

Best regards,
Marco
I have tried this but it seems to drop the connection as a rebind signal is sent as can be seen in my OP from the status log.
 

CaptainSTX

Part of the Furniture

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top