RT-AC68U Random spontaneous reboots

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

jsmith707

New Around Here
my first post, thank you to all who take the time to help out

bought this RT-AC68U in 2016, never had issues (too much) and while I can share a few quirky things, mostly I have been using it successfully with the ASUSWRT firmware (stock).

The current issue that's giving me ulcers is that it's rebooting on its own when something happens. That something is very random, e.g. I start the Netflix client on a Blu-ray player. Or a Win10 laptop connects to the Wi-Fi (2.4 or 5, it doesn't matter)???

I believe it all started with my upgrade from 3.0.0.4.385.20633 to 3.0.0.4.386.41634. Nothing unusual, right? And yet, I noticed that I started losing the Internet connection from time to time. Even called my provider to find out if there is anything wrong on their end.

These are the things I did once I realized it's my issue
1. Reboot numerous times, both the router and the modem from the provider.
2. Reset to factory settings from within the user interface, re-configured it manually after that
3. Reset to factory settings by holding the WPS button and then again, re-configure manually
4. Flash it with Merlin 386.2_2, reset with the WPS button

When one of the those events occur:
1. I lose connection to the user interface (web portal) from my command center PC :)) which is wired through a Netgear switch
2. All connected devices lose their connections, wired and wireless
3. When I look at the front of the router, the lights don't show as if it's restarting the usual way. They are lit up as if there is nothing wrong ???
4. A few minutes later, I regain connection to the router's web portal. At that moment, the WAN connection is still being negotiated. Sometimes it connects within 30 seconds, sometimes it takes 5 minutes. The System log clearly shows that the router has rebooted because the uptime is reset and the date is wrong, May 5th, 01:05:02. Once, the Internet connection is restored, the date is set correctly

The setup is very simple, a DSL modem SR501 from the Internet provider, then the "beautiful" creature RT-AC68U, then a single cable from port 2 to a netgear switch. ASIDE from the firmware upgrade, no other changes to anything and that's why I'm focusing on the upgrade. But now that I have moved to Merlin, it doesn't make sense

My next step is to enable SYSLOG on a device somewhere so I can collect proper logs (does that make sense? will this help me with anything?) and if I can't figure it out from the logs, then I will force it into recovery mode and restore the last firmware version that was working fine

If you have any ideas, I'd be forever greatful

MD
 

bbunge

Part of the Furniture
Just to make sure you are doing a reset correctly: https://www.asus.com/support/FAQ/1039074/
Use Method 1
After reset do not use any saved settings. Configure manually.
I am having no issues with two AC68U nodes and an AC66U_B1 root router on Asus Version 9.0.0.4.386.41994. Running on Comcast 300/35 cable.
You may want to try John's fork. Older WIFI drivers but up to date with security patches and many modern features. Works very well on older routers.
 

jsmith707

New Around Here
Thank you for the quick reply. Yes, that's the article I followed and yes, i re-configured everything manually after the reset, I did not restore saved settings from a file.

Yes, I noticed there is a newer version but since it shows as "beta" I decided to go with the latest stable.

Did you jump to the "beta" from the previous one, 41634?
 

eibgrad

Very Senior Member
Very difficult to diagnose problems like this, esp. in this forum. This is the kind of thing you typically need to experience first-hand to fully appreciate the actual sequence of events. It's possible you're not noticing some things that would provide more relevant clues.

Of course, the obvious question is, what happens if you go back to the old firmware?

Assuming it makes no difference...

A few years ago I had a similar problem. Tried endless changes, to no avail. Then on a hunch, I decided to have my ISP swap out my current ~6 year old modem for a new one. BINGO! Problem solved. Apparently it had given up the ghost, presumably from all the heat sustained during 24/7 operation over all those years.

These devices are NOT particularly robust. Even your favorite and up-until-now reliable modem/router will eventually give out, some sooner than others (sometimes you just get unlucky), esp. if it tends to run hot. Just look at all the ASUS RT-AC86U failures due to high temps (exacerbated by poor thermal design).

I would check the temps (if reported in the GU), and perhaps even have a fan blowing on it for a while to see if it increases its reliability. But sometimes that's only a stopgap measure if the damage has already been done.
 
Last edited:

sfx2000

Part of the Furniture
The current issue that's giving me ulcers is that it's rebooting on its own when something happens. That something is very random, e.g. I start the Netflix client on a Blu-ray player. Or a Win10 laptop connects to the Wi-Fi (2.4 or 5, it doesn't matter)???

AC Adapter is suspect if the router has been slowly "degrading" in overall stability.
 

jsmith707

New Around Here
Appreciate your response and I agree about the "first hand experience".

Just checked the temps on the router early in the morning when there shouldn't be any traffic and the room is around 17C (62 F). They are 47C, 50C, 69C (117F, 122F, 156F). Are these normal for this router?

Also, would the log give me more information if it's sent to a SYSLOG server? Or would SNMP give me some clues if it's enabled? Obviously, with a problem like this it would be hard to say, I'm just looking for some input from someone who has more experience with logs or SNMP

Thanks again
 

jsmith707

New Around Here
FYI

The SYSLOG idea did not bring fruit to fruition. I can see the log entries but none indicate a reason for the reboot/reset

Reverted back to my original firmware version, no issues so far. Here's two days I will never get back :(
 

maidmeow4

New Around Here
Hi, I have a RT-AC66U_B1 and recently flashed 386.1_0 and 386.2_2, both of them randomly reboots.

EDIT:
my flashing procedure:
1. power off and hold wps button and power on,
2. wait for power led blinks then release wps button, router reboots,
3. after router reboots power off,
4. hold reset button and power on,
5. wait for router boots into rescue mode,
6. use asus firmware restoration utility to upload the firmware,
7. asus firmware restoration utility says firmware restoration was successful and router reboots to a fresh firmware.
 
Last edited:

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top