1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT-AC68U slowing down wired connection

Discussion in 'ASUS AC Routers & Adapters' started by vespid, Oct 10, 2018.

Tags:
  1. vespid

    vespid New Around Here

    Joined:
    Oct 10, 2018
    Messages:
    6
    Hi folks,

    This has probably been asked before, but I can't find an answer that works. I get 100Mbps at my modem and when I wire my PC directly into that modem, but when I connect through my RT-AC68U, the best I can get is 50Mbps or so. Nat acceleration is set to "auto" and I can't find any other settings that make a difference. About the same result when trying wireless. I've updated the firmware (which may be the problem, I suppose).

    What am I missing here?

    Thanks in advance for any help
     
  2. Grisu

    Grisu Very Senior Member

    Joined:
    Aug 28, 2014
    Messages:
    1,508
    known bug with latest firmware, some reported same here ...
     
  3. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    398
    Location:
    Apex, NC
    While it certainly can be a firmware issue as indicated by Grisu, my experience has found it to be an auto-negotiation issue between your modem and the ASUS. This can be caused by the Ethernet cable, please try another, or just an incompatibility between the auto-negotiation of each device. Please refer to the ASUS to confirm that the connection to the modem is and remains at 1Gbps. Additionally, refer to the system log of the ASUS and see if an interface is posting "Link Down" and "Link Up".
     
    doczenith1 likes this.
  4. vespid

    vespid New Around Here

    Joined:
    Oct 10, 2018
    Messages:
    6
    I swapped out the cable between the modem and router and it didn't make a difference. I don't see "link down" or "link up" in the logs anywhere, but I do see this. Once again, when I plug my desktop directly to the modem, I get the 100. Any other thoughts, or specifically, where to look among the many pages of settings on the router?

    upload_2018-11-4_11-16-43.png
     
  5. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    398
    Location:
    Apex, NC
    Congratulations, I believe you found the issue. That WAN connection should be 1Gbps regardless of your ISP contracted speed. Since your PC connects at 100Mbps too, I would replace the modem but this assumes that your PC Ethernet is 1Gbps capable.

    So why is the ASUS connection slower? The ASUS probably has a more current auto-negotiation code than the PC. The ASUS doesn’t like the modem’s auto-negotiations and continues to retry which in my experience will suck up ½ the bandwidth.
     
  6. vespid

    vespid New Around Here

    Joined:
    Oct 10, 2018
    Messages:
    6
    This is my modem, supplied by my ISP. http://a.co/d/4ZVvdNZ Are you saying that I need to ask them for a different modem?
     
  7. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    398
    Location:
    Apex, NC
    Thanks for the link which states that it should support 1Gbps. So the question becomes:
    • Is it the Arris modem?
    • Is it your cable(s)?
    • Is it your PC’s Ethernet adapter?
    Note: Not including ASUS until you can get 1Gbps connection out of modem.

    Your choice on how to proceed.
     
  8. vespid

    vespid New Around Here

    Joined:
    Oct 10, 2018
    Messages:
    6
    When I take the wire from my PC and switch it from the router to directly into the modem, I get this on a speedtest. To a newb like me, that implies that the modem and computer are ok, but I know it isn't that simple:
    upload_2018-11-4_16-26-31.png
     
  9. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    398
    Location:
    Apex, NC
    I suspect when the modem is directly connected to the PC, there are no auto-negotiation retries but the connection is only 100Mbps as you stated. Why your speed test is showing 120+Mbps I can’t explain because while it’s measuring ISP speed the actual methodology of how it accomplishes that is unknown to me.

    Until you validate that you’re getting 1Gbps on a modem connection you can’t consider the ASUS is at fault.
     
  10. dave14305

    dave14305 Senior Member

    Joined:
    May 19, 2018
    Messages:
    345
    Please post the a screenshot of the Network section at the bottom of the Tools -> Sysinfo tab of your router (if you run Merlin Firmware). Interested to see what kind of negotiation is listed on the WAN port.

    Edit: Also, can you login to the modem at 192.168.100.1 to see how it sees the connection to the router?
     
    Last edited: Nov 4, 2018
  11. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    1,051
    Location:
    USA
    Given both support Gigabit Ethernet, the ASUS WAN port should connect to the modem port at 1 Gbps. You already know where to look in the router GUI to confirm this... it reports 100 Mbps, so the cable or ports are suspect.

    When you connect your PC to the modem, you can query the PC wired adapter status to confirm it's connected link rate... what is it? Given your speed test above of 100 Mbps, it may be 1 Gbps. So, maybe either the router WAN cable or port is suspect.

    Use the PC cable to connect the ASUS WAN to the modem. What's the link rate in the router GUI?

    OE
     
    Last edited: Nov 9, 2018
  12. vespid

    vespid New Around Here

    Joined:
    Oct 10, 2018
    Messages:
    6
    I now have time to get back to this. I didn't have the merlin software, but now I do. It is still not where it is supposed to be. Here is what you requested. My computer is wired into LAN3:

    upload_2019-1-10_22-36-27.png
    upload_2019-1-10_22-38-18.png
     
  13. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    398
    Location:
    Apex, NC
    First, you have an issue on the Arris TM822 wherein it is only connecting to the ASUS at 100Mbps. That connection should be 1Gbps or 1000Mbps. The ethernet speed of the Arris is derived by end device (ASUS) auto-negotiation and cable. Yes, both the Arris and the ASUS are cable aware. Your computer connects to the ASUS at 1Gbps. Unplug your computer cable from the back of the ASUS (LAN3) and then plug into Arris. Look at Arris status panel again. Is it 100Mbps or 1Gbps (1000Mbps)?
    • If the Arris shows 100Mbps, then replace the Arris
    • If the Arris shows 1Gbps (1000Mbps), then the issue could be:
      • The cable used between the Arris and ASUS
      • Auto-negotiation issue (Consider using different modem. Some ISP will allow you to use your own. I have a Netgear CM600)
      • ASUS WAN port (doubtful)
    LAN3 is 1Gbps which it should. What is plugged into LAN4 as it only shows a 100Mbps connection?
     
  14. Klueless

    Klueless Very Senior Member

    Joined:
    Jan 1, 2016
    Messages:
    532
    Location:
    Rochester, NY
    Are you implying it used to work properly before you updated the firmware?
     
  15. wouterv

    wouterv Very Senior Member

    Joined:
    Aug 4, 2013
    Messages:
    948
    At first, you don't need Merlin firmware to see the port status:
    upload_2019-1-11_19-32-38.png

    Next I suggest to swap the WAN and LAN 3 cables to see if the WAN port goes up to 1 Gbps.
    The WAN port must indicate 1 Gbps, otherwise you will not reach the full subscription speed.
     
    dave14305 likes this.
  16. Klueless

    Klueless Very Senior Member

    Joined:
    Jan 1, 2016
    Messages:
    532
    Location:
    Rochester, NY
    Since the OP was happy with 100 Mbps from his modem I'm going to assume his subscription rate is 100 x 10 (until I hear different).
    Until recently providers used to advertise "Speeds up to ..." and then under-delivered. Courts began seeing this as misleading advertising so ... I recently switched to a new ISP. They advertised 100 Mbps but I regularly hit 120! I'm certainly not going to sue for that : -)

    My first thought was to turn off QoS and anything else that might disable hardware acceleration but, hey, at only 100 Mbps that so should not be an issue.

    Intriguing that the PC negotiates 1 Gbps with the Arris but the Asus can only negotiate 100 Mbps with the same Arris? (I thought negotiation issues had been resolved years ago.) I know the OP has already swapped cables but, just for grins, if you're using a CAT5e cable try a CAT6. If you're using a CAT6 then try a CAT5e.

    What I'd really like to do is plug the PC into the WAN port of the Asus but I don't know for sure if they'd "connect" such that I could read the negotiated rate from the PC's side?

    In lieu of that maybe get a cheap (and "dumb") four port Gigabit switch (for about $30). Connect one switch port to the Arris and another switch port to the Asus WAN port. If everything displays gigabit then it was the Arris and Asus mis-negotiating with each other.

    I'm also puzzling; If we were dumping Gigabit into a 100 Mbps pipe I could see some loss but we're only dumping 100 Mbps (Internet) into a 100 Mbps Ethernet line. Wouldn't our speeds be a lot closer to 90/95 than 50?

    If neither swapping out (CAT5e/CAT6) cables or adding the switch doesn't fix the problem I'm going to vote faulty WAN port on the Asus.
     
    Last edited: Jan 11, 2019
  17. vespid

    vespid New Around Here

    Joined:
    Oct 10, 2018
    Messages:
    6
    Ok folks, I decided to start out with the simpler options first so I swapped out the yellow cable between the modem and router and that fixed it! I had tried it long ago with a different cable, but that didn't fix it, but a new cable I just got my hands on solved it.

    upload_2019-1-13_13-56-41.png

    It still doesn't make much since to me, but the proof is in the result. Thanks a lot for your time, folks!

    vespid
     
    wouterv likes this.