RT-AC68U won’t update

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Nosh118

New Around Here
Hi there.
So I have an RT-AC68U and recently I’ve been having troubles with intermittent connection while running it in repeater mode to my Orbi system (as there is one room in my house that is a complete dead zone).
To try and solve this, I thought I’d try to update the firmware. I’m running version 384.6 and the first thing I tried to do is upload the most recent update, 384.19. The router UI accepts the file, and the percentage bar goes up, until it says completed. The page then refreshes but the firmware version number is still 384.6. I have tried rebooting, factory resetting and the version still stays the same. Naturally, I thought it might be too big of a gap to jump, so I tried simply upgrading to 384.7. That was a no go, with the exact same thing happening and no change to the firmware version. I even tried Asus’ most recent official firmware and couldn’t get anywhere (same results). Any advice would be greatly appreciated.
 

atkinsom

Regular Contributor
Pull out any USB drives you have attached before starting any firmware updates. After pulling them out do a reboot for good measure before attempting the update.
 

Nasua

Occasional Visitor
Are you sure it is an RT-AC68U and not a converted TM-AC1900 ?
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top