RT-AC86U @ 386.2: Speed test fails when modem in bridge mode

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

spry107

New Around Here
Initially, I've configured RT-AC86U (192.168.2.1) to ignore DNS provided by the ISP router/modem, and it works ok with 1.1.1.1 and 8.8.8.8, likewise "nslookup google.com 192.168.2.1" works fine. Yet when I switch ISP router/modem into bridge mode (and RT-AC86U gets public IP on WAN), "nslookup google.com 192.168.2.1" breaks, while querying 1.1.1.1 still works. Likewise, internet works but Speedtest even resolves list of servers to connect to with a significant delay. It would seem that DNS server on RT-AC86U just stops working when ISP router/modem is in bridge mode.
 

ColinTaylor

Part of the Furniture
Change your router's WAN DNS setting back to automatic and see if that makes a difference.
 

spry107

New Around Here
Tried that, the behavior does not change. The ISP DNS is usable directly in all cases, so I’m really out of ideas why 192.168.2.1 dns can go down as it’s just not there
 

ColinTaylor

Part of the Furniture
Any other changes to the WAN settings page from the default?

Do you have "Enable WAN down browser redirect notice" = Yes in Administration > System?
 

spry107

New Around Here
WAN has everything by default, and "Enable WAN down browser redirect notice" is set to "Yes"
 

spry107

New Around Here
Did that, does not help. Whenever I switch ISP router/modem to bridge mode, I'm starting to get this:

nslookup google.com 192.168.2.1
;; connection timed out; no servers could be reached


And Speedtest on RT-AC86U stops working with a "Failed to complete the Internet speed test. Please check your Internet status at Network Map for more information and try again later." but for sure I can access the internet at the same time.

How to debug this?
 

spry107

New Around Here
Interesting observation: when I switch to bridge mode, and RT-AC86U gets DHCP lease, trying to ping 1.1.1.1 or 8.8.8.8 from RT-AC86U stops working, while the "non-interrupted" ping from the laptop to same 1.1.1.1 or 8.8.8.8 continues to work until restarted. Hm, maybe something fishy about routing table...
 

spry107

New Around Here
But I'm still able to post :) So it means TCP is unaffected (or it seems so), ICMP goes crazy. Another wild observation that randomly, pings start going through but relaunching ping (all via SSH from AC86U) does not succeed. I'm starting to suspect that it's the ISP router/modem but I can not confirm since I don't have ethernet port elsewhere than AC86U,
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top