RT-AC86U Poor Wireless Speed - 160MHz doesn't work

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

James

New Around Here
Hi,

I received a new RT-AC86U router yesterday - I'm struggling to get it set up correctly. I'm hoping someone can help.

I'm testing speeds using netio-gui application. I have a server (actually a laptop) with a USB gigabit NIC connected. As a baseline, I connected my primary laptop via ethernet and tested - I got a throughput of around 900mbps.

The best I'm seeing with wifi on my laptop is around 350mbps - way short of what I believe it should be. My laptop is a Dell XPS 17 9700 with a Killer AX1650s wifi module.

I managed to get the throughput to go up to around 450mbps (with a link speed of 2400mbps) by enabling 160MHz mode on the router. However, something got messed up with the settings. I did a factory reset - now 160MHz doesn't work anymore.

With the router set to 80MHz only, it works, but is limited to 1200mbps link speed, and around 350mbps throughout.
With the router set to 160MHz, I simply don't see the wifi connection advertised. I've checked this on both my laptop and my phone - it's just not there for me to connect to.

I've tried resetting to factory defaults a couple of times - to no avail.

All of this testing has been done with my laptop plugged in, 2 metres away from the router. We live in a remote area - there is no interference from outside.

I bought this router as an upgrade from my AC router - currently it offers absolutely no benefit and I may as well have not bothered spending money on it!

Can anyone suggest anything that I should be looking at to sort it? I was expecting throughout in the order of 800-900mbps as all the reviews say I should get!

Thanks
 

James

New Around Here
Update:

I read a post on here saying that you may need to wait a while after making channel changes on 5GHz due to changes for RADAR.

I changed the channel for 5GHz to 36, with 160MHz width. I'm not connected to it. My link speed is 2,400mbps, but the throughput I'm seeing is limited to 350mbps to 450mbps. It works, but it's only half the speed of what I expected.

What other settings should I look at to speed it up?

Thanks
 

leerees

Senior Member
Might be an idea to send it back and get an AX router. Asus have many and this should solve your throughput issue. Your Dell XPS supports WiFi 6.
 

James

New Around Here
How embarrassing! I put the wrong product code in the header sorry.

I have an RT-AX86U. Not the AC.

It's connecting at 2400mbls link speed, but the throughput isn't what I would expect.

Thanks
 

L&LD

Part of the Furniture
Remove the killer software and install Intel drivers instead.
 

airgap

Regular Contributor
James...it's not always garanteed that you will get that specific speed which is written on the ad :)

There have to be a lot of things in perfect synergy to achieve almost those speeds.

Besides that WiFi has some limitation and there things like "air-time" or "channel overlap" (if you share the same channel with others in your neighbourhood) etc.

Did you speed test with iperf3 from your Router directly to your laptop or how did you meassure it?

By the way: Often it's related to your client device - in your case your laptop wifi module. Probably drivers AND the settings in the advanced adapter settings for your wifi.

Check if there are settings for MIMO or BEAMING or "BOOST" etc. settings will improve the performance and may be switch entirely to 5GHz instead of 2.4GHz. That might help also.
 

leerees

Senior Member
Remove the killer software and install Intel drivers instead
I'm confused here. Why would intel drivers work for a killer WiFi adaptor? Is killer part of intel?
 

L&LD

Part of the Furniture
The hardware is Intel, the drivers (killer) are garbage.
 

thiggins

Mr. Easy
Staff member

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top