1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT-AC86U with Zabbix agent?

Discussion in 'Asuswrt-Merlin' started by Markfree, May 24, 2020.

  1. Markfree

    Markfree Regular Contributor

    Joined:
    Feb 13, 2016
    Messages:
    51
    Have anyone tried using Zabbix Agent on AC86U router?

    If we search for Zabbix, Opkg finds some packages.
    Code:
    # opkg find *zabbix*
    zabbix-agentd - 4.0.16-3 - Zabbix agentd
    zabbix-get - 4.0.16-3 - Zabbix get
    zabbix-proxy - 4.0.16-3 - Zabbix proxy
    zabbix-sender - 4.0.16-3 - Zabbix sender
    zabbix-server - 4.0.16-3 - Zabbix server
    So, I tried installing Zabbix Agent.
    Code:
    # opkg install zabbix-agentd
    Installing zabbix-agentd (4.0.16-3) to root...
    Downloading https://bin.entware.net/aarch64-k3.10/zabbix-agentd_4.0.16-3_aarch64-3.10.ipk
    Configuring zabbix-agentd.
    So far so good. I can even test some items.
    Code:
    # zabbix_agentd -t system.hostname
    system.hostname                               [s|<correct_hostname>]
    But when I check for open ports, I can not find port 10050 (standard) open.

    Actually, when I try to run, it tells me I should have a zabbix user.
    Code:
    # zabbix_agentd -f -c /opt/etc/zabbix_agentd.conf
    zabbix_agentd [12022]: user zabbix does not exist
    zabbix_agentd [12022]: cannot run as root!
    I created a user Zabbix using USB Application interface and now it seems to work.
    Code:
    # zabbix_agentd -f -c /opt/etc/zabbix_agentd.conf
    Starting Zabbix Agent [hostname]. Zabbix 4.0.16 (revision 9377bec666).
    Press Ctrl+C to exit.
    Also, my Zabbix server is able to check some items.

    But, as you can see, it is running on the foreground.

    So I started it on background.
    Code:
    zabbix_agentd -c /opt/etc/zabbix_agentd.conf
    I don't know if there is something else to do.
    Have anyone tried?
    Thanks
     
    Last edited: May 25, 2020