RT-AC88U - AP isolation keeps activating

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Ganfoud

Occasional Visitor
Hi
I have an issue with my RT-AC88U : after a while (less than 24 hours) the WiFi connected devices are not able to see each other (no answer to ping/no route to host when trying to SSH in/ERR_ADDRESS_UNREACHABLE in chrome)
I have no issue if I try from a wired connected device

AP isolation is off for both bands
If I turn AP isolation on and off again, it works for a while and then not anymore
Same if I reboot
I tried a factory reset and the same happens

I am out of options, do you have any idea?
 

L&LD

Part of the Furniture
Welcome to the forums @Ganfoud.

After the factory reset (which method did you use?), did you use an old, saved backup config file to configure the router? If so, you negated the reset.

Have you tried using a different SSID? One that has 8 alphanumeric characters, no punctuation, no spaces or smiley faces, and which has never been used/seen by your client devices before? You can use a Guest network to test for this.

Or try resetting (fully) the network settings of the client devices in question?
 

Ganfoud

Occasional Visitor
thanks for your answer
i did the factory reset via the web UI and I saved/restored the config via the nvram utility on a usb stick, which I understood is ok
I am currently trying a different SSID, I'll see the results tomorrow

and I did reset the settings on some devices (a Raspberry Pi and a canon printer) but without success...
 

L&LD

Part of the Furniture
If you restored your configuration, you're also restoring the (possible) bugs/interactions too.
 

Ganfoud

Occasional Visitor
ok, I tried doing a factory reset and did all the settings manually instead of restoring the backup, and the issue is appearing again
any other idea?
 

JWoo

Senior Member
Is this happening on a guest network?
 

ColinTaylor

Part of the Furniture
If I turn AP isolation on and off again, it works for a while and then not anymore
Same if I reboot
Changing the AP isolation setting, or any other WiFi setting, causes the entire WiFi service the be restarted, just like a reboot. So your problem is not necessarily related to that particular setting.

Try investigating some of the more general recommendations regarding WiFi problems, e.g. turn off Protected Management Frames, Airtime Fairness and Universal Beamforming.
 

Ganfoud

Occasional Visitor
Hi
I did try this before the factory reset and it didn't change anything
I just turned all these off, let's see if it works...
 

ColinTaylor

Part of the Furniture
Hmmm... Looks like I might have a similar problem but only on the 5GHz band. Is your problem also only with 5GHz?

Can you ssh into your router and post the output of these commands:
Code:
nvram show | grep isolate | sort
wl -i eth1 ap_isolate
wl -i eth2 ap_isolate
 

Ganfoud

Occasional Visitor
no, the issue happens when connected either on 2.4 or 5 GHz

Bash:
nvram show | grep isolate | sort

wl0.1_ap_isolate=1
wl0.2_ap_isolate=0
wl0.3_ap_isolate=0
wl0.4_ap_isolate=0
wl0_ap_isolate=0
wl1.1_ap_isolate=0
wl1.2_ap_isolate=0
wl1.3_ap_isolate=0
wl1.4_ap_isolate=0
wl1_ap_isolate=0
wl_ap_isolate=0
Code:
wl -i eth1 ap_isolate
1
Code:
wl -i eth2 ap_isolate
1
 
Last edited:

ColinTaylor

Part of the Furniture
These isolation issues never seem to get resolved. Here's one example: http://www.snbforums.com/threads/gu...-and-a-potential-workaround.68307/post-640784

So even though your nvram variables would indicate that isolation is off for all WiFi apart from the first 2.4GHz guest network, the output from the WiFi driver would indicate otherwise.

Try manually turning the isolation off for each of the primary WiFi networks:
Code:
wl -i eth1 ap_isolate 0
wl -i eth2 ap_isolate 0
and then check whether it's actually done anything:
Code:
wl -i eth1 ap_isolate
wl -i eth2 ap_isolate
Making any WiFi changes in the GUI of restarting the router will obviously revert these changes.
 

Ganfoud

Occasional Visitor
Ok I just did and the output of both commands is still 1
I still cannot access the other wireless devices, I just did a service restart_wireless, let's see if it works

And yes I've seen that it seems to be a very annoying issue!
I guess the workaround could be to put a restart_wireless in the cron but it is not very satisfying...
 

john9527

Part of the Furniture
IIRC the forced AP isolate was in the GUI code for 'Alexa' enabled routers. I'll try and check it again later today.
 

Ganfoud

Occasional Visitor
Just a detail: I talk of AP isolation because I don't see what could cause wireless devices to be unreachable from another wireless device whereas wired devices can reach them, however I am not 100% sure that this is the root of the issue!
 

ColinTaylor

Part of the Furniture
Hmmm... Looks like I might have a similar problem but only on the 5GHz band. Is your problem also only with 5GHz?
OK. For my router, which is a completely different platform, isolation does appear to be working when changed through the GUI. It's just that the wl -i eth7 isolate command doesn't do anything or return a meaningful result. 2.4GHz (eth6) works as expected though.
 

john9527

Part of the Furniture
IIRC the forced AP isolate was in the GUI code for 'Alexa' enabled routers. I'll try and check it again later today.
Checked...code is still there for guest networks if you enter the guest gui. If lan_access is disabled it will also force ap_isolate to be set.....
Code:
        if(amesh_support && amesh_wgn_support){
            $("input[name='wl_ap_isolate']").attr("disabled", false);
            var wl_ap_isolate = ($("select[name='wl_lanaccess']").val() == "off") ? 1 : 0;
            $("input[name='wl_ap_isolate']").val(wl_ap_isolate);
        }
 

Ganfoud

Occasional Visitor
I am not sure what it implies? Does it mean that if you activate the AP isolation for the guest network, it will activate it for all networks?
 

john9527

Part of the Furniture
I am not sure what it implies? Does it mean that if you activate the AP isolation for the guest network, it will activate it for all networks?
No, it means on the selected guest network if you disable intranet access, it will also automatically set AP isolation.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top