RT-AC88U loses internet after reboot, have to reboot modem

FranticOrange

New Around Here
Hi all, and Happy New Year.

I'm hoping someone can help me.

I recently upgraded my router (Asus RT-AC88U) to 386.3_2 and started to experience an odd issue at around the same time. I've lived with it hoping that upgrading to 386.4 might resolve it, but no such luck. I have reset to factory defaults several times (using both the WPS method and the web UI method), but the issue remains.

Whenever I reboot my router, it loses the connection to the internet via the modem with the message "Your ISP's DHCP isn't functioning properly". Rebooting the modem then resolves the issue but that's not a workable solution for me as I have the router scheduled to reboot every week.

I'm in the UK, my ISP is TalkTalk and the modem is a SAGEMCOM FAST 5364. A network cable is connected from the WAN port of the router to the LAN1 port on the modem. I have the modem's IP address set to 192.168.2.1 and DHCP is set to issue IP addresses in the 192.168.2.10 to .254 range with a subnet mask of 255.255.255.0. The router's IP address is the default 192.168.1.1. Note that nothing is physically connected to the modem other than the router, WiFi is disabled on the modem and all of the devices in my home use WiFi through the router.

After a router reboot and the problem occurs, for diagnostic purposes, I can unplug the network cable from the router and plug it into a laptop and can see that the modem issues me a valid 192.168.2.x IP address and the laptop has internet access. Out of interest, then plugging the cable back in to the router does not force the modem to issue a new IP address.

My setup isn't new and has been working fine for a couple of years until the 386.3_2 upgrade.

Can any of the experts here offer me any guidance please?

Thank you.
 

ColinTaylor

Part of the Furniture
Out of interest, then plugging the cable back in to the router does not force the modem to issue a new IP address.
Do you mean that it doesn't issue any IP address at all (i.e. it doesn't detect the connection), or that it issues the same IP address it had previously?

Try changing WAN > Internet Connection > Special Requirement from ISP > DHCP query frequency to Continuous Mode.
 

FranticOrange

New Around Here
Do you mean that it doesn't issue any IP address at all (i.e. it doesn't detect the connection), or that it issues the same IP address it had previously?

Try changing WAN > Internet Connection > Special Requirement from ISP > DHCP query frequency to Continuous Mode.
It continues to display the "Your ISP's DHCP isn't functioning properly" message rather than displaying any IP address that may have been issued by the modem to the router. I suppose I could get the router into the "bad state" and then connect a laptop directly to the modem and view the attached clients list to see if it thinks it's actually issued an IP address to the router, if that would help.

I've changed the DHCP query frequency to Continuous Mode, which didn't appear to make any difference. I also restarted the router with that setting in place, which also didn't change anything. I also switched "Internet Connection" off in the router settings for a few seconds, then switched it back on again thinking that might force the router to realise that there really is an internet connection, but no difference. It seems that only a restart of the modem has any effect.
 

ColinTaylor

Part of the Furniture
Strange. I suppose there could be something odd about the Sagemcom's DHCP server. You could try ignoring DHCP and setting the router's WAN Connection Type to Static IP with an address of 192.168.2.2.
 

FranticOrange

New Around Here
Strange. I suppose there could be something odd about the Sagemcom's DHCP server. You could try ignoring DHCP and setting the router's WAN Connection Type to Static IP with an address of 192.168.2.2.
Thanks for the suggestion. I've just tried this and whilst it removes the error message and displays the IP address along with "Internet status: Connected", there still seems to be no internet access until I restart the modem.

I'm quickly running out of ideas...
 

FranticOrange

New Around Here
My apologies - my previous post was incorrect. It displays the IP address for a fraction of a second and then shows "Internet status: Disconnected". However, the internet light on the router is white (normal) rather than red (error).
 

ColinTaylor

Part of the Furniture
Can you unplug the cable from the router's WAN socket, wait 60 seconds, then plug it back in and wait another 60 seconds. Post the contents of the router's System Log.
 

FranticOrange

New Around Here
Note that the router/connection was in a "good state" when I did this as I'd just restarted the modem. Plugging the cable back in, as per the above, created the "bad state" that I'm experiencing.

Log attached.
 

Attachments

  • syslog.jpg
    syslog.jpg
    138.8 KB · Views: 40

ColinTaylor

Part of the Furniture
Hmm. From the log it looks like everything worked properly.

Are there any access controls in the modem's config that might be blocking the router's connection?

Random things to try:

1. Clone the MAC address of your PC (WAN - Internet Connection > MAC Address) and then power cycle both the modem and the router.

2. The WAN socket may be faulty. Reassign one of the LAN ports as the WAN and plug into that instead. WAN - Dual WAN > Enable Dual WAN > Primary WAN > Ethernet LAN
 

FranticOrange

New Around Here
The kids are back home now and I'll only get complaints if I continue with the analysis today! :confused:

Thanks again for the suggestions and for your help - I'll try those out tomorrow and will report back here with the results.
 

FranticOrange

New Around Here
So I found time to try the above suggestions.

Cloning the MAC address, applying, and then restarting the router made no difference to my problem.

Reassigning the WAN port to LAN1 and applying automatically restarted the router, and I still get the same message "Your ISP's DHCP does not function properly". Note that this is still with a static IP address allocated to the router.

Again, restarting the modem resolves the issue, despite it never actually dropping the connection to the ISP.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top