1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT-AC88U went dark on me

Discussion in 'ASUS N Routers & Adapters' started by Cliff Poe, Sep 29, 2018.

  1. Cliff Poe

    Cliff Poe New Around Here

    Joined:
    Sep 29, 2018
    Messages:
    2
    I noticed this AM my RT-AC88U has NO lights on. All lights off. This is not something I did.

    It's working and everyone can connect and the SSID is showing up, but all lights are off.

    I've googled stealth mode, but there is no Tools option in my firmware version 3.0.0.4.384_32799

    Can anyone assist me with getting the lights back on?

    Thanks

    Cliff
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. Kal-EL

    Kal-EL Very Senior Member

    Joined:
    Aug 15, 2013
    Messages:
    1,437
    Location:
    Motor City, Michigan-USA
    I believe on the 88 there is a button to turn the lights off. Try the front of the router on the right side there are two push button switches.
     
  4. Cliff Poe

    Cliff Poe New Around Here

    Joined:
    Sep 29, 2018
    Messages:
    2
    Wow! Superman answered my question! I like this forum!
     
  5. Kal-EL

    Kal-EL Very Senior Member

    Joined:
    Aug 15, 2013
    Messages:
    1,437
    Location:
    Motor City, Michigan-USA
    LOL Glad your lit up again. :D
     
  6. Xentrk

    Xentrk Very Senior Member

    Joined:
    Jul 21, 2016
    Messages:
    1,630
    Location:
    The Land of Smiles
    I turned off WiFi by mistake when moving the router for cleaning one time. I had pressed the WiFi button next to the LED button on the right front panel. Probably not the best location for the buttons and the engraved labels being black on black make the buttons hard to read. Took a minute or two to realize what caused the outage.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!