RT-AC88U went from 800Mbps to 520Mbps with Cox Gigablast

TimRedBeard

New Around Here
My current setup is a Netgear CM1200 Modem with Cox Gigablast and I'm running a RT-AC88U with Asuswrt-Merlin 384.19. I was having great download speed between 800-920 down without issues. My upload speeds have been consistent at 35 up. However now I can't get my speeds above 520 down at all. I've done everything I can think of. I've searched the forums and tried every kind of settings that I've found to try and get the best speeds. Does anyone have any suggestions on how to help me get better download speeds?

QoS is off
AiProtection is off
Jumbo Frame - Disabled
NAT Acceleration - Auto (CTF is enabled)
Spanning-Tree Protocol - Enabled
Link agg - Disabled
Enable WAN - Yes
Enable NAT - Yes
UPnP - No
Connect DNS Server Automatically - Yes

Any help would be great, I don't know what else I can do except reset the router and start fresh. Thank you in advance.
 

L&LD

Part of the Furniture
 

degrub

Very Senior Member
check what the speed is directly connected to the modem to see in which of the two the problem lies.
 

pencilhead

New Around Here
Turn off spanning tree unless you have bonded links or something like a NAS with 2 interfaces. Link agg is off. It's not needed for single connected devices where there is no chance of a loop.
 

ddaenen1

Senior Member
My current setup is a Netgear CM1200 Modem with Cox Gigablast and I'm running a RT-AC88U with Asuswrt-Merlin 384.19. I was having great download speed between 800-920 down without issues. My upload speeds have been consistent at 35 up. However now I can't get my speeds above 520 down at all. I've done everything I can think of. I've searched the forums and tried every kind of settings that I've found to try and get the best speeds. Does anyone have any suggestions on how to help me get better download speeds?

QoS is off
AiProtection is off
Jumbo Frame - Disabled
NAT Acceleration - Auto (CTF is enabled)
Spanning-Tree Protocol - Enabled
Link agg - Disabled
Enable WAN - Yes
Enable NAT - Yes
UPnP - No
Connect DNS Server Automatically - Yes

Any help would be great, I don't know what else I can do except reset the router and start fresh. Thank you in advance.
So this happened overnight, without any changes to hardware or provider, right? I would have done a reboot already. When i owned an AC88u, this was my first remedy. Pull out the power supply plug, wait 30 seconds and plug it back in. It was the fix for most issues. Also the reason why it is gone now.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top