What's new

RT-AX56U - Can't access USB drive from Windows

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hello everyone,

I've been racking my brain trying to figure out why my USB device that worked without issue with my old Nighthawk R7000 suddenly doesn't with this new router.

I've configured it to have a name and is on the same workgroup. I've tried logging in with my admin account and the default admin:admin with no luck. I've tried various other drives and again, windows can see them, but can't access them.

This is the error I get:


These are the settings on the SMB page:


Anyone have some tips? I've tried formatting the drive FAT32, NTFS, and exFAT. All have the same result.


New Around Here
Can you ping "MEDIA"?


C:\Users\peter>ping media

Pinging media.router.peter [] with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms



Part of the Furniture
Side note: Change "Simpler share naming" to Yes.

Can you try accessing it by IP address, e.g.


Also try putting in the name of one of the shared folders (not shown in your screenshot), e.g.



Regular Contributor
Hmm, I had this last summer on an RT-AC88U just after I upgraded from 384.11_2 to 384.12 in this thread https://www.snbforums.com/threads/384-12-smb-share-name.57389/#post-502586
There were quite a few changes to WDS in that release I think, but not sure exactly what stopped it working after the upgrade.
I think in summary setting a domain name to anything in Advanced Settings > LAN > LAN IP page got mine to work.
I only have SMBv2 set and just type the network name as I'm not bothered about using the network view in explorer.
I see you don't have guest access on - I use the same username/password on my login as I've set in the Samba settings as WIndows tried your creds first I think. Obviously you could just type them in the first time connecting and I think Windows remembers them.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!