RT-AX56U: Speed tests = perfect; actual performance = unusable

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

twinreverb

New Around Here
This is puzzling. I purchased the Asus RT-AX56U in hopes of upgrading an aging but reliable 802.11n router.

Set up the Asus, ran the usual speed tests, and everything looked great: 5GHz devices pulling 120 Mbps on my 100Mbs plan, which was a nice boost over the old router. 2.4GHz devices pulled around 40-70 Mbps down, which was about in line with the old router or maybe a bit better. Uploads were around 5-6 Mbps on everything, which is consistent with the old router.

However, I soon discovered that the real world performance was terrible on all of the 2.4GHz devices: general web browsing was sluggish; Youtube videos would choke and buffer forever; Twitch streams were impossible to watch, with freezing/buffering every 2-3 seconds. Immediately tried the speed tests again, and they appeared normal. Went back to the streams, couldn't manage even 480p.

Checking out Asus' traffic monitor, I fired up a Twitch stream: the data initially spiked above 40+ Mbps for a second or two, then quickly got choppy and dropped off to sub 1Mbps for the remainder. As if something was throttling the bandwidth down to near zero. All of this while sitting five feet from the router, line of sight, signal strength good, channel clear. Doesn't seem to be a matter of interference. Any QoS settings, parental controls, etc. are switched off. Cloudflare DNS, Google DNS, no change. I attempted to replicate my settings from the old router, but nothing helped.

After a week of setting after setting, reboot after reboot, I got to thinking it's defective router, and decided to try a "simpler" unit; a TP-Link AX21. To my horror, it exhibited the exact same behavior as the Asus.

There are less options to deal with on the TP-Link, but no combination of settings seemed to improve the situation. Running low on ideas, I set up a 2.4Ghz guest network and connected to it. As if by magic, everything worked perfectly! Performance snappy again, can stream all day without a hiccup. Go back to the main 2.4Ghz network, and it's unusable. Back onto the guest network, and there's no problem whatsoever.

Out of curiosity, I decided to try the Asus again. Set up a 2.4Ghz guest network on it, connected, and everything worked perfectly. Main 2.4Ghz network remains unusable.

How is this even possible? Silly me thought the guest network inherited the same settings from the main network, but apparently that's not the case. I think I can live with this workaround, but I'd still like to figure out what the deal is.

So I guess my question is: what settings might a guest network ignore or do differently from the main network, such that it could correct the problem I've described?
 

bbunge

Part of the Furniture
Possible your clients do not like WIFI 6?
If you are using WPA2/WPA3 drop back to just WPA2. Keep your SSID and passphrase simple (letters and numbers only).
Use Dual Band SmartConnect.
5 GHz at 80 MHz on channel 36 or 149. Avoid DFS channels if possible.
2.4 GHz at 20 MHz on channel 1, 6 or 11
Disable Airtime Fairness.
 

Volt

Regular Contributor
A guest network isolates clients from your private network, so one of the possibilities might be that some client is flooding your network with packets that affect other clients connected to 2.4. When you use a guest network, packets from your private network do not reach devices connected to the guest network and, thus, do not affect their performance, but it's just a guess. Did you try connecting clients one by one?
 

twinreverb

New Around Here
Possible your clients do not like WIFI 6?
If you are using WPA2/WPA3 drop back to just WPA2. Keep your SSID and passphrase simple (letters and numbers only).
Use Dual Band SmartConnect.
5 GHz at 80 MHz on channel 36 or 149. Avoid DFS channels if possible.
2.4 GHz at 20 MHz on channel 1, 6 or 11
Disable Airtime Fairness.
Thanks, but no noticeable difference using these settings. WiFi 6 or not, the router is supposed to be backwards compatible, right? It's only the legacy devices that are having issues.

What firmware version are you running?
3.0.0.4.386.44266
 

L&LD

Part of the Furniture
Good enough reason for me to drop all the 'legacy' devices.
 

twinreverb

New Around Here
A guest network isolates clients from your private network, so one of the possibilities might be that some client is flooding your network with packets that affect other clients connected to 2.4. When you use a guest network, packets from your private network do not reach devices connected to the guest network and, thus, do not affect their performance, but it's just a guess. Did you try connecting clients one by one?
That makes sense, but I don't think it's the case here.

I have tried connecting one by one. Most of my troubleshooting has been done with just a desktop PC hardwired to the router, and a laptop to test the wifi. Nothing else connected.
 

Volt

Regular Contributor
To be clear, if you disconnect the desktop and leave only the laptop connected, does the problem persist? In general, I think that the router is not the cause of the problem, since you had the same issue with another router. It is either your clients or, theoretically, channel congestion (it may be a coincidence that when you enabled the guest network, the router accidentally selected a better channel). I don't know what else to advise. :(
 

twinreverb

New Around Here
To be clear, if you disconnect the desktop and leave only the laptop connected, does the problem persist?
Yes. With the laptop as the one and only device connected to the network, the problem persists.

In general, I think that the router is not the cause of the problem, since you had the same issue with another router.
It is either your clients or, theoretically, channel congestion (it may be a coincidence that when you enabled the guest network, the router accidentally selected a better channel). I don't know what else to advise. :(
The router is on a fixed channel. I can jump back and forth between the main and guest network, but only the guest network provides usable speeds.

Thanks for trying.

This blog post describes a problem very similar to what I'm experiencing. The author claims it was (mostly) corrected in a firmware update from Asus.
 

Thornado

Occasional Visitor
Thanks, but no noticeable difference using these settings. WiFi 6 or not, the router is supposed to be backwards compatible, right? It's only the legacy devices that are having issues.


3.0.0.4.386.44266
Version 3.0.0.4.386.44266 is not a stable release. I was experiencing connectivity issues, especially with 2.4 Ghz devices.

Try to rollback to Version 3.0.0.4.386.42808, which is the latest stable release.

Recommended channels:
5 Ghz = 132
2.4 Ghz = 6
 

Igs

New Around Here
I bought a very similar router (ax58). First thing I did was upgrading the software before connecting my devices. Then I connected my Sonos speakers which are 2.4Ghz. And that was a nightmare. They didnt want to add! Or, at some point, they were added, but then dropped again.

So i checked Sonos forums and there were dozens of ineffective advices, but one guy had a solution. He said: "Please reset the router after the router update. Some Asus routers have issues and that would be fixed after the reset."

This worked! Remember, you have to reset after updating the router!
 

Easy Rhino

Senior Member
he wait is the problem only in 2.4ghz?

how congested is your airspace? At my in-laws apartment, there are so many wifi units nearby that 2.4ghz is literally unusable even when adjacent to the router. It's not an Asus, it's just too crowded of an airspace.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top