RT-AX58U DHCP/IP Issue

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

manicdefender

New Around Here
Hi All.

I'm having a weird issue. When Win 10 gets to the login screen, it takes anywhere from 30-45 seconds for it to realize it's been issued a IP. I get the "limited or no connectivity" icon until finally it picks up it's IP address from the router. The odd thing is it's statically addressed/reserved from the router side so it should be instant. I've even gone as far as reinstalling Windows, latest drivers/BIOS etc. Windows is set to DHCP. Rebooted router etc. No obvious cause. Motherboard is a TUF-B450-PLUS GAMING

Syslog is attached. The one called syslogrebootpc.txt is where I cleared the log and then immediately restarted the PC to see whether anything obvious flagged up straight away. But I'm not sure why it's complaining about Port 3, I only use ports 1 + 2. Port 3 does have a cable in, but nothing plugged on the other end. PC is plugged into Port 1, TP-LINK switch into Port 2.

Any suggestions welcomed.
 

Attachments

  • syslog.txt
    449.1 KB · Views: 30
  • syslogrebootpc.txt
    610 bytes · Views: 36

jimilolo

New Around Here
Have you tried on a different cable?
Have you static IP (no dhcp) address on your computer?
Do you have the current Realtek drivers?
 

manicdefender

New Around Here
Okay, a further update. Tried replacement cable. Also tried a completely different device. I plugged my laptop in via cable and it experiences the same symptoms. On WiFi it gets an IP straight away. Both laptop and PC have the latest drivers from the manufacturer's website. Does not appear to happen if I statically address within Windows. I've also factory reset Merlin and this has made no difference.
 

L&LD

Part of the Furniture
What firmware is the router running?
 

L&LD

Part of the Furniture
Was a full reset to factory defaults performed when flashing RMerlin 384.19_0? Without using a saved backup config file afterward.

Did you try with a different brand of cable? A different LAN Port on the router? Did you test flipping the cable around too (end over end)?

Was this working before you flashed to 384.19_0? From what firmware version did you flash from?

If you have (or haven't) performed the above, you may want to try the following to see if this is a hardware or configuration/cable issue too.

Fully Reset Router and Network
 

manicdefender

New Around Here
If I remember correctly I did a factory reset after flashing Merlin. Didn't use a saved config afterwards (as I know that can cause issues). Yup tried different cable brands and ports. Bare in mind when my laptop is hard wired it does the same thing. That's on a different port. I have also tried flipping the cable.

It was working fine on stock (can't remember what version it came with but I always upgrade stock then flash Merlin, then reset, then configure - It was purchased on 27/11 if that helps narrow it down). It has been working fine up until the last 3-4 weeks or so. It also had a reset today including " Initialize all the settings, and clear all the data log for AiProtection, Traffic Analyzer, and Web History."

I have just tried your steps for resetting it once more, the problem still remains
 

L&LD

Part of the Furniture
By a different Port, I meant on the router too. Was that attempted?
 

cptnoblivious

Regular Contributor
I've had some delays with DHCP addressing using WIFI on my 58U, to the point where sometimes I just switch to a different network (i.e. if 2.4Ghz is acting up, I switch to 5G).
On my android phone I can see it connect, then when it's trying to get a DHCP address it doesn't complete.

Rebooting the router had helped in the past. I'm waiting for the new Merlin version to finish the beta and hoping that something in the update will address the issue. If not, I'm moving DHCP to my Raspberry Pi's.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top