RT-AX86u: eth0 down and back up -> loss of connectivity

Lynx

Senior Member
Why does eth0 going down and then back up again:
Code:
Aug 10 04:38:14 kernel: eth0 (Int switch port: 3) (Logical Port: 3) (phyId: c) Link DOWN.
Aug 10 04:38:17 kernel: eth0 (Int switch port: 3) (Logical Port: 3) (phyId: c) Link Up at 1000 mbps full duplex
not result in a WAN restart / DHCP WAN IP update?
Shouldn't this always cause a WAN restart / DHCP WAN IP update because it is like the WAN cable being disconnected and reconnected?
Background:
I have the following setup:
Asus RT-AX86u (192.168.1.1) -> Huawei B818-263 (192.168.8.1) -> Internet
Every 48 hours my modem loses connection with ISP and regains it again about 2 seconds later, e.g.:
Code:
Aug  7 23:01:27 kernel: eth0 (Int switch port: 3) (Logical Port: 3) (phyId: c) Link DOWN.
Aug  7 23:01:30 kernel: eth0 (Int switch port: 3) (Logical Port: 3) (phyId: c) Link Up at 1000 mbps full duplex
This results in loss of internet connectivity until I manually restart WAN or reboot my router. I have tried setting DHCP mode: continuous (no change). I have also tried setting network detection to both ping and dns (no change).
 

Lynx

Senior Member
I have it set in bridge mode.
I am keen to try to get that to work properly if I can.
I did some testing and it seems if I pull the WAN cable the Asus Router is very slow to detect change and restart the wan. It must be pulled for about > 5 seconds for the Asus Router to restart the wan.
Should not:
Code:
2430 admin     3492 S    /sbin/udhcpc -i eth0 -p /var/run/udhcpc0.pid -s /tmp/udhcpc -t2 -T5 -A160 -O33 -O249
detect eth0 down and then obtian new WAN IP lease when eth0 is back up?
In this connection (no pun intended), I have been looking at:
ifplugd is a Linux daemon which will automatically configure your ethernet device when a cable is plugged in and automatically unconfigure it if the cable is pulled. This is useful on laptops with onboard network adapters, since it will only configure the interface when a cable is really connected.
And also:
 
Last edited:

KevTech

Very Senior Member
You sure that is not from whatever device is plugged into that port going in and out of sleep mode?
I get link down message when my PC goes into sleep mode and link up message when it comes out of sleep mode.
If I turn off the power management setting for my NIC then I do not get those messages as the NIC never powers down so the link never goes down.
 

Lynx

Senior Member
I just updated my post above. I tried physically disconnecting the WAN cable and the problem is that the Asus Router is VERY SLOW to detect this. As in, the cable must be disconnected for something like > 5 seconds before it will restart the wan. It seems like udhcpc will not deconfig upon cable disconnection like dhcpc does.
So the problem seems to be that the modem is operating too quickly - eth0 goes down and back up with about 2 seconds between. And the Asus Router does not detect that.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top