[RT-AX88U] Configuring the router in client mode

Shivang

New Around Here
I am trying to configure the router in client mode. I used the wl command to set the 5GHz interface (eth7 in this case) in client mode and connect to a Netgear RAX80 router. The commands are below:

Code:
wl -i eth7 ap 0
wl -i eth7 scan
wl -i eth7 scanresults //To see the NETGEAR SSID
wl -i eth7 join NETGEAR58-5G
wl -i eth7 bssid
This works fine so far. I can see it's connected as the last command shows the BSSID of the Netgear router.

The problem begins here:

1) It doesn't get assigned an IP. I assign it an IP manually as follows:

Code:
 ifconfig eth7 192.168.1.100
Now the router has an IP 192.168.1.100 for the 5GHz interface (eth7) and 192.168.50.1 for its bridged interface (br0).

NOTE: I assign eth7 192.168.1.100 as the Netgear router has an IP 192.168.1.1

2) I tried pinging the Netgear router but I get no reply. I checked the ARP table and there was no MAC address for the Netgear router. So I manually added an ARP entry.

3) I tried pinging again but still there was no reply. I captured a packet trace to see what was going on and it turned out the Netgear router got the ping request and was sending an ARP request to the Asus router for the IP 192.168.1.100 but it never got a reply.

What could the problem be? Is it the bridged interface being active that causes issues? Can I force the Asus router to reply to the ARP request?

Thanks for reading the huge post. Any suggestions would be appreciated.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top